Problem running satnogs-setup

pi@raspberrypi:~ $ sudo satnogs-setup
Starting Ansible Pull at 2022-10-22 15:59:34
/usr/bin/ansible-pull -d /root/.satnogs/ansible -U librespacefoundation / SatNOGS / satnogs-client-ansible · GitLab -C stable -t satnogs-setup
[WARNING]: Could not match supplied host pattern, ignoring: raspberrypi
localhost | SUCCESS => {
“after”: “e6b68d6755a085f79c6c4697d75b055d3699b36a”,
“before”: “e6b68d6755a085f79c6c4697d75b055d3699b36a”,
“changed”: false,
“remote_url_changed”: false
}
[WARNING]: Could not match supplied host pattern, ignoring: raspberrypi
ERROR! couldn’t resolve module/action ‘ansible.posix.mount’. This often indicates a misspelling, missing collection, or incorrect module path.

The error appears to be in ‘/root/.satnogs/ansible/roles/satnogs_client/tasks/main.yml’: line 138, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

- Restart satnogs-client service
  • name: Use tmpfs for state directory
    ^ here
    Press enter to continue…

Normal this is just a warning, is apart from this message the station run ok?

I have uploaded a new version of Satnogs, and the problem has been fixed.

2 Likes

We are getting the same error when using the command ‘sudo satnogs-setup’. In addition, we couldnt change any configuration settings because of this error. How can we upload the new version of Satnogs to the Raspi4?