No waterfall uploaded from the ground station - possible errors in the initial setup?


#1

Dear SatNOGS community,

My name is Luca and I am a mechanical engineer who recently graduated. I am interrested in getting a functional ground station for satNOGS using a rasperry pi and RTL dongle.

I do not really know if this was already answered anywhere and in that case please accept my apologizes! Also, I am not sure if the problem is Software or Hardware, but I guess it should be software.
I can only include 2 links in my post, so please find all screenshot here below: https://imgur.com/a/8NAEU67

My current setup is the following. I have a pi 3 B running the satNOGS client. My station is up and running and I can schedule passes. Station ID is 449.
Of all the passes that I have done currently, no waterfall/audio/data is being uploaded after the pass. And I ran out of ideas. see this observation for example: https://network.satnogs.org/observations/410622/
Here is however what I found disturbing. I have 3 things.

During the activation of the client, at some point there is a step called : Add archive repositories keys. This step was failed 3 times, then a long error message appeared in red, and the step was tried again 3 times. without success. But the activation of the client still ended and the station was shown as connected to the api. See screenshots on imgur and linked above for more details of the errors.

So I went to the troubleshooting page of the wiki and I try the 2 last steps, which are trying to communicate with the rtl dongle, and to manually decode a fm recording.

For the rtl test, I used the command rtl_test. see results above. Everything seems similar as the troubleshooting page example, except that in my case, “it was saying: lost at least 120 bytes”. However, below, it was saying also: Sample per million lost (minimum): 0. See link above for more details. I do not know how to interpret this 120 bytes being lost. For completeness, this 120 bytes being lost appeared just after starting the test, and not after pressing ctrl-c to stop it.

On to the next test, I tried to “try a manual run of satnogs_fm_demod.py to make sure that works:”
For this, I used following commands:
$ cd /tmp
$ satnogs_fm_demod.py --rx-sdr-device=rtlsdr --rx-freq=444000000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat

This is more concerning, as it tells me that this command is not found: Check screenshots linked above. I checked again, a run it a second time, it did not work.

After this, I installed the satNOGS client again, with updates, and the 3 sames “errors” appeared.

I hope that I did a stupid mistake somewhere, even though I would be really sorry to steal your time for a stupid mistake. Please let me know if you have any idea on how I can resolve the problem, or simply continuing the troubleshooting.

Thank you for your help!
Luca


#2

Please try an observation with either an FM or CW transponder that is known to work.
You could use e.g. one of the XW2 sats to test! :slight_smile:


#3

Hello!

Thank you for your fast reply. I have scheduled for the 24 hours 7 passes of the satellite that you suggested me, including SAUDISAT 1C, LILACSAT 2, XW-2E and XW-2B. I will try to see if other satellite from XW-2 give good passes in the next night and so add more try.

However, I do not understand why this could help me. In fact I have the feeling that event if it was an issue that the signal is too weak or not visible for any reason, I should still get a waterfall (unicolor waterfall, but still a waterfall, no?).

I will anyway comment here as soon as some observations will have been made.
Thank you!
Luca


#4

The decoder might have failed…


#5

In you first screenshot, it shows that satnogs-radio is not installed due to an error. This is why you haven’t installed gr-satnogs package, which means no gnuradio scripts, waterfalls, audio etc etc…

There is this thread “Installing latest builds - Setup Update Failure” from a user that has the same issue with you. I hope this will help, let us know if you need more help!


#6

Thanks to both of you!
So indeed I can confirm that none of the passes with FM or CW worked. Still no waterfall was uploaded to the database.

Fredy, thank you for this great link, I found out a lot of useful information, however I was not able to solve the issue, due to my lack of technical knowledge.

First thing I tried is to change the port trough which the key are “read”. I used this trick suggests in the other post:

I edited the file via the terminal and changed the url as said. It did not work, however with the file updated, the time for 1 try was much longer. To explain myself, the program tries to add the keys 3 times before showing an error in red. The time between 2 trials was much longer than before (going to 45sec before, up to 3-5 minutes with the edited file). Picture here: https://imgur.com/a/qcBbb5N

Unfortunately this was the only option of the other thread that I could understand completely (and so was able to perform).

I did try this one.

However it did not work, and I am sure that is due to my lack of knowledge in linux.

My next idea was to open port 11371 of my router, which I had no time to do yesterday. but I am a bit pessimistic about the result. Did I miss something important from the other port? Is there anything else I should try/do?

Thank you for your great help, I appreciated it.
Cheers,
Luca


#7

:frowning:

Have you run these commands as root? You can either run sudo su - for being root and then run the commands, or you can add sudo in front of both the commands.

Just in case you are not familiar with it, this is also known as port forwarding.


#8

Dear all!

Thank you very much for your help! I did solve my problem !

The issue was indeed coming from one of the key being expired and I had to rerun the above mentionned commands with sudo in front. One of the command containing a "blabla | blabla "did not work so I had to split it in two. Here is the chain of commands used to solve my issue:

  1. $ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8B48AD6246925553
  2. $ sudo wget -O - https://ftp-master.debian.org/keys/archive-key-7.0.asc
  3. $ sudo apt-key add archive-key-7.0.asc
  4. $ sudo apt update
  5. $ sudo satnogs-setup
  6. Update
  7. reboot the pi ($ sudo reboot)
  8. $ sudo satnogs-setup
  9. Apply
  10. reboot the pi ($ sudo reboot)

And all my problems were solved! My station was delivering data to the database. No need to forward of port in the end.

The next step was to find the optimum gain for my setup, and it seems that I have to set it quite high to get a good signal. I received signals from ESEO, the ISS, the NOAA and some other satellites. I am happy about it :slight_smile:. However I am not sure how to find the optimum gain, I guess that I will just remain close to the value I have now, since it is giving me good results.

Thank you everybody for your excellent support!

Kinds Regards,
Luca


#9

What you might have missed:

  1. $ sudo apt update
  2. $ sudo satnogs-setup
  3. Update
  4. Apply(!)
  5. Exit
  6. $ sudo reboot

#10

I do agree that a $ sudo apt update is mandatory at stage 4, and that a reboot at the end is always good, so I have added them and edited my last post, thank you for the corrections!

However, according to that wiki page, it is recommended to do a reboot after the update! But I do not think that this is very big deal in the end.
https://wiki.satnogs.org/Omnidirectional_Station_How_To#Configuring_the_satnogs-client


#11

It is wrong! The Apply has to be done after the Update!