Station doesn't work after update

Updated station to Buster, then reinstalled satnogs station x 3
it works but no waterfall or date is recorded anyone help?
rtl-sdr dongle works on laptop with sdr# ,

see report below and rtl_test
anyone help ?

Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004012056”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1-1”,
“gr-soapy”: “2.1.2-1”,
“gnuradio”: “3.8.0.0-6”,
“satnogs-config”: “0.10”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “satnogs”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 971059200,
“available”: 790810624,
“percent”: 18.6,
“used”: 109879296,
“free”: 401272832,
“active”: 310071296,
“inactive”: 174682112,
“buffers”: 33742848,
“cached”: 426164224,
“shared”: 6479872,
“slab”: 63881216
},
“disk”: {
“total”: 14978719744,
“used”: 3343458304,
“free”: 10979291136,
“percent”: 23.3
}
},
“configuration”: {
“satnogs_antenna”: “rx”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rf_gain”: “11”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “125”,
“satnogs_station_id”: “657”,
“satnogs_station_lat”: “-40.938”,
“satnogs_station_lon”: “175.679”
}
}
------------[ copy end ]-------------

Press Enter to continue…

rtl_ test shows
pi@satnogs:~ $ rtl_test
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode…
Allocating 15 zero-copy buffers
lost at least 120 bytes

Hi,
This seems to be linked to the post a created earlier on RTL-SDR setup.
I did a new installation, and I have exactly the same problems. No waterfall and no data.
I have installed additional rtl-sdr libraries and can test the dongle on the raspberry-pi but the station does not initiate the servicing of the radio. It just seems the station is dead. There is no activity in the log. I stoped and started the service and that is all that is in the log file
journalctl -u satnogs-client.service
– Logs begin at Fri 2020-04-03 09:53:41 BST, end at Fri 2020-04-03 11:26:48 BST. –
Apr 03 09:53:45 SomersetWest systemd[1]: Started SatNOGS client.
Apr 03 10:20:14 SomersetWest systemd[1]: Stopping SatNOGS client…
Apr 03 10:20:14 SomersetWest systemd[1]: satnogs-client.service: Main process exited, code=killed, status=15/TERM
Apr 03 10:20:14 SomersetWest systemd[1]: satnogs-client.service: Succeeded.
Apr 03 10:20:14 SomersetWest systemd[1]: Stopped SatNOGS client.
Apr 03 10:20:20 SomersetWest systemd[1]: Started SatNOGS client.

Rikus

EDIT: There are some new updates in client, please update through sudo satnogs-setup

Do you get any error in logs? You can check the logs by running:
sudo journalctl -u satnogs-client.service

Also when the observation is running can you see any files in /tmp/.satnogs/data? You can check this by running:
ls -la /tmp/.satnogs/data.

Hi Fredy
sudo journalctl -u satnogs-client.service last entry reads:-

Apr 04 00:14:41 satnogs satnogs-client[307]: RuntimeError: soapy::source: Antenna rx at channel 0 is not supported. Available antennas are: [RX]
Apr 04 00:14:44 satnogs satnogs-client[307]: satnogsclient.observer.observer - ERROR - No waterfall data file found

have tried changing USB socket, no change

Max

The error message is telling you what’s wrong.

Your SATNOGS_ANTENNA setting should be ‘RX’, not ‘rx’.

73
Mark VK5QI

yeah … nah
spotted that and corrected it …
also changed the gain …

Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1-1”,
“gr-soapy”: “2.1.2-1”,
“gnuradio”: “3.8.0.0-6”,
“satnogs-config”: “0.10.1”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: true,
“platform”: {
“system”: “Linux”,
“node”: “satnogs”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 971059200,
“available”: 791900160,
“percent”: 18.4,
“used”: 112721920,
“free”: 569196544,
“active”: 264163328,
“inactive”: 61771776,
“buffers”: 26701824,
“cached”: 262438912,
“shared”: 6483968,
“slab”: 54919168
},
“disk”: {
“total”: 14978719744,
“used”: 3341049856,
“free”: 10981699584,
“percent”: 23.3
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rf_gain”: “32.8”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “125”,
“satnogs_station_id”: “657”,
“satnogs_station_lat”: “-40.938”,
“satnogs_station_lon”: “175.679”

There are pending updates, please perform update (choose update option and when is done hit apply) and let us know if you problem is solved.

Hi Fredy
have updated again, just waiting on some passes to test it …

Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1-1”,
“gr-soapy”: “2.1.2-1”,
“gnuradio”: “3.8.1.0~rc1-2”,
“satnogs-config”: “0.10.1”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “satnogs”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 971059200,
“available”: 781586432,
“percent”: 19.5,
“used”: 117264384,
“free”: 107446272,
“active”: 384491520,
“inactive”: 366870528,
“buffers”: 46829568,
“cached”: 699518976,
“shared”: 5877760,
“slab”: 88997888
},
“disk”: {
“total”: 14978719744,
“used”: 3826024448,
“free”: 10496724992,
“percent”: 26.7
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rf_gain”: “32.8”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “125”,
“satnogs_station_id”: “657”,
“satnogs_station_lat”: “-40.938”,
“satnogs_station_lon”: “175.679”
}
}
------------[ copy end ]-------------

Press Enter to continue…

The support report is only needed in case something is proven to fail! :slight_smile:

Thanks DL4PD just posted to show update

Observations still fail , with last posted config
While watching in the monitor the error below occurs as soon as sat in range and countdown clock suggests sdr should be activated

thread ‘main’ panicked at ‘called Option::unwrap() on a None value’, src/libcore/option.rs:378:21 note: run with RUST_BACKTRACE=1 environment variable to display a backtrace.

also rtl_test shows
pi@satnogs:~ $ rtl_test
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
usb_claim_interface error -6
Failed to open rtlsdr device #0.

rtlsdr dongle is warm as usual, works on laptop with sdr#

tried second rtlsdr v3 dongle same result and error

also

Logs begin at Sat 2020-04-04 02:11:46 BST, end at Sat 2020-04-04 10:05:49 BST. –
Apr 04 02:11:49 satnogs systemd[1]: Started SatNOGS client.
Apr 04 02:15:36 satnogs systemd[1]: Stopping SatNOGS client…
Apr 04 02:15:36 satnogs systemd[1]: satnogs-client.service: Main process exited, code=killed, status=15/TERM
Apr 04 02:15:36 satnogs systemd[1]: satnogs-client.service: Succeeded.
Apr 04 02:15:36 satnogs systemd[1]: Stopped SatNOGS client.
Apr 04 02:15:36 satnogs systemd[1]: Started SatNOGS client.
Apr 04 02:34:06 satnogs satnogs-client[958]: rot_init called
Apr 04 02:34:06 satnogs satnogs-client[958]: dummy: _init called
Apr 04 02:34:06 satnogs satnogs-client[958]: rot_register (1)
Apr 04 02:34:06 satnogs satnogs-client[958]: rot_register (2)
Apr 04 02:34:06 satnogs satnogs-client[958]: dummy_rot_init called
Apr 04 02:34:06 satnogs satnogs-client[958]: rot_open called
Apr 04 02:34:06 satnogs satnogs-client[958]: dummy_rot_open called
Apr 04 02:34:06 satnogs satnogs-client[958]: rot_get_position called
Apr 04 02:34:06 satnogs satnogs-client[958]: dummy_rot_get_position called
Apr 04 02:34:06 satnogs satnogs-client[958]: rot_set_position called
Apr 04 02:34:09 satnogs satnogs-client[958]: Found Rafael Micro R820T tuner
Apr 04 02:34:09 satnogs satnogs-client[958]: Found Rafael Micro R820T tuner
Apr 04 02:34:09 satnogs satnogs-client[958]: [R82XX] PLL not locked!
Apr 04 02:34:09 satnogs satnogs-client[958]: [INFO] Using format CF32.
Apr 04 02:34:10 satnogs satnogs-client[958]: Could not find port: freq in:
Apr 04 02:34:10 satnogs satnogs-client[958]: freq
Apr 04 02:34:10 satnogs satnogs-client[958]: system
Apr 04 02:34:10 satnogs satnogs-client[958]: 4
Apr 04 02:34:10 satnogs satnogs-client[958]: Traceback (most recent call last):
Apr 04 02:34:10 satnogs satnogs-client[958]: File “/usr/bin/satnogs_bpsk_ax25.py”, line 541, in
Apr 04 02:34:10 satnogs satnogs-client[958]: main()
Apr 04 02:34:10 satnogs satnogs-client[958]: File “/usr/bin/satnogs_bpsk_ax25.py”, line 526, in main
Apr 04 02:34:10 satnogs satnogs-client[958]: tb = top_block_cls(antenna=options.antenna, baudrate=options.baudrate, bb_freq=options.bb_freq, bw=options.bw, dc_remov
Apr 04 02:34:10 satnogs satnogs-client[958]: File “/usr/bin/satnogs_bpsk_ax25.py”, line 138, in init
Apr 04 02:34:10 satnogs satnogs-client[958]: self.satnogs_doppler_compensation_0 = satnogs.doppler_compensation(samp_rate_rx, rx_freq, lo_offset, baudrate*decimatio
Apr 04 02:34:10 satnogs satnogs-client[958]: File “/usr/lib/python3/dist-packages/satnogs/doppler_compensation.py”, line 147, in init
Apr 04 02:34:10 satnogs satnogs-client[958]: self.doppler, “freq”)
Apr 04 02:34:10 satnogs satnogs-client[958]: File “/usr/lib/python3/dist-packages/gnuradio/gr/hier_block2.py”, line 60, in wrapped
Apr 04 02:34:10 satnogs satnogs-client[958]: func(self, src.to_basic_block(), srcport, dst.to_basic_block(), dstport)
Apr 04 02:34:10 satnogs satnogs-client[958]: File “/usr/lib/python3/dist-packages/gnuradio/gr/hier_block2.py”, line 132, in msg_connect
Apr 04 02:34:10 satnogs satnogs-client[958]: self.primitive_msg_connect(*args)
Apr 04 02:34:10 satnogs satnogs-client[958]: File “/usr/lib/python3/dist-packages/gnuradio/gr/runtime_swig.py”, line 3665, in primitive_msg_connect
Apr 04 02:34:10 satnogs satnogs-client[958]: return _runtime_swig.hier_block2_sptr_primitive_msg_connect(self, *args)
Apr 04 02:34:10 satnogs satnogs-client[958]: RuntimeError: invalid msg port in connect() or disconnect()
Apr 04 02:34:15 satnogs satnogs-client[958]: apscheduler.executors.default - ERROR - Job "spawn_observer (trigger: date[2020-04-04 01:34:06 UTC], next run at: 2020-04-0
Apr 04 02:34:15 satnogs satnogs-client[958]: Traceback (most recent call last):
lines 1-43

any ideas ?
cheers

Max ZL2MST

That particular error was encountered last night a few nights ago and should have been fixed. It was a version mismatch issue between gnuradio and satnogs-flowgraphs.

However… your versions look correct, so I don’t know why this would still be occurring…
Paging @Acinonyx @surligas

It’s shouldn’t be occurring. Is it possible that the observation was started before Update finished?

Morning
i think i’m back up and running . just looking at the gain values ,
the set up doc says Example: For RTL-SDR without pre-amp, 32.8 is a good starting value, https://wiki.satnogs.org/SatNOGS_Client_Setup

but the trouble shooting page says If set to low, same. Test a value between 7 and 15. https://wiki.satnogs.org/Troubleshooting

any thoughts on the best value ?
otherwise ill put the station back online today , thank you , Fredy and the community for your help

Max

1 Like

Hi,

@vk5qi wrote a guide on how to properly find a good gain setting, see:
https://wiki.satnogs.org/Omnidirectional_Station_How_To#Setting_the_gain

The Troubleshooting page was giving some dubious answers, I’ve removed some and added a warning banner.

If you just want some first value for rtl-sdr, 32.8 is ok.

Thanks for pointing out this discrepancy between the two wiki pages!

Sincerely,
Fabian

1 Like

Hello, All,

I had the same proble; are you sure you are connected to the server ?

I had to re-enter my SATNOGS_API_TOKEN in the new (started from the image) system, to get connected and active. (with waterfall, decodes etc…)

SATNGS-SETUP => ADVANCED_CONFIGURATION_OPTIONS =>NETWORK_SETTINGS
=>SATNOGS_API_TOKEN ; don’t forget to “apply” and reboot.

Otherwise, your parameters seem OK; here are mine: (see [Observation #2008623])(https://network.satnogs.org/observations/2008623/)

{

  • radio: {
    • name: “gr-satnogs”,
    • version: 2.0.1.0,
    • rx_device: “driver=rtlsdr”,
    • samp_rate: 2.048e6,
    • bandwidth: null,
    • gain_mode: “Overall”,
    • rf_gain: 49.6,
    • antenna: “RX”,
    • lo_offset: null,
    • ppm_error: null,
    • dev_args: null,
    • stream_args: null,
    • tune_args: null,
    • other_settings: null,
    • dc_removal: null,
    • bb_freq: null},
  • latitude: 50.485,
  • longitude: 4.885,
  • elevation: 175,
  • frequency: 137100000

73", Jean-Luc ON4LS

1 Like