SatNOGS install on linux desktop


#1

I am having trouble decoding data on my rpi2 station (https://network.satnogs.org/observations/?station=97). I have installed it twice with no success. The rpi image installation works actually very good for a guy that don’t know Linux very well. The observations seems to be too short in most cases. Only when I observe CW sats that I get the correct time on the observations, but still no decode. So I thought let us test on a faster pc.

So I want to install SatNOGS on a higher performance desktop for a test.

I used the debian image https://www.debian.org/blends/hamradio/ on an old DELL XPS I7 laptop

I am having difficulties following these two

a. https://wiki.satnogs.org/SatNOGS_Client_Ansible

** I am not SSH into the system (i do not have another Linux system or host, I just got the target), I am installing it on the system by opening a Xterm and typing in commands so I suffer to follow this

$ git clone https://gitlab.com/librespacefoundation/satnogs/satnogs-client-ansible.git    # Clone SatNOGS Client Ansible repository
$ cd satnogs-client-ansible                              # Change to cloned repository directory
$ cp -r production.dist production                       # Copy dist configuration
$ vi production/inventory/hosts                          # Update file with your own target host, user and SSH password
$ ssh youruser@yourtargetsystem true                     # Test SSH connection to target system
$ ansible-playbook -i production/inventory -K site.yml   # Run Ansible playbook
$ ssh -t youruser@yourtargetsystem sudo satnogs-setup    # Setup SatNOGS client (see below)

b. https://wiki.satnogs.org/Linux_Desktop

Having a problem here with broken link

wget -O archive.zip https://gitlab.com/librespacefoundation/satnogs/gr-satnogs-package/-/jobs/35403119/artifacts/download (broken link here)

any other pointers or is it a bit of a struggle anyway after having a good experience with the rpi image installation :joy:?


#2

Hey @jjroux
You can use this one https://gitlab.com/librespacefoundation/satnogs/gr-satnogs-package/-/jobs/64327023/artifacts/download

Artifacts of builds can be found here https://gitlab.com/librespacefoundation/satnogs/gr-satnogs-package/-/jobs/

Ansible playbooks can be followed locally too.

I made an edit on the Linux Desktop page to reflect that people should follow the SatNOGS Client Ansible page instead.


#3

Jacques, I tried installing SatNOGS on my Linux Mint laptop. I ran into the broken link. I’m guilty of documenting it with (broken link here).

–Konrad


#4

Thanks you guys you are very helpfull. Big learning curve for me. @WA4OSH any help is better than none. Thanks for documenting.


#5

Jaques,
It looks like User:Ppapadeas added this note on top of the article Linux Desktop:

I’ve had to take my Ground Station down while I re-wire some things here, so I have not had a chance to see if SatNOGS Client Ansible works for me.

–Konrad


#7

Generally, ansible works by assuming you are running remotely the recipes targetted to a host you are trying to configure. If the host is localhost (running ansible locally) then you can set this up and still ansible would not care. Let us know if you need any more help with it


#9

I don’t think it is correctly installed. Can you share more detailed information on the process you followed?


#11

Any one know why this command will not run? error message is “ansible-playbook command not found”


#12

satnogs-client-ansible/production/inventory/host_vars is an empty file.

?

bob
w4ush


#13

[quote=“jjroux, post:1, topic:2233”]

I have solved this problem ,And I successfully ran the command “ssh youruser@yourtargetsystem true”

The next line says to run: “ansible-playbook -i production/inventory -K site.yml” which results in an error “bash: ansible-playbook: command not found.”

I have started from scratch six times and get the same error each time. I checked for “site.yml” and it does exist.

Apparently, the system cannot find the playbook command. Or, the playbook script did not load.

Does that sound reasonable?

How to fix it?

bob
w4ush


#14

any solution on this command not found issue? ran also in this stuff on a clean Debian Stretch 9.2 64 Bit. Some guidance or hint which host to use for pc satnogs-client would be appreciated,

br Robert, 73 de oe6rke


#15

oh silly me! after stepping back a meter i found the solution.

Basically you install the plain vanilla debian stretch version 9 and make it usable (network, cd unmount, user setup root and a working user).
Then kick in the following commands as root
apt-get install sudo
apt-get install ansible

After this adapt /etc/groups and add the working user to the group sudo.
Following the instructions at https://wiki.satnogs.org/SatNOGS_Client_Ansible .
If done correctly the ansible-playbook will fail. this is quite logical since debian is supplying an old 2.2 ansible version in the repo. what helps is to update the ansible.

for this add to /etc/apt/sources.list the following lines:

deb http://ftp.debian.org/debian stretch-backports main
deb-src http://ftp.debian.org/debian stretch-backports main

and use this command to install correctly:
apt-get install -t stretch-backports ansible

This updates the ansible being able to follow the command: ansible-playbook -i production/inventory -K site.yml
the first apt-get install ansible is necessary to create the needed dependencies.

well, and the rest is history. I hope this short guidance might help to bring satnogs-client as well on pc clients.

br Robert, 73 de oe6rke


#16

Thanks for writing this up, it had me stuck for a few minutes.

Now my error is the ‘Update APT Cache’.

TASK [common : Update APT cache] ****************************************************************************************************************************************************************
FAILED - RETRYING: Update APT cache (3 retries left).
FAILED - RETRYING: Update APT cache (2 retries left).
FAILED - RETRYING: Update APT cache (1 retries left).
fatal: [satnogs]: FAILED! => {"attempts": 3, "changed": false, "module_stderr": "Shared connection to 192.168.1.65 closed.\r\n", "module_stdout": "/bin/sh: 1: sudo: not found\r\n", "msg": "MODULE FAILURE\nSee stdout/stderr for the exact error", "rc": 127}
    to retry, use: --limit @/home/beno/satnogs-client-ansible/site.retry

Google seems to suggest that I need to make the changes to the sources.list out, which I did and it makes no difference.
apt-get update shows no errors.

Where is this in the .yml file so I can just remove it and get my station working on Debian?


#17

sudo: not found

Maybe your user running the ansible script is not allowed to use sudo?


#18

I saw that and wondered as well. As you know, there is no ‘sudo’ user on Debian, so I am running the script as root.


#19

I’m not very familiar with debian, tbh!
A quick search delivers similar solutions to this:

Maybe try that first?


#20

Huh. Well, there you go, I had not installed sudo.
apt-get install sudo and we are past that problem. Thank-you VERY much, I had missed that one.

The playbook now runs a long while, then fails here;

TASK [satnogs-radio : Install gr-satnogs] *******************************************************************************************************************************************************
fatal: [satnogs]: FAILED! => {"msg": "The task includes an option with an undefined variable. The error was: 'dict object' has no attribute u'i386'\n\nThe error appears to have been in '/home/beno/satnogs-client-ansible/roles/satnogs-radio/tasks/main.yml': line 36, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n  become: True\n- name: Install gr-satnogs\n  ^ here\n"}

#21

Hm, curious. What hardware are you using?


#22

Its a compact desktop PC.
Intel® Atom™ CPU 230 @ 1.60GHz


#23

Is it a 32 bit machine?