Satnogs Client Setup Fails at <APPLY>

I am setting up my first SatNOGS station using a Raspberry Pi 4. I am at the point of applying my configuration, I only set up the basic settings and browsed through the advanced settings to see what I will need to look out for. I am going to be using an RTL-SDR BLOG V3 ultimately hooking that to an LNA to an M2 SATPACK1. I am adding screen shots of the failure and the Error LOG.

I am getting an error: localhost failed msg: Failed to update apt cach: unknown reason
And so I do not know what to do… It looks as if my jpeg will not work on here…
Any help or direction would be appreciated.
Thank you

Additional screen shot…

Hopefully this helps to understand the state the setup is in…


Is this when you are running satnogs-setup

If so are you running it with sudo satnogs-setup

The permission denied maybe because you are missing the sudo


Hello Mark,
Thanks for the reply. I have to admit this is the first experience I have had with raspberry pi, Linux, even CLI (so I basically jumped in without learning how to swim). I am following the Satnogs wiki client setup instructions. Are there two ways of setting this up one standard and one sudo? Or did I miss a step? Would you be able to point me in the right direction? Or provide some advice? Thank you for reaching out!!

Hi Jeff

I’m also a fairly new user to satnogs but I do have the advantage of a lot of experience with Linux :slight_smile:

I believe the instructions say to use sudo, (for reference sudo instructs the command to be run with root permissions, think running as administrator to liken it to using Windows)

The instructions I used were the ones from here but there may be other instructions as well SatNOGS Client Setup - SatNOGS Wiki

Anything I can do to help with the setup just ask.


Thank you Mark. That is the same set of instructions I am following. I completed the “sudo apt update” then” sudo apt upgrade” I got the error then completed the “sudo apt purge needrestart” and didn’t get the error so I assumed that would have set everything up to move on I entered all of the basic config info then hit “Apply” and tried 4 times still failed. So something is missing…?? Should I or could I do a complete reset and start over? Or is it still salvageable from where i’m at?

Hi Jeff

Sometimes it might be easier to just start over (One advantage or running everything on a standalone Pi)

Just a few more questions for clarity
When you ran “sudo apt upgrade” did you get any errors at that point?

When running the satnogs-setup command did you run “sudo satnogs-setup” or without the sudo.

Thank you.

I have to say I must not have included the sudo because I just typed sudo in front of the commands following the instructions in the client setup. How or where do I find “sudo” ?

sudo is a builtin command on linux so you should have to look for it anywhere.

If you try run sudo satnogs-setup and let us know if you are still getting the permission denied error


I will give this a try tonight after work. Thanks for all if the help!!

@n0nqd no worries, I may not be able to help you live when you are trying due to time zones but if I am online I will do my best.


I was able to fix this issue after clearing what’s inside sources.list.d/ansible.list
sudo nano /etc/apt/sources.list.d/ansible.list
And then hitting Apply again

Thank you, I will look into this as well. Can I just run that command or do I have to be in a specific promt ?

Once you are logged into the pi you should be able to just run the command

Well I tried clearing out what was inside sources.list.d/ansible.list it was empty black screen with Alt commands across the bottom. I then performed a sudo apt update then a sudo apt upgrade which ran well rebooted with a new Kernal. Went back into satnogs-setup then hit apply seems like it went further then failed again. See screen shot for details… Thank you…

I can see you are running that as the user satnogs, did you create that user in /home ?
That will probably create a bunch of problems, it is supposed to be created and maintained by ansible.
Create a user for yourself, or just the classic pi user instead.

1 Like

Thanks for bringing that up. I have been trying to figure out how to change that. Doesn’t that go all the way to the initial flashing of the raspberry pi SD card? I cant seem to figure it out.

The easiest way is to start again and don’t create a user satnogs when flashing the SD card.

okay… Thanks I will. I really was hoping to be able to just change the host id…

Just to be sure, I am not sure what you mean by host id,

By choosing satnogs as the username you ran into problems, so don’t use satnogs as the initial username when creating the SD card image.