SatNOGS Ansible on Debian Buster - failed install

I tryed to install SatNOGS Client Ansible on Debian 10.2.0 (4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64) based on this manual:
https://wiki.satnogs.org/SatNOGS_Client_Ansible

But I have problem with libgnuradio-satnogs.

TASK [satnogs-radio : Check if libgnuradio-satnogs is installed] ****************************
FAILED - RETRYING: Check if libgnuradio-satnogs is installed (3 retries left).
FAILED - RETRYING: Check if libgnuradio-satnogs is installed (2 retries left).
FAILED - RETRYING: Check if libgnuradio-satnogs is installed (1 retries left).
fatal: [satnogs]: FAILED! => {“attempts”: 3, “changed”: false, “msg”: “No package matching ‘libgnuradio-satnogs’ is available”}

PLAY RECAP **********************************************************************************
satnogs : ok=60 changed=27 unreachable=0 failed=1 skipped=7 rescued=0 ignored=0

Any ideas what’s wrong?

1 Like

Possibilities below. I’ll take a look at the ansible setup too

  1. You don’t have the repo added to you apt list in /etc/apt/sources.list or /etc/apt/sources.list.d. Ansible should do this.

  2. You need to run sudo apt update, because step 1 is ok, but the package list isn’t updated. You can also run Update from the satnogs setup program too.

  3. The wrong repo is in the repo list, in which case you may get an error like this when running sudo apt update:

...
Err:4 http://download.opensuse.org/repositories/home:/librespace:/satnogs_unstable/Raspbian_10 ./ Release
  404  Not Found ...

This is because the repo is set for Raspbian ARM architecture, but you are running x86_64 (Intel) architecture.

-Jeff

See also this post, maybe helps:

I just ran the Ansible setup from that wiki doc on a bare Debian Buster machine and it worked. Maybe you just hit a transient network issue. Try running the Ansible command again, and see if it fails in the same spot.

My quick notes on the install:

# On Debian Buster
# This is for doing all the Ansible steps just on one computer.
# It assumes you aren't using a centralized Ansible setup
# (e.g. if this is your only Ansible using computer...).
#
# Run below as regular "sudo" user, or as root:
sudo apt update
# XXX Note, needs python 2 setuptools, NOT python3-setuptools
sudo apt install ansible python-setuptools
sudo apt clean
git clone https://gitlab.com/librespacefoundation/satnogs/satnogs-client-ansible.git
cd satnogs-client-ansible
cp -r production.dist production
vi production/inventory/hosts

# Make that file below
# * Replace ansible_user "debian" with your username that can ssh/sudo, NOT "satnogs".
# * Set a ansibe_host (the computer hostname).

---
all:
  hosts:
    satnogs:
      ansible_host: 'satnogs-client'
      ansible_user: 'debian'
      ansible_ssh_pipelining: true
satnogs-setups:
  hosts:
    satnogs:
satnogs-radios:
  hosts:
    satnogs:
hamlib-utils:
  hosts:
    satnogs:
satnogs-clients:
  hosts:
    satnogs:
snmpds:
  hosts:
    satnogs:
gpsds:
  hosts:
    satnogs:

# Set up ssh keys:
ssh-keygen -t ed25519
cat ~/.ssh/id_ed25519.pub >> ~/.ssh/authorized_keys
# Make sure you can ssh to yourself (replace 127.0.0.1 with the
# name you set in ansible_host)
ssh 127.0.0.1 true

# Run the playbook:
ansible-playbook -i production/inventory -K site.yml

# Now run the SatNOGS setup:
sudo satnogs-setup


Before you wrote this I tried command:

sudo apt-get install -y python-pip python-dev supervisor cmake libusb-1.0-0-dev libhamlib-utils vorbis-tools software-properties-common unzip

from previous manual: https://wiki.satnogs.org/Linux_Desktop

Now client works. I think the whole problem was in python-setuptools. Now only web server on port 5000 doesn’t work but i can live without it.

Thank you for your help. You are doing amazing work guys!

1 Like

Cool, glad you got it going.

The web server on port 5000 doesn’t exist in the latest generation of the software.