Rotor control issue

I am having a problem with Gpredict controlling my EA4TX ARS-USB controller for Azimuth and Elevation rotators
I have them working with hamlib with this rotctl -m 606 -r /dev/ttyACM0, where I can change both the Azimuth and elevation positions.
In Gpredict I have tried putting the Host as /dev/ttyACM0 and also to rotctl in Hamlib /usr/local/bin/rotctl but nothing seems to work.

Is there someone who could please help me, I am new to Linux, Ubuntu, as I am trying to move from Windows 10 completely
Many Thanks

Host in Gpredict is localhost

I have tried that, but it still is not doing anything

I also had the firewall to allow incoming and outgoing traffic on ports 4533 (rotctld) and 4532 (rigctld).
Use gufw (sudo apt install gufw) to set this via a GUI.

Done that, now I have 4 rules for incoming and outgoings but still nothing on Gpredict
Gpredict is not even showing the correct readings from both rotators

Message Logs - Level 4: Debug

And check, if the log file (/home/username/.config/Gpredict/logs) says something like that:

2024/06/01 16:44:26|4|rotctld_socket_open: Network socket created successfully
2024/06/01 16:44:26|4|rotctld_socket_open: Connection opened to localhost:4533

I do not have anything in the log, even after I changed it to Level 4, only this:

That’s strange.

Besides that, if you click on Engage in the rotator window, does it stay in blue?
Rotor engaged

And if you enter in a terminal

netstat -n | grep 4533

does it show this (while the Engage button is still blue)?


And please also try in a separate terminal window

rotctld -m 606 -r /dev/ttyACM0 --port=4533 -vvvvv | tee -a /home/m0jtl/rotctld.txt

It creates rotctld.txt in your home folder for examination.

Thanks, I will give it a try on the next pass.
I am trying everything out on my Windows setup just to be certain there is not a problem with the hardware side of it, then if it all works I’ll go back to Linux and try everything you suggested
Many Thanks

1 Like

I came back to Linux and tried netstat -n | grep **4533 and I got nothing, then tried rotctld -m 606 -r /dev/ttyACM0 --port=4533 -vvvvv | tee -a /home/m0jtl/rotctld.txt
It made the file but Terminal just sat there and there was nothing in the text file.

Hamlib was not responding to anything so I tried to reinstall it by the following, hope this is correct:
./configure --prefix=/usr/local
sudo make install
when I did the sudo make install I got an error:
libtool: error: error: cannot install ‘’ to a directory not ending in /usr/local/lib

Like I said I am new to this, so I must be doing something wrong, but not sure what!!

Try this for reinstalling hamlib:

git clone GitHub - Hamlib/Hamlib: Ham radio control library for rigs, rotators, tuners, and amplifiers
cd Hamlib
sudo apt install autoconf
sudo apt install libtool
sudo apt install g++
./configure --disable-dependency-tracking
sudo apt install make
make check
sudo make install

Ok all re-installed as you said.
rotctld.txt (2.3 KB)

When I do netstat -n | grep 4533 I just get the command Prompt

As for the Engage on the rotator window, mine is Grey and when clicked it turns a darker grey

I have just noticed when I put
rotctld -m 606 -r /dev/ttyACM0
into terminal it just sits there with a flashing cursor but when I do the same with
rotctl -m 606 -r /dev/ttyACM0 I can control the rotators, is this right?

That’s right. And Gpredict needs the deamon (rotctld).

Are you sure you entered rotctld -m ____ ?

rotctld.txt says in its first line

Usage: rotctl [OPTION]… [COMMAND]…


When I do netstat -n | grep 4533 I just get the command Prompt

This means, that rotctld didn’t start and/or Gpredict couldn’t establish a link to rotctld.

Ok, then in your case, it’s darker grey. This is good.

This is the output from both the rotctl and rotctld
rotctld -m 606 -r /dev/ttyACM0 --port=4533 -vvvvv | tee -a /home/m0jtl/rotctld.txt
rotctl -m 606 -r /dev/ttyACM0 --port=4533 -vvvvv | tee -a /home/m0jtl/rotctl.txt

These are the rotctl and rotctld settings, are they correct?
it is hangs with a blinking cursor when I do the rotctld command