Photo interrupter

Today was my first test of satnogs rotator. Unfortunately not everything worked as expected.

As soon as I powered up the rotator, it started with a 360 degree on both axis. After that it would not accept any command to move!!!

It was clear that it was on error state. Power off and on again. The same one more time, 360 degrees in both axis and … error.

Back on the lab… everything is working fine :triumph:

After some thought …it hit me… the photo interrupter is too sensitive.

I couldn’ t get easy the photo interrupter that is recommended in the BOM so I used this one:

On the next test on the rooftop, I covered the photo interrupter with carton box and everything worked fine.

So I need another photo interrupter or a better cover (thicker) for the rotator.

We have the same problem, but with external box the photo interrupter it works.

We have opened an issue for this. We want to replace with a mechanical switch like this.
You can see all the new parts here.

It is probably working with the external box on, due to the smaller gap between the transmitter and the receiver.

In my case the photo interuppter has a very big gap, ~10mm !!!

I am looking forward to see the new version 3.1.

In any case, I resolved my issue with a beautiful :smiling_imp: white spray of paint. One (or two) layers of paint on the external box made everything work as expected.

photo is coming soon…

I am not so super happy with the optical end stop design with regards to how the LED is connected. Let me ask if you are using the LED?

I think the LED draws some power so the high level is not fully reached and thus the sensor will trigger “earlier”.

@akef: ok your sensor is really very very wide :wink: