New Installation - satnogs cannot be online

I just installed Satnog, but it’s still offline.

$ journalctl -f -u satnogs-client.service

Started SatNOGS client.
satnogsclient - ERROR - SATNOGS_STATION_LAT not configured but required
satnogsclient - ERROR - SATNOGS_STATION_LON not configured but required
satnogsclient - ERROR - SATNOGS_STATION_LAT not configured
satnogsclient - ERROR - SATNOGS_STATION_LON not configured
satnogsclient - ERROR - Settings are invalid, exiting…
satnogs-client.service: Main process exited, code=exited, status=255/EXCEPTION
satnogs-client.service: Failed with result ‘exit-code’.
satnogs-client.service: Service RestartSec=100ms expired, scheduling restart.
satnogs-client.service: Scheduled restart job, restart counter is at 52.
Stopped SatNOGS client.

Please Help…

The error messages here are fairly self explanatory. You haven’t set up your station lat/lon (and probably other settings) using sudo satnogs-setup.

You will need to run sudo satnogs-setup and configure this appropriately:

Mark VK5QI

Thank you for the help. but I have read and haven’t found the problem

Please run sudo satnogs-setup, then go to Advanced -> Support, and past the output from that here. That will show us what settings you may or may not have set.

“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1.2-1”,
“gr-soapy”: “2.1.3-1”,
“gnuradio”: “”,
“satnogs-config”: “0.10.1”
“state”: {
“is-applied”: true,
“pending-tags”: null
“system”: {
“distribution”: {
“DESCRIPTION”: “Debian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Debian”
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “yc5abk”,
“release”: “5.1.0-aml-s905”,
“version”: “#5.91 SMP PREEMPT Mon Jul 8 15:49:06 MSK 2019”,
“machine”: “aarch64”,
“processor”: “”
“memory”: {
“total”: 840687616,
“available”: 544493568,
“percent”: 35.2,
“used”: 215793664,
“free”: 403161088,
“active”: 123994112,
“inactive”: 163774464,
“buffers”: 11501568,
“cached”: 210231296,
“shared”: 1241088,
“slab”: 86495232
“disk”: {
“total”: 7317086208,
“used”: 5854478336,
“free”: 1135460352,
“percent”: 83.8
“configuration”: {
“gpsd_enabled”: true,
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_network_api_url”: “”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “20”,
“satnogs_station_id”: “1601”,
“satnogs_station_lat”: “1.914S”,
“satnogs_station_lon”: “100.878E”
------------[ copy end ]-------------

First up, latitude and longitude must be entered as decimal degrees (which you have done), but as positive or negative numbers (not S/E as you have done). South latitude should be negative, west longitude should be negative, so in your case, latitude should be -1.914 , longitude 100.878.

Apart from that, your config looks OK, but you should adjust your gain settings using the ‘Setting the Gain’ guide, as the default gain setting is not useful:

1 Like

ok sir, I’ll try again. thank you for your help … if there are any more obstacles I will convey …

Ok Sir… Done… Thx four your help. 73

please help sir … how do i set the ppm of this image … how many ppm should i input … thanks

First up, what kind of RTLSDR dongle are you using?
Does it have a TCXO (Temperature Compensated Crystal Oscillator), or is it just a standard crystal? If it is the latter, setting a ppm offset may not help as this kind of RTLSDR often drifts badly with temperature.

Based on the waterfall, your receiver appears to be high in frequency by about 8 kHz. Given the centre frequency is meant to be on 137.912 MHz, the PPM offset an be given by ((f + 8000)/f - 1)*1e6, where f is 137912000 Hz. This gives a PPM offset of 58 ppm. This is fairly high for most TCXO-based RTLSDRs. The RTLSDR v3 usually has a PPM offset of around 1ppm (not worth worrying about).

This can be entered using sudo satnogs-setup, in the Advanced -> Radio -> SATNOGS_PPM_OFFSET setting. I’m unsure if the correction should be entered as 58 or -58 however. Try one, check an observation, then try the other if it’s gone even further off frequency!

Mark VK5QI

Thank you, sir, I only use the usual blue one.

“Blue one” doesn’t really tell me much about what kind of SDR it is. If it has a TCXO inside, it will usually be indicated on the label. Otherwise, you can crack open the case and take a look inside.

If it looks like the following image, then it doesn’t have a TCXO:

If it looks different to that, then it may have a TCXO, but I’d need a picture to be sure.

Either way, the fact that it’s 58 ppm off-frequency isn’t a good sign, and I’d recommend getting something like either the RTLSDR v3 units, or one of the TCXO RTLSDRs from Nooelec.

Mark VK5QI

yes … absolutely the same as the one at

So that means no TCXO, and a SDR that has the potential to drift in frequency as temperature changes.

I’d highly recommend getting one of the RTLSDRs I recommended above, for a more stable station.

Mark VK5QI

ok sir … but before I had a good brother what should I do for the brother that I have now… and according to the picture above how many ppm should I set. thank…

the command SoapySDRUtil --probe satnogs encountered an error [ERROR] avahi_service_browser_new () failed: Bad state …
does this matter, sir?

I think is a good option to install rtl_tcp server.

With the server installed, you can stop satnogs service and connect to your dongle with sdrsharp. Using a well known frequency station near your home, you can adjust ppm looking at the waterfall.

To stop satnogs: sudo systemctl stop satnogs-client

To run rtl_tcp server: rtl_tcp -a

To run again satnogs: sudo systemctl start satnogs-client

Or even easier connecting to your dongle soapy server using Cubicsdr.

What do you think about it?

Ok sir … I already did. and now I can find out the ppm … thanks for the help …

Best Regard,

1 Like


if i want to add SPF5189z LNA … what settings should i change sir …

Best Regard,