Install Problems with v2.2.1 for Raspberry Pi

raspberrypi

#1

Hello,

I am working to use a Raspberry Pi 3 for many of my ham shack activities, one of which is to be running GPredict. I did a “sudo apt-get install gpredict” and I got v1.3. I noticed that even thought I updated the TLE file, several of the normal satellites I use are not listed, or are listed differently than v2.2.1 on my Windows laptop. I wanted to update my Pi to v2.2.1, but I am running into one particular issue.

I went to https://launchpad.net/~gpredict-team/+archive/ubuntu/ppa/+packages
used the down arrow on gpredict 2.2.1-ubuntu18.04~ppa3
downloaded the armhf to my Pi
executed “sudo dpkg -i gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb”
When I do this, I get the following:

(Reading database … 142717 files and directories currently installed.)
Preparing to unpack gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb …
Unpacking gpredict (2.2.1-ubuntu18.04~ppa3) over (1.3-3+b1) …
dpkg: dependency problems prevent configuration of gpredict:
gpredict depends on libgoocanvas-2.0-9 (>= 2.0.2); however:
Package libgoocanvas-2.0-9 is not installed.

dpkg: error processing package gpredict (–install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) …
Processing triggers for gnome-menus (3.13.3-9) …
Processing triggers for mime-support (3.60) …
Processing triggers for man-db (2.7.6.1-2) …
Errors were encountered while processing:
gpredict

The problem seems to lie with libgoocanvas-2.0-9

I’ve searched the forums, and I found someone with the same problem, but the response was for him to update his Pi OS to the latest version. I actually did this earlier today for another program I use. My latest OS information is:

PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”
ID=raspbian
ID_LIKE=debian

I also did try to install with the tarball, but when I ran “sudo ./config” I get a lot of action, but at the very end I get the message lines:
./configure: line 4471: intltool-update: command not found
checking for intltool >= 0.21… found
configure: error: Your intltool is too old. You need intltool 0.21 or later.

I can usually work my way through these things, or piece together enough information from different places to figure it out, but this time I cannot.

Any help would be very appreciated, especially considering I see many folks using gpredict on their RPI’s. What I am doing wrong?

Thank you and 73

Nick
KC1DKY


#2

I forgot to mention, I also used the instructions listed here:

https://community.libre.space/t/installing-gpredict-binary-on-the-raspberry-pi-3/2145

and I get the same result, that it is missing the libgoo.


#3

Hey Nick,

have you tried, on your RasPi, to

$ sudo apt install libgoocanvas-2.0-9

or the development version:

$ sudo apt install libgoocanvas-2.0-dev

before installing the package?


#4

I thought dpkg -i would install dependencies but it does not. It does, however, generate a list of unresolved dependencies that apt-get -f will pick up. So, I think the correct procedure is to run apt-get, then repeat the dpkg -i command:

$ sudo dpkg -i gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb
$ sudo apt-get -f install
$ sudo dpkg -i gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb

Alex


#5

Note that these instructions refer to using the graphical installer tool and using the package built for Ubuntu 16.04 not 18.04. That could make a difference.


#6

In one step I think you can do:
apt-get install ./gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb
(note the “./”) to get the package installed with all dependencies.

Or may be on its 16.04 counterpart in this case.


#7

@DL4PD
I tried both commands and this is what I got:

$ sudo apt install libgoocanvas-2.0-9
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libgoocanvas-2.0-9 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libgoocanvas-2.0-9’ has no installation candidate

AND

$ sudo apt install libgoocanvas-2.0-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libgoocanvas-2.0-dev
E: Couldn’t find any package by glob ‘libgoocanvas-2.0-dev’
E: Couldn’t find any package by regex ‘libgoocanvas-2.0-dev’

It’s funny because that libgoocanvas-2.0-dev library appears to be available for Stretch based on this website: http://www.raspberryconnect.com/raspbian-packages-list/item/109-raspbian-libdevel yet using apt install or apt-get install, says it can’t find the package…


#8

@n5fxh

Tried this with both 18 and 16. Here’s what I got with 16:

$ sudo apt-get install ./gpredict_2.2.1-ubuntu16.04_ppa2_armhf.deb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘gpredict’ instead of ‘./gpredict_2.2.1-ubuntu16.04_ppa2_armhf.deb’
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gpredict : Depends: libgoocanvas-2.0-9 (>= 2.0.2) but it is not installable
Recommends: libhamlib-utils but it is not installable
E: Unable to correct problems, you have held broken packages.


#9

@csete, Alex
Thank you for your reply. Still not working. It’s that libgoo package that it just cannot get around.
In order (note the $ as each prompt):
$ sudo dpkg -i gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb
Selecting previously unselected package gpredict.
(Reading database … 142550 files and directories currently installed.)
Preparing to unpack gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb …
Unpacking gpredict (2.2.1-ubuntu18.04~ppa3) …
dpkg: dependency problems prevent configuration of gpredict:
gpredict depends on libgoocanvas-2.0-9 (>= 2.0.2); however:
Package libgoocanvas-2.0-9 is not installed.

dpkg: error processing package gpredict (–install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) …
Processing triggers for gnome-menus (3.13.3-9) …
Processing triggers for mime-support (3.60) …
Processing triggers for man-db (2.7.6.1-2) …
Errors were encountered while processing:
gpredict

$ sudo apt-get -f install
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
libgoocanvas-common libgoocanvas3
Use ‘sudo apt autoremove’ to remove them.
The following packages will be REMOVED:
gpredict
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 5,418 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database … 142662 files and directories currently installed.)
Removing gpredict (2.2.1-ubuntu18.04~ppa3) …
Processing triggers for mime-support (3.60) …
Processing triggers for desktop-file-utils (0.23-1) …
Processing triggers for man-db (2.7.6.1-2) …
Processing triggers for gnome-menus (3.13.3-9) …

$ sudo dpkg -i gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb
Selecting previously unselected package gpredict.
(Reading database … 142550 files and directories currently installed.)
Preparing to unpack gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb …
Unpacking gpredict (2.2.1-ubuntu18.04~ppa3) …
dpkg: dependency problems prevent configuration of gpredict:
gpredict depends on libgoocanvas-2.0-9 (>= 2.0.2); however:
Package libgoocanvas-2.0-9 is not installed.

dpkg: error processing package gpredict (–install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) …
Processing triggers for gnome-menus (3.13.3-9) …
Processing triggers for mime-support (3.60) …
Processing triggers for man-db (2.7.6.1-2) …
Errors were encountered while processing:
gpredict


#10

Yes, it is available. You can also see it in the Raspbian Repository:
http://archive.raspbian.org/raspbian/pool/main/g/goocanvas-2.0/

That’s why in the past I have arrogantly replied to people that they need to make sure that they use Raspbian Stretch. It’s absurd, but I think something is broken in the Rasbian upgrade process. I bet it would work with a fresh install of Raspbian Stretch.

I’m sorry but I don’t use Raspberry Pi desktop, so every time I need to check something like this it takes me several hours to set up and prepare. I don’t have time to do that now, so please try a fresh install of Raspbian.


#11

Have you tried to check your sources.list and update your package db (apt-get update). The package is really in the distribution but your install does not seem to see it except it is being referred by other packages.


#12

@csete
Alex, thank again for the reply. I may wait it out a bit to see if something gets updated for the Stretch OS. After going through over 2hours of upgrade from Jessie yesterday, I’m not in the mood for a fresh install. Although, now that I think about it, it might be quicker. My problem is, and you’ll laugh, I don’t have enough micro SD cards. To do a fresh install, I’d have to wipe the one that’s in there, and I don’t want to lose the data that I have. I have to weigh my options over the next few days while I’m still on vacation. I could try from a USB drive, I suppose…


#13

@n5fxh
@csete

Well, interestingly enough, after running
$sudo apt-get update
$sudo apt-get upgrade (which didn’t work and it told me to then run…)
$sudo sudo apt --fix-broken install
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
libgoocanvas-common libgoocanvas3
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
libgoocanvas-2.0-9 libgoocanvas-2.0-common
The following NEW packages will be installed:
libgoocanvas-2.0-9 libgoocanvas-2.0-common
0 upgraded, 2 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 214 kB of archives.
After this operation, 1,686 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://raspbian-us.ngc292.space/raspbian stretch/main armhf libgoocanvas-2.0-common all 2.0.2-2 [114 kB]
Get:2 http://raspbian-us.ngc292.space/raspbian stretch/main armhf libgoocanvas-2.0-9 armhf 2.0.2-2 [100 kB]
Fetched 214 kB in 0s (294 kB/s)
Selecting previously unselected package libgoocanvas-2.0-common.
(Reading database … 142662 files and directories currently installed.)
Preparing to unpack …/libgoocanvas-2.0-common_2.0.2-2_all.deb …
Unpacking libgoocanvas-2.0-common (2.0.2-2) …
Selecting previously unselected package libgoocanvas-2.0-9:armhf.
Preparing to unpack …/libgoocanvas-2.0-9_2.0.2-2_armhf.deb …
Unpacking libgoocanvas-2.0-9:armhf (2.0.2-2) …
Setting up libgoocanvas-2.0-common (2.0.2-2) …
Setting up libgoocanvas-2.0-9:armhf (2.0.2-2) …
Setting up gpredict (2.2.1-ubuntu18.04~ppa3) …

I was able to run
$sudo dpkg -i gpredict_2.2.1-ubuntu18.04_ppa3_armhf.deb

which actually installed 2.2.1 on my Pi!!!

BUT!!! I still have the same original problem that even after updating the TLE file from the network, satellites AO-91 and AO-92 still shows up with their original FOX designations. This is different from my list on my Windows laptop. When I update the TLE, it says there are 504 missing satellites. Do I need to download a TLE file from somewhere else to get it updated properly?

Thanks again for all the help. Very strange how even though I thought the Pi was updated, it wasn’t…


#14

AO-91 is the same as Fox-1B.

As for AO-92, you probably need to add http://www.amsat.org/amsat/ftp/keps/current/nasabare.txt to the list of files to download under Preferences 🡒 TLE update.

These are mostly satellites and objects that have decayed. Sadly, there is not yet any easy way to remove them from gpredict.