Installing Gpredict binary on the Raspberry Pi 3

We do not yet have binary repository for Raspbian or Debian, but it is possible to install the binary .deb package from our Ubuntu repository. The following works for Raspbian Stretch:

  1. Go to Packages in “Gpredict releases” : Gpredict releases : “Gpredict Team” team and select the latest Ubuntu 16.04 package group (currently gpredict - 2.2.1-ubuntu16.04~ppa2)

  2. Download the armhf .deb file, currently gpredict_2.2.1-ubuntu16.04~ppa2_armhf.deb.

  3. Open a file manager and find the .deb file, usually in the Download folder. Right click and select Package Install.

This should install Gpredict and its dependencies. Gpredict will now be available under the Internet and Education menus.



Just tried this procedure but got an error saying:

Failed to install file
An unspecified transaction error has occurred.
More information is available in the detailed report.

I’m betting I won’t understand anything in the detailed report, but let’s say I can. Where do I find this detailed report please?

Ken Alexander, VE3HLS

Not sure, but you can try Raspberry Pi menu -> Preferences -> Add / Remove Software -> Options -> Package Log…

I just tried the procedure again and it is still working fine. So please make sure you are using an up to date version of Raspbian Stretch and that you download the correct package.

There is also an option to install through the command line using dpkg, though that’s certainly not easier :slight_smile:

Thanks Alex,

I am new at this so easy is what I need. There was no detailed report in the location you suggested. I will check first to make sure I have the correct version of Raspian Stretch. I dont know how to determine that so I will just go ahead and find and install the latest version I can find and start over.

thanks again!


Okay, let me know how it works. If it doesn’t we can try to find another way, though I am not a Raspberry Pi power user either.

The upgrade to latest Raspian Stretch did it! It installed right away and runs fine!

Thanks again Alex,