How to install satnogs with a raspberry pi 4?

I am new, I would like to install satgnos on my raspberry 4 but the artifacts image does not work on the raspberry pi4.
How should we do it?.
Best regards
Philippe

Hi Philippe,

I have a RPi 4 running the current satnog image from here:

https://wiki.satnogs.org/Raspberry_Pi

Did you verify the checksum of the artifacts.zip file before burning it to the SD card? Download/burn it again. Or try burning it to a different SD card (in case your original SD card is corrupt.).

1 Like

Hi
Thanks you for your answer.
I have test and check but is not the same version.Tomorow i tests this version on my Pi.

hello, i installed the image on my raspberry. But I can not connect to the network error message “failed for updated apt cache”. can you tell me?
Best regards
Philippe

What do you get if you run:

sudo apt-get update
sudo apt-get upgrade

Bonjour ,
Le Pi ce connect après la commande " sudo apt-get update " reviens avec une erreur 4.
signature invalid erreur de GPG
avec la commande " sudo apt-get upgrade " ne trouve pas de mise a jour apres avoir lue la liste des paquets fait les dépendances lectures des informations calculs de la mise jour.

Are you connected to a network? Can you successfully ping Google’s DNS server?

ping 8.8.8.8

If you have not setup the network connection, see:

for connecting to a wifi network.

Wired (ethernet) should connect automatically via DHCP. But it you want to set a static IP edit /etc/dhcpcd.conf (yes you configure a static IP in a file with DHCP in the name … don’t ask lol) and add something like:

#SatNOGS static IP
interface eth0
static ip_address=10.1.100.200/24
static routers=10.1.100.1
static domain_name_servers=8.8.4.4 8.8.8.8

apres le ping ttl 119 time 27.8 ms

1 Like

@f8avp check this https://wiki.satnogs.org/Troubleshooting#Invalid_Signature_for_download.opensuse.org

J ai effectuer la manip le raspi m indique " started SatNOGS RUNNING par contre dans le dashbord je suis toujours offline

Hello,
My station always remains offline.
I don t manage to be online. using journalctl -u satnogs-client I have no error message life
– Logs begin at Sun 2021-06-06 10:14:30 CEST, end at Sun 2021-06-06 10:23:54 CEST. –
juin 06 10:14:34 raspberrypi systemd[1]: Started SatNOGS client.
juin 06 10:14:38 raspberrypi satnogs-client[364]: Traceback (most recent call last):
juin 06 10:14:38 raspberrypi satnogs-client[364]: File “/var/lib/satnogs/bin/satnogs-client”, line 5, in
juin 06 10:14:38 raspberrypi satnogs-client[364]: from satnogsclient import main
juin 06 10:14:38 raspberrypi satnogs-client[364]: File "/var/lib/satnogs/lib/python3.7/site-packages/satnogsclient/__
juin 06 10:14:38 raspberrypi satnogs-client[364]: logging.basicConfig(format=settings.LOG_FORMAT, level=getattr(log
juin 06 10:14:38 raspberrypi satnogs-client[364]: File “/usr/lib/python3.7/logging/init.py”, line 1918, in basicC
juin 06 10:14:38 raspberrypi satnogs-client[364]: root.setLevel(level)
juin 06 10:14:38 raspberrypi satnogs-client[364]: File “/usr/lib/python3.7/logging/init.py”, line 1358, in setLev
juin 06 10:14:38 raspberrypi satnogs-client[364]: self.level = _checkLevel(level)
juin 06 10:14:38 raspberrypi satnogs-client[364]: File “/usr/lib/python3.7/logging/init.py”, line 195, in _checkL
juin 06 10:14:38 raspberrypi satnogs-client[364]: raise TypeError(“Level not an integer or a valid string: %r” % le
juin 06 10:14:38 raspberrypi satnogs-client[364]: TypeError: Level not an integer or a valid string: <function info at
juin 06 10:14:38 raspberrypi systemd[1]: satnogs-client.service: Main process exited, code=exited, status=1/FAILURE
juin 06 10:14:38 raspberrypi systemd[1]: satnogs-client.service: Failed with result ‘exit-code’.
juin 06 10:14:39 raspberrypi systemd[1]: satnogs-client.service: Service RestartSec=100ms expired, scheduling restart.
juin 06 10:14:39 raspberrypi systemd[1]: satnogs-client.service: Scheduled restart job, restart counter is at 1.
juin 06 10:14:39 raspberrypi systemd[1]: Stopped SatNOGS client.
juin 06 10:14:39 raspberrypi systemd[1]: Started SatNOGS client.
juin 06 10:14:41 raspberrypi satnogs-client[653]: Traceback (most recent call last):
juin 06 10:14:41 raspberrypi satnogs-client[653]: File “/var/lib/satnogs/bin/satnogs-client”, line 5, in
juin 06 10:14:41 raspberrypi satnogs-client[653]: from satnogsclient import main
lines 1-23
what must be done to have the one line station?
regards

Double check the Debug Level setting in satnogs-setup and make sure it’s set to DEBUG, INFO etc (not any of the integers)

Raise or Set the debug level

  • Run sudo satnogs-setup;
  • Go to Advanced Configuration and set the Debug level (see below)
  • Apply the change

Setting Value


CRITICAL 50
ERROR 40
WARNING 30
INFO 20
DEBUG 10
NOTSET 0

If that’s not the issue, post the output of given by Advanced -> Support so we can look at your individial configuration settings for more clues.

1 Like

here is file after parameter:
– Logs begin at Sun 2021-06-06 11:14:13 CEST, end at Sun 2021-06-06 15:05:58 CEST. –
juin 06 11:14:13 raspberrypi satnogs-client[5748]: File “/usr/lib/python3.7/logging/init.py”, line 195, in _checkLevel
juin 06 11:14:13 raspberrypi satnogs-client[5748]: raise TypeError(“Level not an integer or a valid string: %r” % level)
juin 06 11:14:13 raspberrypi satnogs-client[5748]: TypeError: Level not an integer or a valid string: <function info at 0xb65ab
juin 06 11:14:13 raspberrypi systemd[1]: satnogs-client.service: Main process exited, code=exited, status=1/FAILURE
juin 06 11:14:13 raspberrypi systemd[1]: satnogs-client.service: Failed with result ‘exit-code’.
juin 06 11:14:14 raspberrypi systemd[1]: satnogs-client.service: Service RestartSec=100ms expired, scheduling restart.
juin 06 11:14:14 raspberrypi systemd[1]: satnogs-client.service: Scheduled restart job, restart counter is at 1572.
juin 06 11:14:14 raspberrypi systemd[1]: Stopped SatNOGS client.
juin 06 11:14:14 raspberrypi systemd[1]: Started SatNOGS client.
juin 06 11:14:16 raspberrypi satnogs-client[5752]: Traceback (most recent call last):
juin 06 11:14:16 raspberrypi satnogs-client[5752]: File “/var/lib/satnogs/bin/satnogs-client”, line 5, in
juin 06 11:14:16 raspberrypi satnogs-client[5752]: from satnogsclient import main
juin 06 11:14:16 raspberrypi satnogs-client[5752]: File "/var/lib/satnogs/lib/python3.7/site-packages/satnogsclient/init.
juin 06 11:14:16 raspberrypi satnogs-client[5752]: logging.basicConfig(format=settings.LOG_FORMAT, level=getattr(logging, s
juin 06 11:14:16 raspberrypi satnogs-client[5752]: File “/usr/lib/python3.7/logging/init.py”, line 1918, in basicConfig
juin 06 11:14:16 raspberrypi satnogs-client[5752]: root.setLevel(level)
juin 06 11:14:16 raspberrypi satnogs-client[5752]: File “/usr/lib/python3.7/logging/init.py”, line 1358, in setLevel
juin 06 11:14:16 raspberrypi satnogs-client[5752]: self.level = _checkLevel(level)
juin 06 11:14:16 raspberrypi satnogs-client[5752]: File “/usr/lib/python3.7/logging/init.py”, line 195, in _checkLevel
juin 06 11:14:16 raspberrypi satnogs-client[5752]: raise TypeError(“Level not an integer or a valid string: %r” % level)
juin 06 11:14:16 raspberrypi satnogs-client[5752]: TypeError: Level not an integer or a valid string: <function info at 0xb65a7
juin 06 11:14:16 raspberrypi systemd[1]: satnogs-client.service: Main process exited, code=exited, status=1/FAILURE

Yes, it is complaining about the Log Level setting. Check your Log Level setting in satnogs-setup and make sure it is set to one of DEBUG, INFO, ERROR, WARNING, CRITICAL. And make sure the level is in all CAPITAL letters, it’s case sensitive (pretty sure).

if that’s not the issue, post the output of given by Advanced -> Support so we can look at your individual configuration settings for more clues.

1 Like

versions": {
“satnogs-client”: “1.5.1”,
“satnogs-client-ansible”: “202105301943”,
“satnogs-flowgraphs”: “1.3.1-1”,
“gr-satnogs”: “2.2.1.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14satnogs2”,
“satnogs-config”: “0.12”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2021-06-06T14:56:27.802430+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.17-v7l+”,
“version”: “#1421 SMP Thu May 27 14:00:13 BST 2021”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 1957195776,
“available”: 1690034176,
“percent”: 13.7,
“used”: 81612800,
“free”: 1351356416,
“active”: 241324032,
“inactive”: 288436224,
“buffers”: 62717952,
“cached”: 461508608,
“shared”: 94478336,
“slab”: 47419392
},
“disk”: {
“total”: 62526631936,
“used”: 3566403584,
“free”: 56365150208,
“percent”: 6.0
}
},
“configuration”: {
“satnogs_antenna”: “rx”,
“satnogs_api_token”: “[redacted]”,
“satnogs_log_level”: “DEBUG 10”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “230”,
“satnogs_station_id”: “2237”,
“satnogs_station_lat”: “45.379”,
“satnogs_station_lon”: “4.823”,
“sentry_dsn”: “d7c9e849f45cclele24ea2cc6a8b77ba4e94d987”,
“sentry_enabled”: true
}
This does not have to change above the parameters noted
Thanks for your help

“satnogs_log_level”: “DEBUG 10”,

Ah, change this setting in satnogs-setup to just read DEBUG by deleting the 10 part

“satnogs_antenna”: “rx”,

Maybe change this to RX in case it is case sensitive (not 100% certain of this but it won’t hurt)

1 Like

{
“versions”: {
“satnogs-client”: “1.5.1”,
“satnogs-client-ansible”: “202105301943”,
“satnogs-flowgraphs”: “1.3.1-1”,
“gr-satnogs”: “2.2.1.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14satnogs2”,
“satnogs-config”: “0.12”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2021-06-06T16:30:31.576412+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.17-v7l+”,
“version”: “#1421 SMP Thu May 27 14:00:13 BST 2021”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 1957195776,
“available”: 1662062592,
“percent”: 15.1,
“used”: 105693184,
“free”: 1312542720,
“active”: 245800960,
“inactive”: 322392064,
“buffers”: 67186688,
“cached”: 471773184,
“shared”: 98324480,
“slab”: 47300608
},
“disk”: {
“total”: 62526631936,
“used”: 3572727808,
“free”: 56358825984,
“percent”: 6.0
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_log_level”: "DEBUG ",
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “230”,
“satnogs_station_id”: “2237”,
“satnogs_station_lat”: “45.379”,
“satnogs_station_lon”: “4.823”,
“sentry_dsn”: “d7c9e849f45cclele24ea2cc6a8b77ba4e94d987”,
“sentry_enabled”: true
}
}This does not have to change above the parameters noted
Thanks for your help

What does the syslog show for error messages now that the LOG_LEVEL is fixed?

Also a reboot wouldn’t hurt if you haven’t done so recently.

1 Like

versions": {
“satnogs-client”: “1.5.1”,
“satnogs-client-ansible”: “202105301943”,
“satnogs-flowgraphs”: “1.3.1-1”,
“gr-satnogs”: “2.2.1.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14satnogs2”,
“satnogs-config”: “0.12”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2021-06-06T14:56:27.802430+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.17-v7l+”,
“version”: “#1421 SMP Thu May 27 14:00:13 BST 2021”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 1957195776,
“available”: 1690034176,
“percent”: 13.7,
“used”: 81612800,
“free”: 1351356416,
“active”: 241324032,
“inactive”: 288436224,
“buffers”: 62717952,
“cached”: 461508608,
“shared”: 94478336,
“slab”: 47419392
},
“disk”: {
“total”: 62526631936,
“used”: 3566403584,
“free”: 56365150208,
“percent”: 6.0
}
},
“configuration”: {
“satnogs_antenna”: “rx”,
“satnogs_api_token”: “[redacted]”,
“satnogs_log_level”: “DEBUG 10”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “230”,
“satnogs_station_id”: “2237”,
“satnogs_station_lat”: “45.379”,
“satnogs_station_lon”: “4.823”,
“sentry_dsn”: “d7c9e849f45cclele24ea2cc6a8b77ba4e94d987”,
“sentry_enabled”: true
}

I rebooted the pi it hasn’t changed
“versions”: {
“satnogs-client”: “1.5.1”,
“satnogs-client-ansible”: “202105301943”,
“satnogs-flowgraphs”: “1.3.1-1”,
“gr-satnogs”: “2.2.1.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14satnogs2”,
“satnogs-config”: “0.12”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2021-06-06T18:41:35.233065+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “raspberrypi”,
“release”: “5.10.17-v7l+”,
“version”: “#1421 SMP Thu May 27 14:00:13 BST 2021”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 1957195776,
“available”: 1748844544,
“percent”: 10.6,
“used”: 104050688,
“free”: 1536561152,
“active”: 104267776,
“inactive”: 256585728,
“buffers”: 27488256,
“cached”: 289095680,
“shared”: 21069824,
“slab”: 31412224
},
“disk”: {
“total”: 62526631936,
“used”: 3581693952,
“free”: 56349859840,
“percent”: 6.0
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_log_level”: "DEBUG ",
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “230”,
“satnogs_station_id”: “2237”,
“satnogs_station_lat”: “45.379”,
“satnogs_station_lon”: “4.823”,
“sentry_dsn”: “d7c9e849f45cclele24ea2cc6a8b77ba4e94d987”,
“sentry_enabled”: true
}
}
------------[ copy end ]-------------

if i trie systemctl pi answer is
● satnogs-client.service - SatNOGS client
Loaded: loaded (/etc/systemd/system/satnogs-client.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2021-06-06 20:43:10 CEST; 305ms ago
Main PID: 4619 (satnogs-client)
Tasks: 1 (limit: 3860)
CGroup: /system.slice/satnogs-client.service
└─4619 /var/lib/satnogs/bin/python3 /var/lib/satnogs/bin/satnogs-client

juin 06 20:43:10 raspberrypi systemd[1]: Started SatNOGS client.
thank you for your help

1 Like