How to configure gain - satnogs not nearly as good as gqrx

I’ve built a ~140 MHz VHF turnstile. When I connected it to my RTL-SDR and started GQRX, I had a great signal from e.g. NOAA-19, which completely suppressed noise. I then shortened the coax from 12 meters to 2 meters, and connected it to my satnogs station. Now, my satellite signals are hiding in the noise. I first tried with the default gain - I think that’s zero. I then increased to 25.4 dB - exactly same result. Now, I’m trying 49.6 dB gain, to see if that helps.

In GQRX, I can choose LNA gain (I don’t have an LNA, though), OR click “Hardware Gain”. Can I enable hardware gain in satnogs?

1 Like

The RF Gain option in the config is the amplifier built into the RTLSDR. (The gain setting in GQRX / SDR#)

Not sure what Hardware Gain is on GQRX

Okay. I’ve seen that an older version of GQRX also has something called MIX gain and BB gain, but it isn’t documented anywhere.

The funny thing is: Disabling HW gain in GQRX lets me play with the slider LNA gain, and it has a huge effect, even though I don’t have an LNA. It must be a built-in LNA in the RTL-SDR. I guess the HW gain button is some sort of AGC, which satnogs apparently does not utilize.

Hardware AGC (automatic gain control) is an option that rtlsdr exposes and changes dynamically it’s gain depending on the noise it receives, however it doesn’t work fine all of the times.

SatNOGS Gnuradio scripts don’t enable this option. So you will need to set the gain that rtlsdr will use (LNA Gain in Gqrx).

You will need to experiment to find the right one for your station, you can start by finding out in gqrx near what value you get the best results and then try the specific gains, around the gqrx value, in SatNOGS.

Note 1: About the specific gains, rtlsdr can get specific values as gain, you can find them either by running rtl_test in command line or in this wiki page.
Note 2: In SatNOGS for rtlsdr you will need to change only RF Gain, IF and BB gains are not used by this device.

4 Likes

Thanks for the clarification! I’ve now made a new observation of NOAA-19 with my gain maxed out at 49.6 dB, and it clearly makes no difference at all:
https://network.satnogs.org/observations/598892/

The signal is just as weak as with a gain of 0 dB. What can be the cause of this?

Could be your antenna is not well suited for NOAA observations.

But when I connect the antenna to my rtl-sdr, put my rtl-sdr in my laptop and use gqrx, I get a great signal, free from noise. That’s what puzzles me.

How is your waterfall adjusted in GQRX? It could very well be that the S/N ratio is identical between both software packages, but the waterfall in GQRX is adjusted a little bit differently and thus yields a “nicer” look? Just an idea.

–Roy
K3RLD

1 Like

I seem to have a similar problem with my station. My results with GQRX with RTL-SDR v3 are considerably better than when using SatNOGS. I tried some different gain values without obvious improvements.

1 Like

What ever came of this?

Same problem here…

Some more information about the OP’s station setup would be useful here.

I then shortened the coax from 12 meters to 2 meters, and connected it to my satnogs station. Now, my satellite signals are hiding in the noise.

This makes me wonder if there is an issue with noise radiated from the station itself, i.e. from a noisy switch-mode supply or similar. I have seen similar on stations powered by PoE injectors. Turn the PoE injector off and run the RTLSDR from a laptop, and the noise magically disappears…

1 Like

Did you find any solution? I’m having similar problems

I removed the poe’s, and the ethernet cable… I run a separate 220vac line to my satnogs box and configured wifi connection.
Inside the box I’ve put a original raspberry psu and now there isn’t any noise coming from my satnogs… But unfortunately, I have some of them coming from the neighbourhood…

1 Like

Changing RF gain seemed to make no difference for me either. Seems like it is not using the builtin LNA at all?

1 Like

@vk5qi I tend to agree with your assessment of the station gear itself contributing to the noise floor. Of course once you move the RTLSDR from the environment that’s suspect, such as to a laptop, etc… you automatically change the conditions you want to test against.

So what about leaving the RTLSDR, along with it’s PoE and other suspect noise sources in place, but use the rtl_tcp utility to “remote in” with GQRX (or SDR#, etc…) and assess the noise conditions that way ?

I’ve started to do that, along with using the rtl_power utility, to keep the conditions of the ground-station gear intact, but use different methods of looking at the RF environment/spectrum the RTLSDR is seeing. @0xCoto’s CygnusRFI utility (unveiled in this post) would also serve this remote-troubleshooting for RF noise quite well.

Do we think that doing things this way would be an advisable form of troubleshooting ground stations ?
Advisable in the sense that we recommend it to new folks trying to set up their ground-stations ?

Also, now that openwebrx has a new lease on life, I’ve wondered if ALL my ground stations should have some form of web-server accessibility to remote in and troubleshoot the listening conditions when I see issues with observations.

obviously the satnogs-client would be temporarily disabled while such troubleshooting was underway… but if these kinds of troubleshooting methods are useful, maybe they could be better documented as such and added to the troubleshooting portion of the wiki ?
(not asking for anyone else to take this on… I’ll be glad to help document these kinds of tools in the wiki as applied to these issues, just looking for others to confirm that they’re recognized and useful troubleshooting paths)

2 Likes

Last night I set my RF Gain to 19.7 instead of 49.6 - I now see that I completely missed the obvious before.

Since the waterfall image auto adjusts I didn’t notice before that the waterfall range is what changes. -100dB to -20dB now - before it was more like -60dB to 0dB.

I can imagine other people could make that mistake too and miss that the range changes with gain.

Using the hardware AGC would be a nice option though - necessary gain could be different in different bands.

The issue with the approach you mentioned is that you cannot disable power to the most likely noise source: the RPi and the PoE system powering it.

This is why I suggested using a laptop computer of some sort. Yes, it has the potential to introduce noise itself, but what you’re looking for is changes in the noise floor as you power various devices on and off.

73
Mark VK5QI

I just updated my client from 0.9 to 1.3.1 and set the RF_GAIN to 30 dB. Let’s see if that helps…

1 Like

…and it does! So my conclusion is that as of Satnogs client 1.3.1, the receiver gain is actually implemented! Case closed :slight_smile:

1 Like