Gpredict issues using hamlib rotctld dummy model

Hi, I am using hamlib rotctld with a dummy model to improve/test how to connect from a Linux VM from Frankfurt to control antennas in Aachen using a remote port forwarding ssh tunnel. Basically I am developing software to improve the use of such a tunnel and get reconnects when needed, try to get the connection between Frankfurt and aachen as robust as possible. The connection works all fine, but:

when satellites pass from Azimut 359° to 181° Gpredict Rotor Control reports “Read Error”. I guess that the dummy model (rotctld -m1) expect azimut in the format -180° to +180°

when satellites pass between Azimut 0° to 180° Gpredict Rotor Control reports correctly, and the rotctld running at Aachen does its job and reports that it is happy (RPRT 0)

Can I fix this in the Rotors interface configurator of Gpredict, or do I need to fix it in the dummy rotor model file (in Aachen)?

Best regards,

1 Like

Aaaaaah!! I discovered it right now. In the main GUI, under Edit/Preferences/Interfaces/Rotators, you select the rotator config name in question (where your connection to rotctld is defined). There, you select edit, and then, you can select the appropriate Az Type. Per default, this is set to “0°–>180°–>360°”.

If you are using the dummy rotator (Hamlib Deamon command: rotctld -m 1 -vvvvv), this shall be set to “-180° → 0° → +180°” to ensure correct functioning. To be sure, also check the following items are set correctly:
Min AZ: -180
Max Az 180
Azimuth end stop position -180

Important: Also, make sure you have closed the Window: Gpredict Rotator Control: Amateur, before you tackle the rotor configs, otherwise, it will not update the new configs nor notify you that the config has not been updated.

I oversaw/ignored this yesterday because at the time, I was not aware that the hamlib dummy rotator would only accept Az-values between: -180 to +180 :slight_smile:

Best regards from FH Aachen Space Operations Facility (FHASOF)
Sacha Tholl