Auto-scheduler unable to install

I have tried to install auto-sheduler on my ID-724 RPi using these instruction.


I didn’t get very far. I updated and installed the dependencies then…

pi@raspberrypi:~ $ source env/bin/activate
(env) pi@raspberrypi:~ $ pip install -r requirements.txt
ERROR: Could not open requirements file: [Errno 2] No such file or directory: ‘requirements.txt’
(env) pi@raspberrypi:~ $

root@raspberrypi:/home/pi/env# ls
bin include lib share

The env directory exists but there is no requirements.txt file
The RPi is runing on buster and has been upgraded to the latest 1.3.1 client

The next step would be:- Copy the env-dist file to .env and set your SatNOGS Network API token.

Copy from where? Copy to .env which is a hidden file so that would mean copy as root?

Looks like I’m in over my head again and need some help please.

Hi Bob, I had / have the same problem as you,

I’m not a computer guy, and I don’t know why but the second time I’ve tried to install the Auto-scheduler, the ‘requirement.txt’ error did not appear.

Then my understanding is that we need to copy the content from an installed file into a file which don’t have any name ( .env) (it could have been ‘blablabla.env’ if i’m not wrong), so we need to : cp env-dist .env

Then if you open this file (nano .env) you will see that this is a config file which take your API, you will then have the possibilities to put your API into this file, in the right place

This file looks like that :

# Copy this file to .env and complete the information needed

# Your SatNOGS network API token

NETWORK_API_TOKEN = ''

And I’ve done a small test, if you try to copy env-dist into another file like ‘test.env’ it will do exactly the same (cp env-dist test.env)

But then after doing all this things I still had another error trying to run the python file, and at this step due to my poor skills, I gave up until I find more information

I really hope one day to be able to install this program, I spend far too much time on my computer scheduling observations.