Adalm Pluto not working

Hi all,
I did successfully installed satnogs with a RTL SDR RX.
Upload of passes OK.

Now I wanted to use my Adalm Pluto as a RX.
I went thru all theses steps from this [documen] (Home · pothosware/SoapyPlutoSDR Wiki · GitHub)
After all I could check Pluto working with sudo SoapySDRUtil --probe it looks fine.
In satnogs-setup I set the parameters related to the document above.
Then I setup the satnogs-monitor.
The requested passes are shown but I never got a waterfall or spectrum as I got with the RTL SDR RX??!!
Everything looks fine but no upload!
Does somebody already uploaded passes with a Adalm Pluto?
TNX for suggestions.

Does it work with other sdr software, i.e SDR++?

Good day Armin,

I guess you also asked Mike DK3WN for support, did he forward my reply?

I have following questions:

Can you share the output from the following commands:

  • SoapySDRUtil --info
  • SoapySDRUtil --probe="driver=plutosdr

Run sudo satnogs-setup and share the output from Advanced -> Support

This information then can be used to do some further investigation. I don’t have a Pluto but maybe other can also help in getting this up and running @SA2KNG @pe2bz


Hi Jan, yes it was me with Mike.
Thank you for answer.
We are analyzing the journalctl file.
Here we did found an ERROR message that the proposed sample rate of 2e6 is not supported.
Only standard sample rates known from the soundcards are supported?!?
I will try to contact theses OM.
Best 73

Then I guess the plutosdr isn’t recognized, but the commands I shared will produce information that will help us find a solution.

Hi Jan, here the screenshots:

You see we are using not driver=plutosdr as we found in another paper just to use it as written.
We are HB9ARK and me as you can see from the prompt.

Thank you for support.
I just got the message that I can send only one picture. I will send direct by mail to you


You are an using Soapy 0.8 module and it seem this was build from source.

This will not work with a SatNOGS rasberri Pi image, it is build around Soapy 0.7.

You need to install the driver from the repository sudo apt-get install soapysdr0.7-module-plutosdr

But first I need to be sure what kind of SatNOGS install was used, I need more information from this setup.

Ok, this was asked here as well (:

These are my satnogs settings, it’s a good start to get it up and running:


the PPM needs to be 0 or not set, you have to correct this with the: fw_setenv xo_correction xxxx

Depending on OS you will have to bring up the usb-ethernet interface that the pluto creates, on debian it’s /etc/network/interfaces and it’s friends.

I’m using my docker images so I don’t install anything else on the host, if running on the host you probably need the soapysdr-module-plutosdr from satnogs repo.

Hi Jan, this sounds hot!
I did download the image from satnogs.
During the different steps I got this message:

I was confused about this?
I will try to send you the steps direct per mail.

For consistency and future reference, please keep the conversation here, else many people will work on the same problem and no one can be helped by this in the future.

That kernel upgrade message is normal and just suggesting you reboot to apply it.


I’ve changed your user status, so now you will be able to upload more files/images here.

To keep the information in one place and available for all / other users I also will paste my email reply in this topic and keep my answers over here:

As Daniel says, except I am also OK with up to 6e6 for samp_rate

Added to that, I tend to “watch” my satnogs station with
sudo journalctl -f -u satnogs-client -n 512

which gives me output as soon as an observation starts, which usually leads me to the source of the problem if something fails.
If nothing fails it could look like this:

Dec 15 08:08:55 raspberrypi satnogs-client[9829]: Observation: 6875767, Norad: 33591, Name: NOAA-19, Script:, Baud: 2400.0, Frequency: 1544500000
Dec 15 08:08:55 raspberrypi satnogs-client[24284]: rig_init: rig does not have rx_range!!
Dec 15 08:08:55 raspberrypi satnogs-client[24284]: network_open: hoststr=, portstr=4532
Dec 15 08:08:59 raspberrypi satnogs-client[9842]: [INFO] Opening PlutoSDR #0…
Dec 15 08:09:00 raspberrypi satnogs-client[9842]: [INFO] Using format CF32.
Dec 15 08:09:00 raspberrypi satnogs-client[9842]: [INFO] Auto setting Buffer Size: 131072
Dec 15 08:09:00 raspberrypi satnogs-client[9842]: [INFO] Set MTU Size: 131072
Dec 15 08:09:00 raspberrypi satnogs-client[9842]: [INFO] Has direct RX copy: 1
Dec 15 08:24:15 raspberrypi satnogs-client[24284]: netrigctl_close: done status=Command completed successfully

Good luck !


I did try to “downgrade” from V8 to V7 using
sudo apt-get install soapysdr0.7-module-plutosdr

After this --probe shows this

Still V8??

what os version is this ? debian(raspbian) bullseye and the satnogs repos only contain 0.7

I do recommend you use those packages instead of building from source.
if building from source then make sure you checkout the correct version.

here’s a test script I use to test the flowgraph settings. it works on a ansible install and my docker images. if on a custom client you will need to start the doppler control rigctld -T -m 1 manually.

If you need help adding the satnogs repos, as root (not sudo), with wget installed:

echo "deb ./" > /etc/apt/sources.list.d/satnogs.list
wget -qO - | gpg --dearmor -o /etc/apt/trusted.gpg.d/satnogs.gpg

Please answer the questions I asked before, we need a baseline.

Hello, I’m working on a similar system. I have the following error that I can’t make sense of.
I have done the following steps till now.

  1. Using the satnogs image on RPi4, I installed plutosdr.
  2. Checked that satnogs client and plutosdr setup are according to the manual guide.
  3. Scheduled the observation and at the time of observation the above error pops up in the live error log.

How do I proceed to run the system?

File “/var/lib/satnogs/lib/python3.9/site-packages/satnogsclient/observer/”, line 233, in observe
Dec 16 16:08:46 raspberrypi satnogs-client[2682]:
Dec 16 16:08:46 raspberrypi satnogs-client[2682]: File “/usr/lib/python3.9/”, line 349, in call
Dec 16 16:08:46 raspberrypi satnogs-client[2682]: with Popen(*popenargs, **kwargs) as p:
Dec 16 16:08:46 raspberrypi satnogs-client[2682]: File “/usr/lib/python3.9/”, line 951, in init
Dec 16 16:08:46 raspberrypi satnogs-client[2682]: self._execute_child(args, executable, preexec_fn, close_fds,
Dec 16 16:08:46 raspberrypi satnogs-client[2682]: File “/usr/lib/python3.9/”, line 1823, in _execute_child
Dec 16 16:08:46 raspberrypi satnogs-client[2682]: raise child_exception_type(errno_num, err_msg, err_filename)
Dec 16 16:08:46 raspberrypi satnogs-client[2682]: FileNotFoundError: [Errno 2] No such file or directory: ‘436848700’

This is a PRE script error, make sure SATNOGS_PRE_OBSERVATION_SCRIPT is correct.

Indeed, remove the script option, what currently is configure isn’t pointing towards a script file.

I also have a question:

What documentation did you use that tells you to build Soapy from source?
I really would like to know, because that isn’t necessary and will create extra issues.

Hi all,

I have decided to stop using Pluto as an RX with Pi and satnogs.
For me as a rf-hardware man the handling is becoming too complex.

I will use now satnogs with a RTL SDR wich works fine.
My interest to use Pluto as RX was as it offers much bigger bw than RTL SDR.
I hope that there will be published an easy way to use Pluto with Pi as RX for satnogs.
Thank you all for your support!

1 Like

Well, you mostly don’t need high bw for the usual obs. I really like the pluto and despite it could do with some improvements in the fw it’s still a very nice sdr.

Regarding simplicity, we have worked on getting the software packaged for satnogs and tested to make sure it really works out of the box. This is complicated by the fact that many guides still insist you build it from source, which will inevitably make it harder to manage for the regular user.

I don’t use satnogs-client on the host anymore, it’s all in docker for me sine a few months ago. But if you’re interested I could write a small guide for the pluto on a raspberry pi with satnogs-client, but it will require a clean system, like following the install from scratch.