Yeasu rotor engaging with Gpredict on Linux

Hi everybody,

I am working on autonomous ground station. i’am working under ubuntu 20.04 LTS (Not the last 20.04.6LTS)

Setup ::

Rotor :: YAESU G-5500DC and GS-232B (encoder)
Carte :: Jetson Nano 4Gb (LINUX-Ubuntu20.04LTS)|| Computer (LINUX-Ubuntu20.04LTS) 
Tranceiver :: Hack RF One (and next Adalm-Pluto)
Hardware :: filter and LNA for antenna

I connect the computer to the GS232b encoder (du to USB to serial) witch is connect to AZ-EL dual controller box witch is connect to the two motors.

So I am encountering one principal problem without issues and i start to be desperate

I am using “Rotctl” thank to the last “Hamlib” library version.

When I open a terminal and use “” sudo rotctl -m 603 -r /dev/ttyUSB0 “” as command, everything works good. Sometimes little bug but it’s happened.

But the real problem comes with Gpredict using, when i try to connect the system at Gpredict, i don’t succeed to enable the following-up thanj to the engage button on the control rotor panel… And really don’t know why …

I edit my rotator (port 4533 and Azmuth type) and my ground station (localisation). I force thank to “minicom” my serial port on ttyUSB0 also

But when i go through the ‘antenna control’ menu, when i press “engage button” during any satellite rush nothing happened … (even with little tolerance and cycle)

Do not hesitate to ask some others informations and i’ll try to put some new about the next week !

Thx you all,

Vivi973

If it helps I’m setup like this.

1 Like

Hey, thank you really much [ve6kdx];

Yes for me it’s the same

and when I use track and engage for the motor nothing happened … But maybe it’s me who is forgotting something … You just have to connect all the systeme and normay it’s working …

Callback : I use Ubuntu 20.04 LTS and last version of Gpredict

@Vivi_973 This is what I use with my Aurdinio controlled satnogs rotator and it works.

rotctld -m 202 -r /dev/ttyACM1 -s 9600 -t 4533 -C timeout=500 -C retry=0 -vvvvvv

timeout and retry were the key for my setup to work with Gpredict

1 Like

OKKKKKKKKKKKKKKKKKKKKKKKKKKKK, I am soooo sorry for this waste of time, since one month I just forgot to put the “d” at the end of “rotctl” :sweat_smile: :scream: :scream: :scream: :scream: :scream:

With “rotctld” indeed that work perfectly !!! (Almost)

When u write your command :
" rotctld -m 202 -r /dev/ttyACM1 -s 9600 -t 4533 -C timeout=500 -C retry=0 -vvvvvv"

  • m is for the model (603 for me)
  • r is the path
  • s for the BaudSpeed
  • C for config parameter (as timeout and other)

But for the two next i don’t really understand :

  • t → for force the serial port ??
  • vvvvv → What is for this ?

Thank a lot for this help !!! You really help us !

Now it’s almost working, we can track and engage the rotor correctly … indeed it’s easier with an server :rofl:

We just don’t understand why the reading have some error during the tracking … (Photo)

Any idea ?

Moreover, as I want the ground station autonomous, i’m planning to have a little executable to accurate data and pilote my rotor with the extraction of the gpredict data, someone think it’s possible or not ? The goal is to use less of ressources (energie) during pass.

Sill thx you [satcolintel5] :grinning:

Soon

-t is just to explicitly define which port rotctld will be listening on, it’s the default port so it’s being redundant. -vvvvv... is just telling rotctld to be more verbose in the the debug/log output.

My guess is if it works sometimes but not others, you might want to fiddle with the baud rate (4800/9600) and/or timeout setting (increase most likely) … one at a time of course!