Yaesu G-5500 through "COM-232B" controller - both azimuth and elevation are way off

My G-5500 works just fine - the analog meters on the control box match the actual az/el angles perfectly. So instead of paying 950 USD for an original Yaesu GS-232B (which I, perhaps unreasonably, consider a glorified level shifter), I went with a cheaper, Chinese model by BH4TDV:

However, azimuth angles reported by rotctl (model 603) are too low by a factor of 1.5, and elevation angles are too low by a factor of 2.3, see this graph:


I took it apart to see if there’s anything to adjust, but there’s absolutely nothing to change inside:

This page discusses - and links to - a calibration program, but it’s Windows only, and I’m using Ubuntu. And I can’t get wine to run it - it crashes every time I try to access the serial port. Besides, I doubt that this program would solve the problem - I suppose it’s for calibrating minor, percent-wise discrepancies, not large deviations like the one I’m experiencing.

Any suggestions?

Might be K3NG rotator running on it, then look at the command reference both the O/F and O2/F2 sets this. It might have the backslash commands enabled also.

I’m sorry, but I have no idea what you’re talking about…? I am not using the K3NG controller, just rotctl on a Linux laptop connected to the COM-232B controller depicted. And what do you mean with those commands? I do to think they’re rotctl commands…?

the K3NG rotator is the firmware running on a control interface, either they have rolled their own on the COM-232B or just using K3NG (rotctld talks with this).
In any case, the calibration for the analog values that the position represents is adjusted in the microcontroller with the commands I mentioned.
There is also the pots on the backside of the rotor controller that sets the full scale value, this could get you close, but usually you still need to set the calibration value on the interface to the actual value.
It is not specifically rotctl command, as they are an abstraction away from hardware, but specific yaesu commands.
Open up a terminal on the serial port and type them in, assuming you have set the correct baudrate and such, it should just reply or execute the move you commanded.

Oh, I didn’t realise I just had to open a serial connection! Thanks! But what baud rate? I’ve tried 1200, 9600 and 19200, and I’m not getting any response at all. According to the command refence you linked to, it should report elevation and azimuth angles with B or C (capital letters), but any and all input I make doesn’t result in anything.

There’s an LED on the COM-232B which blinks as I type on my laptop, so it’s definitely connected. I’m just not getting any response. Which is funny, because rotctl succesfully reads and commands…? What can I do?

Follow-up: When I successfully run rotctl, I use 9600 as baud rate:

$ rotctl -m 603 -r /dev/ttyS0 -s 9600 

Rotator command: p
Azimuth: 2.00
Elevation: 0.00

Rotator command:

But when I connect with 9600, e.g. using tio, I’m not getting anything:

$ tio -b 9600 /dev/ttyS0
[tio 15:51:58] tio v1.32
[tio 15:51:58] Press ctrl-t q to quit
[tio 15:51:58] Connected

I can enter B <enter> or C <enter> all I want, nothing happens…

EDIT: And it’s not responding to any Yaesu, Easycom, DCU-1 or Backslash commands…

If it is working with rigctl and not a terminal, either the terminal settings is wrong, or just not sending the commands that it will respond to.
One common mismatch is the newline settings, the device might be expecting CR, LF or both, and will not respond properly when the other is sent.
I am not sure how to set this in tio, I’m using minicom and that can control newline.

1 Like

Well, this is frustrating, to say the least. Connecting with rotctl -m 603 -r /dev/ttyS0 -s 9600 always works. And if I then start minicom with

$ minicom -D /dev/ttyS0 -b 9600


  • ctrl-A Z E to enable local echo, so I can see what I type,
  • ctrl-A Z U to Add carriage return ON

-I’m still getting no response (I’ve even tried with sudo with the same result):

Welcome to minicom 2.8                                                            
OPTIONS: I18n                                                                     
Port /dev/ttyS0, 23:21:21                                                         
Press CTRL-A Z for help on special keys                                           

CTRL-A Z for help | 9600 8N1 | NOR | Minicom 2.8 | VT102 | Offline | ttyS0

UPDATE: Minor breakthrough, while playing with the settings, I’ve entered a lot of B <enter>, and when I turned “Hardware flow control” to OFF, it suddenly replied


However, I can’t do it again - I have to turn HW flowcontrol ON and then OFF again, and then it replies to me! Would you happen to now if there is an easier way to communicate with the box than turning HW flow control on and off all the time?

yeah, that should be off. if it’s a modern device it is usually just rx, tx and ground connected. and no xon/xoff flow control either.
In rigctl/rotctl there is also a few additional oddities, as some of the radios and rotators had really bad implementations, delays between characters and commands is not uncommon. for example ft847. I’m hoping that this is not the case with that controller you have.

1 Like


If you can’t calibrate the controller to the G-5500, you might be able to match the output signal from the G-5500 to a level that the controller is expecting.

On the back of the G-5500 there are four potentiometers which can be reached with a screwdriver. There are two per axis, one for the analog meters on the front, and one for the feedback signal output to the controller.

If I remember correctly the outer two adjust the front meters and the inner two adjust the amplitude of the controller feedback signal.

1 Like

Would you happen to have a list of exact settings for minicom to work? I’m sure the right settings would do the job, because rotctl works perfectly and answers immediately. But so far, I’ve only managed to get minicom to give me a response twice - both times the moment I selected HW flow control OFF, but then it goes quiet again.

Thank you for your suggestion! I hadn’t tried that, but unfortunately, it didn’t quite do the trick. I had turned my elevation to 45°, and rotctl read 19°, so I started turning, but I could only make it go as far as 28° before I hit the stop.

Dosent the Yaesy controkler have a couple potebtiometrs that you can adjust to get the calibration correct? It was a few years ago I had one but I seem to to remember that you could adjust these potentiometers to get the serial interface to correct position.


Regarding the pots, I don’t have that controller, but a G800 and KR500 combined to run a DIY G5500.
The Yaesu controller has the same kind of pots, but does not go the entire span either iirc.
To get them to align properly with the K3NG I had to calibrate the firmware where the 0 and 360 was.

This has to match what the firmware in the controller expects, so not really possible from my end.
If you look at the code you can see that the model original model 603 / GS-232B expects \r which is Carriage Return.
Do note that the different A/B models all expect \r but send different combination in the response.

No flow control, carriage return. Might get away with \r\n as the device might ignore the extra \n.
Hints here as well.

1 Like

Thank you for your reply! I’ve managed to figure out that you can actually send commands as specified in the Yaesu GS-232B manual through rotctl with the w command, so w O set the origin, and w F sets azimuth fullscale. That did the trick, and it works now!

How rotctl manages to communicate with the controller when I can’t remains a mystery. Oh well, I can use my rotor now!

Thank you so much for your help!

Aha, very nice (: glad to hear it is working, awesome !