Wrong azimuth/elevation

Hi everyone,
I have built the Satnogs Rotator V3.1 and the SatNogs controller v2 (but the september 1st 2017 version)

  • I’m using the SparkFun’s Arduino Pro Mini 328 dev-board with ATmega328p
  • I’m using stepper motor 17HS19-2004S1.
  • I’m using original pololu drivers A4988.with 68mOhm resistor
  • I have adjusted the current of the drivers to 1.088 volt
  • I use the Full Step option (I have checked the right components and solders for this option)
  • I use the UART communication port
  • I do not have the optionals rotator encoders.
  • I use the latest arduino stepper_motor_encoder firmware

First, I have to change some values in the rotator_pins.h file, according to the version of my board.

  • M2SF to pin 10 instead of pin 6
  • SW1 to pin 9 instead of pin 5
  • M1IN1 to pin 6 instead of pin 10
  • M1IN2 to pin 5 instead of pin 9

I have set these variables as this, according to the Full step configuration :

  • RATIO 54
  • MAX_SPEED 300
  • SPR 200

When I am connected to the controller, I enter <EL90> for setting the elevation angle to 90 degrees. The rotator move but stop to aproxymatly 45 degrees :frowning:
If I enter <EL180>, its stop to approxymatly 110 degrees.
Same with azimuth (<AZ90> result about 45 degrees, <AZ270> results about 190 degrees).
I have tested errors with the <GE> command and get response 1.
Same with the <GS> command.

I guess something miss me… Please help


1 Like

Hi hubert, greetings from Buenos Aires Argentina. I recently started building the rotor, and I run into the same problem as you, could you fix it? Could you help me?

From already thank you very much!

Pd sorry for my English I use the translator.

Hello Roberto, best 73’s
Unfortunately, I have not solved my problem. Actually I am building a new board, may be a wrong solder and/or a wrong component. This time, I have choose the last version of the board instead of the version with the big fuse.
And you, have you fix it ? I am interressing in it.

F5MZE - Hubert