Wiki tab no longer works

Just clicked on the Satnogs wiki tab and got this.

Whoops! The default skin for your wiki, defined in $wgDefaultSkin as chameleon , is not available.

Your installation seems to include the following skins. See Manual: Skin configuration for information how to enable them and choose the default.

  • monobook / MonoBook ( disabled )
  • timeless / Timeless ( disabled )
  • vector / Vector ( disabled )
  • chameleon / chameleon ( disabled )

If you have just installed MediaWiki

You probably installed from git, or directly from the source code using some other method. This is expected. Try installing some skins from mediawiki.org’s skin directory, by:

Doing this should not interfere with your git repository if you’re a MediaWiki developer.

If you have just upgraded MediaWiki

MediaWiki 1.24 and newer no longer automatically enables installed skins (see Manual: Skin autodiscovery). You can paste the following lines into LocalSettings.php to enable all installed skins:

wfLoadSkin( ‘MonoBook’ ); wfLoadSkin( ‘Timeless’ ); wfLoadSkin( ‘Vector’ ); wfLoadSkin( ‘chameleon’ );

If you have just modified LocalSettings.php

Double-check the skin names for typos.

I don’t understand why & how this came about. I’m a firm believer in If it’s not broken don’t fix it so I have done nothing to bring this about and I don’t understand what this means and how to fix it? I would appreciate if someone could point me in the right direction. I’m not a programmer. My skills are strictly hardware.

Thanks in advance, 73 Bob vk2byf

Can you describe detailed steps to reproduce?

I’ve tried from both network.satnogs.org and db.satnogs.org the wiki links (on the header menu at the top) and both work fine and load https://wiki.satnogs.org/Main_Page.

1 Like

from the network page I just clicked on the Wiki tab at the top of the page which took me to https://wiki.satnogs.org/Main_Page which used to take me to the wiki page but now I get the above message instead.

I did not do any upgrades as everything is running just fine. Did I miss an upgrade or perhaps there was an automated upgrade which needed some intervention?? No idea. Have to go out for a while so there will be a delay before I can respond again.
Bob

That’s very strange, not sure what is going on as I can not reproduce it.

Some generic steps that may solve or help with the issue:

  1. Try hit Ctrl+F5 on the wiki page, maybe something cached causes the issue
  2. Try to visit this page, https://wiki.satnogs.org/Special:Preferences#mw-prefsection-rendering and if it opens check the available skins and maybe choose another skin and save it.
1 Like

@fredy I tried this while logged in and not logged in, in “incognito” mode and not, with Firefox and Chromium and I’m unable to reproduce.

@vk2byf The wiki page has nothing to do with any upgrades on your satnogs-client (e.g. your Raspberry Pi if that’s what you use). Are you logged in to the wiki or viewing anonymously?

1 Like

It works normally again.
I did nothing to fix it.
Even left the PC running while I was out.
Previously I was logged in when I tried to access the wiki page.
All good. Thank you all for your responses.

2 Likes