What i can do to get an better result? Observation 3868633: NOAA 19 (33591)

Regarding Observation 3868633

HI all, can you give me some input what I can do, to get a better result?
According to the Audio, it is not so bad, but also not so good.
I know, it is one of the powerful Satellites.

In January, I changed the SDR stick to a better one (Nooelec NESDR SMArt v4) SDR, since that, I have a much better result.
The Raspberry is direct by the Antenna.
I use the Turnstyle antenna from Wimo … so hmm

I also try to use GSM for fine-Tuning the offset (+18ppm was my result and my offset)

Mby anyone can Share his Settings, to get a feeling how you set up.

Thank you for some hint.

For a NOAA satellite, I think that signal looks pretty good! You could possibly improve performance using a separate preamp, but for the 2m band it may not be necessary.

However, given the image decoding performed badly, I’m wondering if your station is having overrun issues? I see a lot of other observations that have returned artifacts (waterfall, audio), but have been marked as failed.

What kind of Raspberry Pi are you using?

Hello and thank you for your replay,
I use a Raspberry Pi 3B Rev 1.2
Should i replace to a Raspberry Pi4 ? you think, it will be better

Satnogs-client 1.4

My last load:

top - 08:39:30 up 77 days, 15:30, 1 user, load average: 0,00, 0,00, 0,00
Tasks: 108 total, 1 running, 107 sleeping, 0 stopped, 0 zombie
%Cpu(s): 1,6 us, 0,2 sy, 0,0 ni, 98,2 id, 0,0 wa, 0,0 hi, 0,0 si, 0,0 st
MiB Mem : 924,8 total, 159,3 free, 379,6 used, 385,9 buff/cache
MiB Swap: 924,8 total, 923,8 free, 1,0 used. 440,1 avail Mem

Hmm, a Raspberry Pi 3B should be fine…

Indeed it should be fine. @stoffl I suggest you look into the logs by running journalctl -u satnogs-client.service -f and check if you see any O’s or o’s. If yes then you may need to reduce a little the sample rate you use, in order to find which sample rates are supported for your device check this guide.

Thank you,
the log is clear.

My used SampleRate Rate is: 2.048e6 according to the documentation.

Possible SampleRates for my device:
Sample rates: 0.25, 1.024, 1.536, 1.792, 1.92, 2.048, 2.16, 2.56, 2.88, 3.2 MSps

i reduced the gain - but I think it’s worse than before.


i set it back to 49.5 now

Hi, what value did you use? Signal looks still very strong compared to observations of others. Could the SDR be over powered? I don’t know what the limit is for your SDR, but I think my RTL-SDR-V3 has a limit of -10 dbm. Your waterfall is also in that range. Could you try something like 20 or 30db gain? And the pass should be comparable. The second observation you link is very low on the horizon and hard to compare to the others. That is just my 2 cents…

1 Like

i reduced to 38 or 36 nopt remember exactly.
should i go to 20?

Yes I would try that. I used some thing like 25dB gain, so that is worth a try. I used an indoor V-dipole and got: https://network.satnogs.org/observations/3636642/
But I have different sdr. Not sure if we can compare them like this.

1 Like

ok - thank you for your support let me try :slight_smile:


From what I’m seeing of the observations, there is no need to lower the gain here. With a RTLSDR hooked straight up to the antenna, the only time you would need to lower the gain from ‘full’ is if the SDR is being overloaded with local noise. If a preamplifier is used, then lowering the gain on the RTLSDR is necessary to avoid overload due to the stronger signals from the preamp.

In this station’s situation, that isn’t the case, so lowering the gain is only going to reduce the sensitivity of the station, so is not recommended.

Ok I can understand.

I couldn’t see any disturbances in the waterfall. Also, if I use WEB SDR - to check on Radio Station, with this stick.
I also have no significant disturbances in the environment.

In my case, there is no more optimizing without hardware change possible?
mby I need another Stick to get a better result.
Of course, tracking would also make sense.

What is a best practice setup for a good working Station?
According to the Docs, i can only read RTLSDR or Similar - what will be a good solution?

I can’t add my Yaesu Radio for it :D, but it will be one of the best choice.

My next steps will be:

  • check the Gain with 20, if needed back to max gain.
  • another position from Antenna (mby some reflection or not good other things QRN)
  • Analyse my Antenna again, to see if there is any difference since my last check
  • Recheck the RTL SDR and again Calibrate if needed over GSM

I haven’t any more ideas …

A reinstallation from RPI? If there is any setting or whatever broken from the Upgrade V1 to 1.4.

Interesting experience you share, I followed:
It approaches the setting of the gain from the low setting and increase until the noise floor rises. I followed this and came to a value of about 25 db gain. Do you say the opposite? Start with full gain and only reduce when you see overloading? How can we properly recognize overloading?

Well, it depends on your local noise environment too. If you are limited by local noise (as it seems you are) then increasing the gain further may not help.

However, in a situation where local noise is not the issue (as seems to be the case at @stoffl’s station), then going for maximum gain (and hence lowest noise figure) will give the best sensitivity.

Check how noisy the environment is on the air. A filter may be needed.

And the total gain of the LN amplifier and RTLSDR internal amplifier must not exceed 50.