Waterfall in all uploads seem to have rf gain set to zero regardless of config

My RF gain doesn’t seem to be setting on observations, so they upload as very near waterfall blanks.

I have a recent install on two almost identical groundstations that are recently updated. Only difference is antenna. Nooelec nano3 SDR . Quadfilar antennas for both.

When I follow the wiki instructions to set the gain, around 30 was correct for no LNA and with a 20 dB LNA around 10 was correct for both stations. Given that I’m setting up in an aluminum siding house I’m not getting good signals but I don’t expect it until final installation in the rafters of a high garage attic. However connecting to cubicSDR remotely I get excellent reception of local broadcast FM, NOAA weather radio, etc. If I turn the gain way down to zero I get a blank waterfall and crank it up to 45 and its pure white (and somewhat distorted) as you’d expect. I have the exact gain figures written down somewhere, but UHF was a little higher around 13 and VHF was around 10 with my LNA to cause the noise level to boost with cubicsdr. Anyway the point is not using satnogs software but using soapysdr and connecting remotely and using cubicsdr on my desktop the hardware works really well with sensible results.

However, it doesn’t seem to matter how I configure in satnogs-setup, regardless if I set satnogs_rf_gain to 0 or 45 or anywhere in between, the uploaded waterfall is pale blue with some noise, birdies but generally not much signal as if the gain is set to zero rather than the configured value. That seems kinda weird to me.

Uploads and connection to the network are fine, its just low RF levels. On both systems.

I set debug level to debug and didn’t see any interesting error messages. It does log every doppler correction freq change which is a lot of logs, but searching at the start and end found no errors.

The entire config in satnogs-setup using option “Show” can be seen below, obviously this was a during high gain run, although setting it to zero has no change in waterfall output:

│satnogs_antenna: RX│
│satnogs_api_token: (deleted)│
│satnogs_log_level: DEBUG│
│satnogs_rf_gain: '45’│
│satnogs_rx_samp_rate: 2.048e6│
│satnogs_soapy_rx_device: driver=rtlsdr│
│satnogs_station_elev: '290’│
│satnogs_station_id: '1510’│
│satnogs_station_lat: '43.028435’│
│satnogs_station_lon: ‘-88.250514’

I set my RF gain in the Advanced settings its not in Basic settings.

SoapySDRUtil --probe reports


Soapy SDR – the SDR abstraction library


Probe device
[INFO] [UHD] linux; GNU C++ version 8.3.0; Boost_106700; UHD_3.15.0.0-2

RtApiAlsa::getDeviceInfo: snd_pcm_open error for device (default), No such file or directory.

Found Rafael Micro R820T tuner
Found Rafael Micro R820T tuner

– Device identification


– Peripheral summary

Channels: 1 Rx, 0 Tx
Timestamps: NO
Other Settings:
* Direct Sampling - RTL-SDR Direct Sampling Mode
[key=direct_samp, default=0, type=string, options=(0, 1, 2)]
* Offset Tune - RTL-SDR Offset Tuning Mode
[key=offset_tune, default=false, type=bool]
* I/Q Swap - RTL-SDR I/Q Swap Mode
[key=iq_swap, default=false, type=bool]
* Digital AGC - RTL-SDR digital AGC Mode
[key=digital_agc, default=false, type=bool]

– RX Channel 0

Full-duplex: YES
Supports AGC: YES
Stream formats: CS8, CS16, CF32
Native format: CS8 [full-scale=128]
Stream args:
* Buffer Size - Number of bytes per buffer, multiples of 512 only.
[key=bufflen, units=bytes, default=262144, type=int]
* Ring buffers - Number of buffers in the ring.
[key=buffers, units=buffers, default=15, type=int]
* Async buffers - Number of async usb buffers (advanced).
[key=asyncBuffs, units=buffers, default=0, type=int]
Antennas: RX
Full gain range: [0, 49.6] dB
TUNER gain range: [0, 49.6] dB
Full freq range: [23.999, 1764] MHz
RF freq range: [24, 1764] MHz
CORR freq range: [-0.001, 0.001] MHz
Sample rates: 0.25, 1.024, 1.536, 1.792, 1.92, 2.048, 2.16, 2.56, 2.88, 3.2 MSps

journalctl -u satnogs-client.service is extraordinarily verbose in DEBUG mode but doesn’t report any errors or have any commentary at all about gain settings.

Advanced - Support looks like this:

Generating support report. Please wait…
------------[ copy here ]------------
“versions”: {
“satnogs-client”: “1.3.1”,
“satnogs-client-ansible”: “202004031132”,
“satnogs-flowgraphs”: “1.1.1-1”,
“gr-satnogs”: “2.1.2-1”,
“gr-soapy”: “2.1.2-1”,
“gnuradio”: “”,
“satnogs-config”: “0.10.1”
“state”: {
“is-applied”: true,
“pending-tags”: null
“system”: {
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “satnogs-uhf”,
“release”: “4.19.97-v7+”,
“version”: “#1294 SMP Thu Jan 30 13:15:58 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
“memory”: {
“total”: 971055104,
“available”: 787542016,
“percent”: 18.9,
“used”: 105095168,
“free”: 565510144,
“active”: 253542400,
“inactive”: 78622720,
“buffers”: 27848704,
“cached”: 272601088,
“shared”: 18632704,
“slab”: 52875264
“disk”: {
“total”: 61384400896,
“used”: 3768238080,
“free”: 55075192832,
“percent”: 6.4
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rf_gain”: “45”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: “290”,
“satnogs_station_id”: “1510”,
“satnogs_station_lat”: “43.028435”,
“satnogs_station_lon”: “-88.250514”
------------[ copy end ]-------------

Having a look through your observations on station 1509 and 1510, the waterfall looks about right to me. The observation metadata (visible on the left of the observation page) shows the gain is being set correctly.

Of course, you’re not seeing any satellite signals, and I suspect you might be very much limited by local noise. If you only need a gain setting of 10 - 13 dB to increase the noise level then that very much implies this is the case.

For example, this high-elevation NOAA-19 observation shows a lot of local noise: https://network.satnogs.org/observations/2090013/

Increasing the gain further isn’t going to help in this case. You are going to need to try and figure out what the source of your local noise is and eliminate it, or get the antennas (much) further away from it.

Ooooooh… I am suspecting the waterfall is autoranging… The docs don’t really say one way or the other.

I thought it would not be autoranging like cubicsdr or many other sdr apps, including the ones I was using to test components and the overall system. If its not autoranging, then I still don’t understand how changing the input attenuator thru over 40 dB would not cause massive changes in overall waterfall brightness. The noise floor should be huge at 45 dB of gain, and is huge when testing with CubicSDR as per the wiki procedure. Certainly, the overall system SNR seems best when I use the “correct” measured gain value but the waterfall doesn’t change with gain adjustments which seems weird… if its not autoranging.

If its IS an autoranging waterfall, then everything is OK. I suspect that if its working at all, it must be autoranging…

That noise on the NOAA observation is because the antenna is leaning up against my desktop computer case in the basement “lab”. I think everything is working pretty well for being in the basement of an aluminum sided house. Once in a while on satellite passes over 70 degrees elevation I get a shot of good signal thru the house, along with lots of noise, especially on UHF. I wanted to complete all assembly and testing before mounting it up high in the attic and this was my only remaining “problem”. Much easier to troubleshoot a LNA on the lab bench than up on the roof, etc. I’ve found the hard way that an hour in the lab is worth about twenty hours on the roof LOL. I ran the LNA thru the VNA and it looks good and swept the antennas also tried to characterize my SDR as best as I could, aside from testing the entire assembled system. There’s a nice remote spot on the property about a hundred feet from anything electrical about twenty feet up and protected from the elements by a wood shingled roof, its going to be pretty awesome with very low noise levels once I run power to the location.

I’m talking myself into the idea that the waterfall is autoranging… that would explain everything…

Anyways 73 thanks for the help and have a nice day!

Yes, if you look at the scales on the right of the waterfall (compared to other stations), you will see that that the waterfalls are indeed autoranging.


That site is a very interesting resource. I was working off the wiki which doesn’t seem to link to it.

I’d suggest the wiki should link to it, either the troubleshooting page


Or maybe add it to the links drop down list.

Or both.

73 have a nice day

I figured out how to edit the wiki and documented this in


"CubicSDR DOES NOT autorange its waterfall, in contrast, satnogs DOES autorange its waterfall. When you adjust the gain in CubicSDR the waterfall background will dramatically change, but when you adjust the gain in satnogs the waterfall background will not change color. See the web page documenting autoranging waterfalls:


I hope this is of some help to other new ops 73 and have a nice day