TP-Link TL-WR703N no longer available

I’m new here, please bare with me.
I’ve taken this from the hardware page of the main site;
"Our primary configuration includes the BeagleBone Black or the TP-Link TL-WR703N as a single-board computer".
I’ve been reading through the wiki for the TP-Link TL-WR703N an it states this at the beginning;
"TP-Link no longer list the “TL-WR703N” on their website, only the “TL-WR702N”, which has no USB connector and 2 MB flash only, so it can’t run OpenWrt. Alternatives are the TL-WR710N or GL-AR150."
Does anybody know if the suggest alternative, the TL-WR710N, is a direct replacement? Or will the hardware/software configuration need updating?

Generally we only need TL-WR703N for connectivity.

Moving forward you should be able to use any router you want to figure out the connectivity part, as the whole satnogs-client runs on a single embedded (that defaulting to BeagleBone Black for now).

@acinonyx any comments?

We’ve been using the TP-LINK TL-WN722N for the network connection on our Odroid C1. USB connection, external and detachable antenna (!). According to the student who set it up “it just worked”. They are presently $10.99 at amazon.

Have anyone tried using the HooToo router. I picked one up from Amazon. I am new to this and like help on loading OPENWRT to it. Thanks