TP-Link testing

I’ve got exactly the same problem,

I Have found someone saying :
“RTL2832U / R820T sticks may not be fully supported in the RTL drivers used here. The RTL2832U / E4000 sticks work fine.” on this website :

I’m using the R820T tuner don’t know about u?

Yes r820t because its way better available nOw.

I can’t compare the tuners but it works flawless under sdr# with rtlsdr usb. The article is 2012 maybe it has changed.

Try installing the latest version of rtl_sdr package and library from trunk branch.

I did some deep digging on rtl_tcp and sdr#.

  1. The crash bug, where rtl_tcp has segmentation fault after a client disconnects and connects, is caused by an old libusb (<1.0.19). For latest Raspbian it is still necessary to install those packages by hand.

  2. The “buzzing” or strange reception on sdr#. I have checked with wireshark that all packages arrive at the tcp client. However sdr# handles these in a doubtful way as far as I can judge from the old code I saw, since this software is now closed source.I assume its an performance problem of sdr# and you should look out for another open-source receive back-end …

Okay thanks a lot :slight_smile:

Hi guys,
Sorry for reviving the old topic, but I am running into some problems trying to setting up my TP-LINK router.

I have a TL-WR710N with Openwrt 15.05 Chaos Calmer. I am trying to get hamlib and rtl packages installed, but I cannot update the repo. When I run “opkg update” I got a problem with openssl:

wget: can't execute 'openssl': No such file or directory

Searched in how to install openssl but didn’t find anything helpful.
I tried to download and install the packages manually but I got no success. I can ping from and to the router. It is my first time playing with Openwrt.

Thanks in advance.

I am upgrading the OpenWRT wiki Dozuki.

I experienced some problems as this too, however not yours with 15.05.1. There is no openssl package installed on the router.