Tone use under Gpredict/rigctld control?


#1

I just jumped on a low pass of AO-92, but noticed that every time there is a command sent to the rig, my tone setting turns off. My “work around” for this was to set the refresh rate to 5 seconds, and turn the tone on. As soon as the rig updates (and the tone is turned off), I quickly turn the tone on and then start Tx’ing to turn the repeater on (once it’s on, I don’t need the tone - although I can’t remember how long that is good for). In checking the transmitter files for AO-92 and SO-50, neither have any parameter for tone (although the 67.0 tone is mentioned in the document header/description).

Is there a way to hardcode the tone into the transmitter file? Or to otherwise prevent the tone from being turned off everytime the rig updates?

–Roy
K3RLD