Step by step instructions

Can we get step by step instructions of how to set up the whole system (especially the software side of things)? Say I have a beaglebone black. What do I need to install/run? How do I set it up with the arduino? What is different for a Raspberry Pi?

At the moment there are tonnes of repos that are not very documented, and it is neigh impossible to work it out.

1 Like

Hey @rspencer!

Thanks to awesome @cshields we now have instructions on how to install/configure/run satnogs-client on your device. The docs are using raspberry pi 2 as a reference board, but the steps should be similar to any other linux enabled device.

We are planning to streamline this for the end user, in order to have an automated procedure for the client installation, so stay tuned :smile:

For any further information feel free to ask questions here or in #satnogs irc channel.

1 Like


Give me 24hr to update the instructions for the ppm setting.

I should have instructions for the beaglebone black done in a few days (very similar to raspi2 I just need to test on a fresh bbb install)

When you go through the docs please let me know if any discrepancies or improvements.


In the /etc/supervisord/conf.d/satnogs.conf, I’m assuming this is in meters? It might be a good idea to clarify this in the docs.


1 Like

I agree with @rspencer . I’m still building my rotator, but I’ve just got the TP-Link WR703N updated with OpenWRT firmware on it. The README says to install the ‘hamlib-easycomm’ and ‘rtl-sdr’ packages. Are these on the Raspberry Pi or the TL-WR703n ?
Is there any specific config to do on the router?

Updated the doc, thanks for the suggestion (yes it is meters)

I don’t have a TP-Link to test with so I’m not sure on the package names… from hamlib you are looking for the ‘rotctld’ program. For rtl-sdr you will want to use the satnogs fork of this app as it allows for frequency changing in rtl_fm (doppler shift). You can try the raspi doc above and see if enough of it matches up.

OpenWRT seems to use opkg as the package manager. Do I need to manually download the package to the device and then install it using opkg?
There’s a folder in the satnogs github with the package name “hablib”, , but inside it is only a makefile, not the ipk file that opkg is looking for.

I have found a location for hamlib and RTL-SDR-
How different is the Satnogs version of RTLSDR?

Maybe the install of OpenWRT didn’t install the correct repository details. I’ll try again tonight.

Short update:
All I needed to do was run “opkg update” first. This populated the list of packages in the official repository. Looks like this needs to be done after every reboot.

Then I could install Hamlib-easycomm !
Not sure how to specify the Satnogs version of rtlsdr though. More Googling required!


Try following the instructions in the “Install SatNOGS rtl-sdr” section at - as long as you have dev tools and libraries installed this should compile fine. Notably you will need cmake and libusb-1.0 installed.

So not windows then!

A client for windows?

No client for Windows today. If someone wanted to, could take the code and try to figure out a way. I’m not sure if hamlib ports to Windows. The new RX subsystem is based on gnuradio which does have some windows binaries but we have a custom gr block that would need compiled for/against that.

did the instructions guide actually come out? the link above is not working.

This is the new link:

I have been following the Install Guide as listed at the previous posts location, but have a question: Instead of using the default RTL-SDR dongle, can a different type be used. I would like to use the ‘Funcube Pro +’ as it has is a far superior receiver but the instructions are explicit on using the RTL-SDR. Hamlib reports that the Funcube Pro + is a Beta Supported device. I am a Linux user not developer so is there a way to modify the instructions for other hamlib supported receivers? Thanks

1 Like

Client is using gnuradio and osmosdr block for getting data. This means that it will work fine with all sdrs supported by osmosdr.

One of them is Fancube Dongle Pro Plus. The truth is that isn’t in our hw_settings, but I think it will not be so difficult to add it.

I am cc’ing @surligas who knows more on this matter. I can see that fancube(fcd) needs one argument for the type of the dongle (classic or pro), so I am not sure how we can define this.

However the default value if it is not provided is for pro plus, so maybe the only thing needed is just to add one more entry in hw_settings similar to the others and just change dev_arg to fcd. Anyway I’ll think it’s better to wait for @surligas to answer. :slight_smile:


Thanks for helping as I am now stuck. The pi can see the USB devices but that is all I know to do. The version of ahamlib used in the installation supports the Funcube but not the Funcube Pro Plus. The lattest version of hamlib supports both. Again, I dont have the knowledge to install the newer hamlib into my system environment.

A richer set of installation instructions with other hardware options would probably help us folks wanting to bring up a client site get the system on the air easier and increase the number of active ground stations… As I am stuck, I will put this project aside until smarter engineers than me can generate a solution.

Just a clarification, on my previous post I was talking about the new version of the client (0.3.0) which uses the new version of hamlib.

We are in the process of documenting this new version in order to be easy to someone without special technical skills to setup it.

A draft installation guide of client v0.3.0 for rpi3 can be found in this issue.

Awesome! I will be standing by to give it a try. I do have the draft version of the instructions and a partial build of the OS and Software, but I got stuck somewhere towards the end as I could not figure out how to define the FC Pro Plus dongle, that was last week and a number of O/S loads ago. I will start again from a clean load and see how far I can get.