Station Offline Again

Hello all and please help.

My station keeps going offline after many successful observations. Now it’s done it multiple times and i just turn off the pi and SDR RSP1 and it comes back to life and make many more good observations until it fails with bad observations.
This is the output from the journal for your input.


1 Like

The log indicates your rpi’s network has become unreachable.

Next time your SatNOGS goes ‘offline’, login into the pi at the terminal and trying pinging one of Google’s nameserver IPs


If it times out, your network connection has indeed dropped and you’ll need to troubleshoot your wifi connection or wired connection to your router. Rebooting your pi fixes this temporarily (by resetting your pi’s network interface and forcing a renegotiation) but as you noted it will occur again.

If it doesn’t time out and pings successfully, it could be related to a DNS lookup issue on your LAN. You might need to hard-code some alternate DNS servers in place of relying on your router to be the primary DNS for your LAN.

1 Like

TU for the input and direction I’ll make sure i check the ability to ping the DNS Server next time it happens.


1 Like


nslookup or dig and if the dns utils aren’t available then just try ping

1 Like

So it’s doing it again and seems to be able to ping the server but is now saying no space left on device.
Any suggestions on my next move ? and how would i go about checking the space available and cleaning up that space.


This is after a reboot.


1 Like

What SD Card do you use? How big is it?

Could list the files in /tmp/.satnogs/data/ by running ls /tmp/.satnogs/data/ command?

Do you remember if you have expanded the filesystem? If not please do it by running sudo raspi-config and then select the Expand Filesystem option which is in Advanced Options. After that you will need to reboot RPi for complete the expansion.

Thanks Fredy…

After a reboot this morning I have about 20 files in /tmp/.satnogs/data/ and around 30 in /tmp/.satnogs/data/complete/ some with .ogg and .png
Should these folders auto clean out or is it something i should be doing ?

mSD is 32gb and as in the picture from my previous post 3.6gb is used.


/tmp/ is stored in memory, so after a reboot it should be empty. It is strange that it isn’t. Could you run df -h and check about /tmp/ and let us know what you get. It should be something like:

tmpfs 462M 0 462M 0% /tmp/.satnogs

Now about the files in /tmp/.satnogs/data/complete/, after uploading artifacts to Network, Client removes these artifacts except if you have set to keep the RAW files by setting False the option Advanced -> Paths -> SATNOGS_REMOVE_RAW_FILES in satnogs-setup.