Some observations do not start

My station (ID:819) doesn’t execute some scheduled observations. Here is how the client comes to see the scheduled observations. When I launch the client I can see that there is an update of the scheduled observations that is done every minutes.

However the problem is that if I look at the web interface of the client the scheduled observations appear for 1 minute then desappear during 1 minute and then appear with the updates …

And when the scheduled observations disappear if an scheduled observation were to start in this same time (during 1 minute approximatively) this observation doesn’t run because for my station durring this time there is no scheduled observation.

It is like this update of the scheduled observations took 1 minute to do this and suddenly my station considers that there is no observation of programmed during this period.

Thank you for your help :frowning:

There was a change 4 months ago, which was to fix the issue of jobs getting removed and then re-inserted in client scheduler. So now, when client gets new jobs from network, it updates the current scheduled ones and adding the new ones.

Unfortunately the interface wasn’t implemented in the best way, so it has several issues, this is why we have removed it from the latest (development) version in order to implemented from scratch with a different architecture.

Could you restart your station and then run it for sometime without opening at all the web interface?

I suspect that the problem comes from the web interface but I need to confirm it.

EDIT: Have you checked both web interface and journalctl logs for errors?


Hello I did several tests and it seems that when I open the web interface I have a larger amount of observations that start than when I close.

I’ve some errors messages:
when I run sudo service satnogs-client start
I recieve this error message WebSocket transport not available. Install eventlet or gevent and gevent-websocket for improve

Do you think that can be the reason of all my problems ? And on all my observations waterfall the Doppler is not corrected but I don’t understand why !

My Station ID is 819 you can look observations results if you want.

Thank you for your quick reply.

Nope this error can be safely ignored.

That’s strange indeed. The last time I have seen such a behavior was when I have accidentally set wrong longitude and latitude on the client settings.

I have one more guess, that probably is a time issue. Could you check that the time in rpi is the right one and make sure that it is synchronized?

This could explain the missing start times, when there is a sync and the time is moved forward more than 30s. And also the wrong signal curve could be explained with having right TLE and station location but not right time.

1 Like

I use a computer not Raspberry Pi, I think you’re right I have a time lag between logs when I run the command sudo journalctl -f -u satnogs-client.service and the actual time.

My computer shows 17:28 and the logs show 17:26 for example. How can I fix that ?

For longitude and latitude values they ar both good.

Check this article:


Ok ,it’s fixed the ground station works perfectly well. Thanks a lot for your help !!!