[Solved] RTLSDR unsupported sample rate

After being unsuccesful using my B210 and Airspy I tried a rtlsdr with R820T tuner. SoapySDRUtil --probe show now problems with RTLSDR and Airspy.
Manual receive “satnogs_afsk1200_ax25.py --soapy-rx-device=“driver=rtlsdr” --antenna=RX --samp-rate-rx=2.048e6 --rx-freq=145950000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat” shows no failures and both audio and waterfall files are generated.

It is more than annoying to wait for more than 10 minutes after any change in configuration to see that it still doesn’t work.

I spent hours in this community and on a search engine to find a solution, but all attempts failed.

73, Norbert - DL8LAQ

See this problem:
Okt 05 17:30:16 satnogs satnogs-client[3661]: Traceback (most recent call last):
Okt 05 17:30:16 satnogs satnogs-client[3661]: File “/usr/bin/satnogs_cw_decoder.py”, line 465, in
Okt 05 17:30:16 satnogs satnogs-client[3661]: main()
Okt 05 17:30:16 satnogs satnogs-client[3661]: File “/usr/bin/satnogs_cw_decoder.py”, line 448, in main
Okt 05 17:30:16 satnogs satnogs-client[3661]: tb = top_block_cls(antenna=options.antenna, bb_freq=options.bb_freq, bfo_freq=options.bfo_freq, bw=options.bw, dc_removal=options.dc_removal, decoded_data_file_path=options.decoded_data_file_path, dev_args=options.dev_args, doppler_correction_per_sec=options.doppler_correction_per_sec, enable_iq_dump=options.enable_iq_dump, file_path=options.file_path, gain=options.gain, gain_mode=options.gain_mode, iq_file_path=options.iq_file_path, lo_offset=options.lo_offset, other_settings=options.other_settings, ppm=options.ppm, rigctl_port=options.rigctl_port, rx_freq=options.rx_freq, samp_rate_rx=options.samp_rate_rx, soapy_rx_device=options.soapy_rx_device, stream_args=options.stream_args, tune_args=options.tune_args, udp_IP=options.udp_IP, udp_port=options.udp_port, waterfall_file_path=options.waterfall_file_path, wpm=options.wpm)
Okt 05 17:30:16 satnogs satnogs-client[3661]: File “/usr/bin/satnogs_cw_decoder.py”, line 91, in init
Okt 05 17:30:16 satnogs satnogs-client[3661]: tune_args, settings, samp_rate_rx, “fc32”)
Okt 05 17:30:16 satnogs satnogs-client[3661]: File “/usr/lib/python3/dist-packages/soapy/soapy_swig.py”, line 166, in make
Okt 05 17:30:16 satnogs satnogs-client[3661]: return _soapy_swig.source_make(nchan, device, dev_args, stream_args, tune_args, other_settings, sampling_rate, type)
Okt 05 17:30:16 satnogs satnogs-client[3661]: RuntimeError: soapy::source: Unsupported sample rate. Rate must be in the range [8000.000000, 8000.000000] [16000.000000, 16000.000000] [22050.000000, 22050.000000] [32000.000000, 32000.000000] [44100.000000, 44100.000000] [48000.000000, 48000.000000] [96000.000000, 96000.000000]
Okt 05 17:30:16 satnogs satnogs-client[3661]: satnogsclient.observer.orbital - DEBUG - Observer data: {‘lon’: 9.971, ‘lat’: 53.835, ‘elev’: 35}

Satnogs client configuration:
satnogs_api_token: xxxxxx
satnogs_log_level: DEBUG
satnogs_rf_gain: ‘40.2’
satnogs_rx_samp_rate: 2.048e6 <- also 2048000 does not work
satnogs_soapy_rx_device: rtlsdr
satnogs_station_elev: ‘35’
satnogs_station_id: ‘1795’
satnogs_station_lat: ‘53.835’
satnogs_station_lon: ‘9.971’
sentry_enabled: true

Support file:
Generating support report. Please wait…
------------[ copy here ]------------
{
“versions”: {
“satnogs-client”: “1.3.4”,
“satnogs-client-ansible”: “202007160921”,
“satnogs-flowgraphs”: “1.2.2-1”,
“gr-satnogs”: “2.1.2.1-1”,
“gr-soapy”: “2.1.3-1”,
“gnuradio”: “3.8.2.0-2”,
“satnogs-config”: “0.10.2”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2020-10-06T13:24:20.190020+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “satnogs”,
“release”: “5.4.51-v7+”,
“version”: “#1333 SMP Mon Aug 10 16:45:19 BST 2020”,
“machine”: “armv7l”,
“processor”: “”
},
“memory”: {
“total”: 970825728,
“available”: 805134336,
“percent”: 17.1,
“used”: 99037184,
“free”: 460509184,
“active”: 295165952,
“inactive”: 153104384,
“buffers”: 33460224,
“cached”: 377819136,
“shared”: 6586368,
“slab”: 42291200
},
“disk”: {
“total”: 31090814976,
“used”: 3576434688,
“free”: 26203922432,
“percent”: 12.0
}
},
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_log_level”: “DEBUG”,
“satnogs_rf_gain”: “40.2”,
“satnogs_rx_samp_rate”: “2048000”,
“satnogs_soapy_rx_device”: “rtlsdr”,
“satnogs_station_elev”: “35”,
“satnogs_station_id”: “1795”,
“satnogs_station_lat”: “53.835”,
“satnogs_station_lon”: “9.971”,
“sentry_enabled”: true
}
}
------------[ copy end ]-------------

Looks like same problem as in Always no réception ..my log ?

Change to

satnogs_soapy_rx_device”: “driver=rtlsdr”

(just like you did when testing manually)

hmmpff… yes, that looks looks like I did not see wood for the trees! I read this topic, a few times… Now it’s running and should upload data :slight_smile: Thank you!

2 Likes

Nice work. Thanks for reporting back.