[SOLVED] IC-705 kappanhang PTT status


Okay. It was misconfiguration. I changed the radio type to full-duplex. Now gpredict is in control, pushes the radio into SPLIT mode and successfully controls both UP and DOWN frequencies. while I can transmit with the rig’s PTT. I’m very happy with the result! :slight_smile:


I’m playing with gpredict’s radio control features. For rigctld I use kappanhang which connects to the radio via wifi and runs rigctld on 4532.

In gpredict my radio control options are
Radio-type: half duplex
PTT status: read PTT
VFO Up/Down: N/A

With these options gpredict successfully controls my rig’s TX and RX frequency IF I talk via the computer. However, if I want to talk through the radio’s PTT, only the RX frequency is in control, but the TX frequency.

It looks like gpredict knows the PTT status when I talk on the PC, but doesn’t know it if I use the radio’s PTT. It might be possible that kappangang’s rigctld doesn’t correctly report the PTT status, however get_ptt function seems implemented and I’m not quite sure how to verify this.

Anyone with IC-705, kappanhang and gpredict, I’ll be glad to share your config options and etc.
73 de LZ1MZK

Gpredict is 2.3-72-gc596101-3

  • main cpu 1.26
  • others needed?
    kappanhang should be the latest version.