SoapySDRServer not running

Hi, I am currently trying to figure out the RX gain by doing the SoapySDRServer step and this is what I get back.

SoapySDRServer --bind=“”

Server socket bind FAIL: bind(tcp:// [98: Address already in use]

any ideas what I could be doing wrong?

Hi windell747,
Just yesterday I had the same error before checking my RX gain with CubicSDR.
I just ignored the error and continued with the instructions at and all was well.

Steve VK4SMC

These errors would be because SoapySDRServer is already running. The guide gets users to run:

$ sudo systemctl start soapyremote-server

Which will of course start the server. I’m not sure if I put that in the guide or someone else did… Either way, it’s already running so you should be able to connect as per the rest of the guide.

Thanks vk5qi and Steve, Yeah I figured this out a little bit later. I ran

sudo lost -n | egrep LISTEN

(I had to install lsof before running this)

and found the server was already running and bound to port 51132. So I killed the process and then ran

SoapySDRServer --bind=“”

and it worked fine after wards. I guess I didnt think that port 55132 would be the default port it would bind to.

Thank you very much for your help!
Windell, WH7PK

I’ve updated the wiki article with some changes to ensure soapyremote isn’t running after it’s installed. Thanks for pointing this out!