Setup problem RTLSDR

Regarding Observation 1090294

Hi, I’m trying to set the SatNOGS station. It consist of: RPi 3 + RTLSDR (old, not v3) and cross dipole antenna.
At a beginning I have head a blank or purple waterfall. In troubleshooting I have found that this can be due the RF Gain. I went to Advanced SatNogs client settings and set it to 7.7. The waterfall is now visible but it is not OK. Have also try 15.7 but it is the same. The strange thing is that the waterfall is 0.25 sec. Is this still the RF gain problem or something else?
I have checked metadata on observation #1084167 (the same sat and time) and there is RF Gain increased from default to 36.4.

I’m not a Linux guy. Any ideas are welcome. I ordered SDRRTL v3 but need to wait for it.


1 Like

To begin, you have to test the RTLSDR key :

see Setting the gain

and after test if you received signal with Kalibrate-rtl and adpated antenna for GSM. With result you can setting SATNOGS_PPM_ERROR in Advanced configuration of satnogs-setup and Apply configuration.

I’ve tested several parameter better result for me is no lna and 49.6 gain with 69 ppm correction (Old blue key SDR device).


Tnx. You can have the same sdr that I have (mine is black but it is the same as the popular blue)
I have tested it with rtl_test but not calibrated. I will try this in the evening.
But also see that 15.7 gain can be insufficient.

There is something wrong with rtl-sdr installation.

pi@raspberrypi:~ $ rtl_test
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode…
Allocating 15 zero-copy buffers
lost at least 120 bytes
cb transfer status: 1, canceling…

Library error -5, exiting…

As you can see there is library error -5
The same is when I use rtl_test -p to make the ppm correction.

I have used the SatNOGS image for RPi

I will try write image on other SD card. Maybe there went something wrong.

Some small progress. After installing img on new sd card the rtl_test -p is working.
I was able to set the ppm correction.

Now the problem is still with observation duration. The observations are 0.25 sec.
I have tried to experiment with RF Gain but it not change waterfall. The logs for satnogs client is showing no errors.

Do you have any ideas what this can be?

Problem solved, station is running. Problem with duration of observations was in RTL-SDR.
The old one is damaged somehow. When I have connected new sdr v3 it started working OK.

There ware at least two problems:

  1. SD card with write problems
  2. not working SDR
    There can be also an third problem with user rights but I’m not sure. Last time I have created a new installation on SD card I have configured all things as sudo su.

Maybe this will help some one.



Thanks for the feedback on this issue!

Could you please add your summary in the troubleshooting wiki page, to help other with the same issue in the future?