Set Yaesu Antenna and GS232B controller for tracking satellite

Hi everyone,
Now, on my ground station I can have Waterfall, Audio and some data but I never saw my antenna track satellite. And I am asked my self if it normal. Here is my configuration.

“versions”: {
“satnogs-client”: “1.5”,
“satnogs-client-ansible”: “202105092144”,
“satnogs-flowgraphs”: “1.3.1-1”,
“gr-satnogs”: “2.2.1.0-1”,
“gr-soapy”: “2.1.3.1-1”,
“gnuradio”: “3.8.2.0-14satnogs2”,
“satnogs-config”: “0.12”
},
“state”: {
“is-applied”: true,
“pending-tags”: null
},
“system”: {
“date”: “2021-05-25T16:33:52.978064+00:00”,
“distribution”: {
“DESCRIPTION”: “Debian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Debian”
},
“pending-updates”: false,
“platform”: {
“system”: “Linux”,
“node”: “hostname”,
“release”: “4.19.0-16-amd64”,
“version”: “#1 SMP Debian 4.19.181-1 (2021-03-19)”,
“machine”: “x86_64”,
“processor”: “”

},
"configuration": {
    "hamlib_utils_rot_opts": "-m 603 -r /dev/ttyS01 -s 9600 -T 127.0.0.1",
    "satnogs_antenna": "RX",
    "satnogs_api_token": "[redacted]",
    "satnogs_gain_mode": "Settings Field",
    "satnogs_other_settings": "LNA=11,MIX=6,VGA=11",
    "satnogs_rf_gain": "43",
    "satnogs_rot_baud": "9600",
    "satnogs_rot_model": "ROT_MODEL_GS232B=603",
    "satnogs_rot_port": "127.0.0.1:4532",
    "satnogs_rx_bandwidth": "7000000",
    "satnogs_rx_samp_rate": "2.5e6",
    "satnogs_soapy_rx_device": "driver=airspy",
    "satnogs_station_elev": "120",
    "satnogs_station_id": "1062",
    "satnogs_station_lat": "48.807",
    "satnogs_station_lon": "2.229"
}

}

I can send some command to my controller like rotctl P 120 23 and with p it change. But my antenna does not track anymore.
If someone can help for checking issue.

Sincerely,
Silla

The model ( 603, 202 etc) is already defined in the ‘hamlib_utils_rot_opts’ (I think) so I’m wondering if your ‘satnogs_rot_model’ under the Hamlib section is conflicting.

Try setting the parameter to

satnogs_rot_model ROT_MODEL_NETROTCTL

instead of “ROT_MODEL_GS232B=603”

Here’s my relevant section of the satnogs-setup ‘support’ output for reference – it works with my satnogs-client with my satnogs v3.1 rotator (arduino/cnc shield) :


> },
>     "configuration": {
>         "hamlib_utils_rot_enabled": true,
>         "hamlib_utils_rot_opts": "-m 202  -r /dev/ttyACM0 -s 9600 -t 4533 -C timeout=5000 -C retry=0 -vvvvvv",
>         "satnogs_antenna": "RX",
>         "satnogs_api_token": "[redacted]",
>         "satnogs_log_level": "DEBUG",
>         "satnogs_rf_gain": "49.6",
>         "satnogs_rot_baud": "9600",
>         "satnogs_rot_model": "ROT_MODEL_NETROTCTL",

Hi,
Thanks for your response.
I try it but it does not work.
Do you know how to update satnogs-client 1.5 to a latest version?
May be the issue is from there!

Silla

Hi,
Thanks for your response.
I try it but it does not work.
Do you know how to update satnogs-client 1.5 to a latest version?
May be the issue is from there!

Silla

You are missing the ‘Enable’ parameter in your configuration that you posted

 "hamlib_utils_rot_enabled": true,

This might do it.

Not sure about satnogs-client v1.5 or greater, still using 1.4x on my end.

Hi.
Yes I change the value to ‘’ true’’.
But the issue is not fixed yet!

Silla.

Update through the satnogs-config. Update > Apply (then do it again, twice)

This is mine if it helps.
image

Hi,
Thanks for your response!
But it does not work yet.

Silla

Try changing your Serial Port to “/dev/ttyS1” as i think the Pi maybe confused with “S01” Unless you want it on /dev/ttyS0

https://www.raspberrypi.org/documentation/configuration/uart.md