Seem to have similar/worse performance with LNA

Caveats from the start, I’m well aware of the limits of my system. I’m not expecting anything spectacular, but I seem to be getting worse performance when adding in an LNA.

  • V-Dipole Antenna indoors for testing tuned to 137 MHz
  • SPF5189Z LNA

Without a LNA, I can get signals from some of the bigger NOAA satellites, and occasionally a strong Cubesat, but that’s about it, which is what I was expecting.

Recently I tried to integrate an LNA into the loop. Originally ran into the bias tree issues that have been well-documented on this forum, but ended up fixing it with pre/post observation scripts. Even after re-tuning the gain, I now can get pretty much no Cubesats, and the signal from the NOAA satellites appears even weaker. For reference, before the LNA, the SDR gain was set to around 32 dB, and it was decreased to around 28 dB after I added the LNA. Gain was tuned using the SoapySDRServer noise floor method described in the Wiki.

Is there any reason I’d be getting worse observations with a LNA than without one?

Antenna – ~0.75m of SMA coax – LNA – RTL-SDR


1 Like

Did you check for 5V at the LNA with a voltmeter?
Can you see an increase in the noise level when you turn on power (bias-T) to the LNA?
Do you have a genuine RTL-SDR or a fake? How do you know? The fakes have 4 screws in the end plates, the genuine only 2.
You will have to reduce the gain on the SDR when the LNA is working.
RPi and switched mode power-supply can generate a lot of noise which will be picked up by the indoor antenna. Also USB cables are noisy.
LNA should be close to the antenna.

Do you have some example of observations pre/post changes?

The noise floor gain method is good for optimizing the sensitivity of the station (even in the presence of continuously present local noise), but it doesn’t take into account issues due to inter-modulation distortion from other local signals. If you can access the SDR remotely, it might be worth looking at the signal levels during an actual satellite pass (e.g. manually work out when one is occurring using gpredict or otherwise), and adjust gain settings during the pass to optimize achieved SNR.

Mark VK5QI

For what it’s worth, I went through the same process. My RTL-SDR dongle is so close to my antenna that adding an LNA did virtually nothing - and in fact I believe I get better results without it. It may be that my RPi and SDR dongle are noisey enough that adding any type of LNA just makes it worse. How long is the feedline from your LNA to your RPi?

1 Like

Thanks for the tips here.

From the very start, I’m not seeing 5V at the LNA at all. In fact, I’m seeing pretty much nothing across the LNA. Looking at the noise floor, I don’t really see any difference when the bias tree is turned on or off. So that’s probably the problem!
I do have a genuine RTL-SDR. I ordered it directly from them and it has 2 screws on the back.

To be sure, the SPF5189Z LNA can be powered via bias tree, correct?

No 5V at the LNA means it’s an attenuator not a LNA. Fix that first. your Bias-T=on command is not working. Try issuing the command manually.


All of the tests I’ve been doing on this since I realized something didn’t look right have been running the command manually. I’ll keep looking into it.

Did you sort this out @thomp376? I’ve similarly managed to wreck my station yesterday by adding a LNA. :man_facepalming:

Bias tee power

I found getting rtl_biast working manually was relatively straightforward but trickier to get it working automatically during an observation. In the end, I’ve simply configured the pre- and post-observation scripts to run the command:

$ cat /etc/ansible/host_vars/localhost
satnogs_post_observation_script: /home/pi/rtl_biast/build/src/rtl_biast -b 0
satnogs_pre_observation_script: /home/pi/rtl_biast/build/src/rtl_biast -b 1
satnogs_soapy_rx_device: driver=rtlsdr

Although some older posts suggest and the wiki was unclear no other magic incantations were required, it seems these aren’t required with the SoapySDR RTL module.


I’ve also just confirmed for my own sanity that the green LED on my LAN does light up to show it’s powered during an observation; and off again afterwards. That’s the simplest and clearest way to be sure!

journalctl -f -u satnogs-client.service will show the rtlbias_t being run before and after a pass, but the output isn’t that clever as it doesn’t mention what it’s done. I’ve raised an issue in GitHub along with a fix PR.

Apr 17 22:01:48 pinog satnogs-client[1429]: Found 1 device(s):
Apr 17 22:01:48 pinog satnogs-client[1429]:   0:  Realtek, RTL2838UHIDIR, SN: 00000001
Apr 17 22:01:48 pinog satnogs-client[1429]: Using device 0: Generic RTL2832U OEM
Apr 17 22:01:48 pinog satnogs-client[1429]: Found Rafael Micro R820T tuner

That all confirms the bias tee power is enabled during an observation. Incidentally, there’s also another (stale) PR for rtl_biast which allows for reading of the current bias tee setting. I’ve not tried it.

The other way to confirm it’s doing any good is to tune into a reasonably strong signal (e.g. local broadcast FM station) with SoapySDRServer / CubicSDR (see details within Omnidirectional Station How To) and turn it on and off manually and see the substantial difference in gain/attenuation.

Here’s my trials and tribulations:

Before - without any LNA

Local broadcast FM station:

137 MHz:

Some kind of signal, probably terrestial around 137 MHz:

After, with LNA

Breakthrough of local BBC broadcast radio station :frowning:

I then put an FM block in front of the LNA. That got rid of a lot of a FM broadcast harmonics, but also seemed to trash any satellite reception.

I removed the FM block this morning, but realised in the process I’d broken the balun wires :cry:. So I now need to fix that (or just remove it) and try again. Nothing like being six levels deep into your original problem. I’ll probably find I’ll just remove the LNA and FM block for this VHF antenna and save it for another, but I do want to play to see what the best I can get is first.


Observation #1977444 - one of my first nice APT passes from NOAA 19 with just the QFH antenna, no LNA - can’t remember the RTLSDR gain setting, but probably around 20:

Observation #2049657 of NOAA19 the morning before I added the LNA:

Observation #2051207 of NOAA19 immediately after adding the LNA:

Ooops. That’s wrecked it! The waterfall looks a mess too:

More fiddling required.

This will not be the case unless the LNA has a very high noise figure or the SDR has a very very low noise figure (which is never the case). It might be that the gain on the antenna feedpoint was already too high, and so inserting an LNA would only add noise, while providing gain that does not help, since the gain without the LNA is already above the noise floor of the SDR. You might be able to see a difference if your transmission line has a considerable length (i.e. several meters), since the LNA would account for the loss introduced by the transmission line.

No, it cannot! @azisi and I were digging into an SPF5189Z-based LNA and found that it cannot take 5V DC from the RF_OUT port. After removing the C4 component, I was able to feed it ~4.5V via the RF_OUT port using the built-in Bias Tee of the RTL SDR.

C4 is here:

(Note: once you remove C4, you will no longer be able to power the LNA from “the side” (, ), but only from RF_OUT using a bias tee)

Without power, an LNA acts more like an attenuator than an amplifier, and if you see any signal, it’s most likely coming from the traces between the LNA (U1) and the SMA connector (RF_OUT) acting like an antenna, picking up radiation and forwarding it to RF_OUT and into your SDR (that’s why you see many LNAs in a shielded enclosure).

Try placing the filter after the LNA and see if that helps. There is a good chance the insertion loss of the filter is significant at the passband (no less than 1 dB) and degrades the total sensitivity of your system (increases T_sys (≡ total noise figure)), so give that a shot!

1 Like

That does look very much like your LNA is getting flattened (e.g. pushed into a non-linear region, resulting in IMD) by those broadcast stations. As @0xCoto mentions, you may be limited by local noise, so a LNA might not help things.

I’m surprised the FM block would have that much attenuation at the 137 MHz satellite band.
Yes, there might be some attenuation there, but i suspect that your station is going to be more limited by local noise rather than receiver noise, so I wouldn’t worry too much about 1dB or so of insertion loss.
If you have something like a NanoVNA it would be worth testing it to see what the response actually is.

1 Like

Thanks guys for your help. I’ve rebuilt the balun in a slightly more robust manner. Am rather surprised the old one lasted 20 years and suddenly broke now, but I guess it’s not been moved about much. Then I cycled out to get an inline connector thrown at me from two metres social distance - essential for sanity and keeping the belly in check.

Interesting idea to try the bandstop after the LNA @0xCoto. I’ve done some experiments, but it’s tricky trying to do it all within the time of a satellite pass with the antenna up the loft and turning the bias tee on and off - which necessitates a restart of SoapySDRServer and CubicSDR. I’ve got the bandstop after the LNA at the moment, but will try it each way on the next suitable pass.

I’ve no VNA here @vk5qi but if there’s not something at work I can borrow or run it through, then maybe it’s worth investing in more tools at home. :wink:

Here’s what I’ve managed to find so far:

FM broadcast band stop filter

LNA in-line but no FM broadcast band stop filter:

LNA in-line but with FM broadcast band stop filter near the RTL SDR dongle:

That shows it’s working as a band stop, so no loose connections or anything like that, but doesn’t reveal not else.

NOAA 19 pass

Then, I looked to see what I could get during an NOAA 19 pass:

LNA, powered up adjacent antenna, no band stop:

Evidence of APT signal, but very noisy.

LNA removed (couple in-line), no band stop:

Clear APT signal, much less noise.

LNA removed, band stop filter adjacent antenna:

Inconclusive, I think the bird had passed by the time I got up the loft and back down :frowning:. Shame as it would have been clear what the loss from the band stop was.


With the NOAA bird gone, I switched to the next prediction I could see with a reasonable success elsewhere - XW-2B. I didn’t expect much but thought it worth a try and was quite surprised.

LNA (powered) then band stop:

LNA (unpowered) then band stop:

I turned off the bias tee and got CubicSDR up and running again before heading up to remove the LNA. I was quite surprised to find some doppler signals still visible, albeit with a fair bit of RTLSDR gain required.

Band stop adjacent antenna, no LNA:

Still good.

Next steps

There’s a NOAA 15 and NOAA 19 pass shortly. I’ll try the band stop either side of the LNA and maybe repeat the inconclusive LNA removed, but band stop filter in place test before going back to no LNA.

I feel like I’ve somewhat hijacked @thomp376’s thread but it’s the same issue and hopefully getting to the bottom of it will assist him too.

And something I forgot to mention: if you’re feeding the LNA via a bias tee and use a filter after the LNA, make sure the current provided by the bias tee actually goes through the filter and onto the LNA!

No problem with power, the LNA LED is glowing. It’s an one and I did read somewhere it was happy to pass the voltage.

NOAA 15 pass

ANT - LNA - bandstop - RTLSDR:

ANT - bandstop - LNA - RTLSDR:

And back to ANT - LNA - bandstop - RTLSDR to confirm:

Well that’s telling.

NOAA 19 pass

Confirmed I could see the satellite with the setup as above with LNA powered. Then switched the bias tee off.

With just the band stop in place:

With just a coupler:


  • When using an LNA there’s far too much FM broadcast harmonics present; I need to use a band stop filter.

  • When using an LNA, I need to put the band stop after the LNA. The other way around seems to have odd effects.

  • I don’t need to the band stop if I’m not using an LNA.

I’m not yet clear on whether I’m getting a better signal with or without the LNA. It’s hard to tell with such a transient signal and no proper test gear. I think I’ll leave it in place for now and let the station collect some data or see what it looks like.

Hmm. These are the first two passes with the LNA. RTL-SDR gain = 0.

Observation #2057479 NOAA 15

Observation #2057485 NOAA 18

Compared to a previous pass without LNA

Observation #2049657

Looks like it was better before, but I’ll try a bit of gain for the next passes and see what that does

Missed a NOAA 18 pass by seconds while I was applying a gain change in satnogs-setup :frowning:. Shame there’s not a way to force an observation right now for testing purposes, or for satnogs-client to pick up anything already scheduled for ‘now’ at (re)startup.

Still, it gave me chance to fiddle with the gain - looks like about 10’s best so I’ll set that for the passes in NOAA the morning and see what I can pick up in the meantime.

Direct comparison of two closely equivalent NOAA 19 passes with and without LNA:

Observation #2049657 2020-04-17 08:00 no LNA RTL-GAIN probably about 40:

Observation #2057489 2020-04-19 07:37 with LNA and RTL-SDR gain 20.

Looks like there’s not much in it, slightly less interference with LNA although that may well be local environmental changes. The LNA seems to have a more distinct AOS/LOS, but I’m not sure what that tells.

Well that would certainly be the problem then. Looking online, not sure how I’ve missed that before. Will either pull out components or just power it externally.
Thanks for the response.