SatNOGS stopped working after upgrade

I stuffed up my perfectly good ID-724 UHF ground station trying to upgrade it to Bullseye and the latest satNOGS software
It’s been running for several years. I ignored the golden rule. Don’t fix it if it’s not broken.

I remember I can generate & send the satnogs-setup/ Advanced support/ file for the Gurus to look at and help me figure out my mistakes.
The problem is, how do I cut & paste the report into this post. It doesn’t work in the regular way on Putty.
Thanks for your time and advice.
Just highlighting the area of interest which turns grey doesn’t “paste” anything.
Bob vk2byf

There is no in-place upgrade from Buster to Bullseye, you need to reinstall with the new image.
Safe the file /etc/ansible/host_vars/localhost and restore the file after you re-image your flash card and before you run sudo satnogs-setup

The new latest Raspberry Pi image is also not creating a default user, if you use a monitor and keyboard for the initial install, this isn’t a problem during the first or second boot you are asked to create an account.

There you can choose for pi as an username.

Otherwise you the rpi-imager and configure a default account.

Thanks for your quick reply. I did start with a brand new Raspian SatNOGS Image: 873Mb, which I got from… I used the Raspberry Pi Imager to write the image onto the SD card, about 3.8GB. I ended up with Lnux 5.15.61 bullseye. So far, so good.
I hope.
I ran satnogs-setup and I think here is where things went wrong.
I’m not a programmer, so need specific & clear instructions.

My ID724 UHF receiver is back to running on the old version 1.6 under Buster. Should I use the /etc/ansible/host_vars/localhost file from the old system and overwrite the new file before running satnogs-setup again with the bullseye version of Raspian ?
Do I need to start from scratch with a blank SD card and re image the SD card and start again?
What are the next steps after running sudo apt update && sudo apt upgrade and before running satnogs-setup? should I overwrite the new /etc/ansible/host_vars/localhost file with the old one?
Thanks for taking the time to help. I’m 72 and my memory is not what it used to be.
By the way, the new image already knows me as user pi with a new password. The RPi imager allows some editing of the OS image before writing it to SD Card.
73 Bob vk2byf

Make sure this file is in place when your run sudo satnogs-setup, when this is in place it will use the current configured values and will make life easier.

My 724 Ground station is working on the old buster SatNOGS 1.6 at the moment and I don’t want to upset that, so I have to wait until my new RPi 4 for my 568 station arrives. Now I have a copy of the correct setup file /etc/ansible/host_vars/localhost. I also know my mistake why it doesn’t work
I have to set a satnogs parameter to satnogs_soapy_rx_device: driver=rtlsdr. I had it as satnogs_soapy_rx_device: rtl-sdr. Furthermore, I also don’t have a PPM offset which is only -1 so not essential.
I will report back when I set up my next RPi and fix the updated SD card for the 724 receiver.
Thanks, Bob

1 Like

Hi PEOSAT. Update. My new ID-568 is running on RPi 4 with OS 11, bullseye. I used the latest image downloaded and updated. It shows up as on-line but, still Client V1.6, no observations yet but, I used exactly the same configuration as before entered manually. It’s not too hard.
My ID-724 will be next as soon as I’m satisfied ID-568 is working properly.
Thanks for your guidance.
73 Bob vk2byf