Satnogs-setup python error

Hi,

I have downloaded the latest image (2022091000), trying to update my RPi-4. (Was running satnogs-1.6)
I thought the image provided bullseye, but I see 10.13 in /etc/debian_version.

I had errors about an ansible module:

ERROR! couldn't resolve module/action 'ansible.posix.mount'. This often indicates a misspelling, missing collection, or incorrect module path.

The error appears to be in '/root/.satnogs/ansible/roles/satnogs_client/tasks/main.yml': line 138, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

Fixed that with: ansible-galaxy collection install ansible.posix

When I run ‘sudo satnogs-setup’ I get:

Traceback (most recent call last):
  File "/var/lib/satnogs-config/bin/satnogs-config", line 5, in <module>
    from satnogsconfig import main
  File "/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/__init__.py", line 8, in <module>
    from satnogsconfig.menu import Menu
  File "/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/menu.py", line 298
    init_value := self._config.get_variable(menu['variable'])
               ^
SyntaxError: invalid syntax

I didn’t know := was allowed in Python, it is hard to Google on, but I couldn’t find a mention to that operator anywhere.

Tried to change the four occurences (also in other files) to ‘==’, but that was giving problems further in the setup proces.

I don’t know if I am running bullseye, I thought I was but /etc/debain_version says 10.13. But I don’t think this error has anything to do with the distribution.

I would like to know what I did wrong. I’m afraid that restarting from scratch will lead me to the same problem.

Please have a look at [Announcement] SatNOGS station software upgrades are available - #8 by Acinonyx

Hi, I have similar problems. Just to make sure I understood… Should I update to Debian bullseye to solve the various problems? I do not want to mess-up everything :slight_smile:

The save way, reinstall as mentioned in the above link.

image

Make sure you note all the settings in /etc/default/satnogs-client and backup /etc/ansible/host_vars/localhost

The file in /etc/ansible/host_vars can be reused.

Thanks. We’ll try. I’m running a PC, not a Raspi. I will get an empty HD and try to reinstall everything.

I didn’t know you where running from a x86 system.

I have done the following: remove all satnogs packages (after backup the files and settings) and then did a bullseye upgrade, after that cloned the satnogs ansible repo and did a new install.

This link isn’t complete yet, but can guide you.

OK. Thanks for the link. I understand I have to install the ansible from PPA, but I see you have the focal repository.

deb http://ppa.launchpad.net/ansible/ansible/ubuntu focal main

Is that correct? Is only the older version of ansible working?

Yes it is, this is the install as proposed by the ansible community on there site.

1 Like

How are things working out?

Let me know if you run into issues, maybe I can even visit “Noordwijk” it has been a while.

That is, if you installed it in The Netherlands :smiley:

Hi, reinstalled everything today from scratch and went smoothly. So, your procedure is still good. I just skipped the Debian installation steps which I did before starting reading your page.

Now, I’m in troubles with with rotctld and hamlib version 4, which apparently are not compatible anymore with our antenna controlbox. I was using hamlib 3.3 before, with rotor model 1001. In the hamlib 4, there is still the 1001, plus 1002 and 1003 which seems older versions of the box (we have the old version) but there is still a protocol error. I will sort it out later, looking into the source code. In any case the azimut motor is stuck, probably due to a damaged end-stop switch. Too cold to go on the roof now.

In case you pass by Noordwijk, you are welcome!

What Rotor are you using?
Are you still using the old genso setup ?