Satnogs-setup doesn't work

I am trying to install satnogs-client on a Raspberry Pi 3 not using the image.
Following the instructions on, the installation using ansible from a client PC finished successfully.

However, satnogs-setup doesn’t work, with following output:

Inconsistency detected by get-dynamic-info.h: 138: elf_get_dynamic_info: Assertion `info[DT_RELENT]->d_un.d_val == sizeof (ElfW(Rel))' failed!

I also tried apt update and apt upgrade, but the result did not change.

Does anyone have the same problem?

I have never tried this on a Raspberry Pi.

Thanks for the information! I’ll try another way.

To better understand the issue a few questions:

  • Which base-image did you use on the Pi3? For satnogs-stable stations this should be Raspbian 10/buster 32-bit
  • Is this the complete log output you get when calling sudo satnogs-setup?
  • Where did you run sudo satnogs-setup? It’s supposed to be run on the Raspberry Pi itself. (I ask this because a quick web search shows that a similar log message is seen by users of the Homebrew package manager on Mac OS X).

The version of Raspbian is 10/buster 32-bit.
That message is all of the output for sudo satnogs-setup on the Raspberry Pi (not on the client PC :laughing:). I also got the same message without sudo.

Here is the information about my system:

$ cat /proc/device-tree/model
Raspberry Pi 3 Model B Plus Rev 1.3d
$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 10 (buster)
Release:        10
Codename:       buster
$ cat /proc/version
Linux version 5.10.103-v7+ (dom@buildbot) (arm-linux-gnueabihf-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #1529 SMP Tue Mar 8 12:21:37 GMT 2022
$ sudo satnogs-setup
Inconsistency detected by get-dynamic-info.h: 138: elf_get_dynamic_info: Assertion `info[DT_RELENT]->d_un.d_val == sizeof (ElfW(Rel))' failed!
1 Like

Thanks! I can confirm that everything looks as it should.

Some people suggest to have seen this error being caused by a corrupted SD card, see
this post and this post. Other than that I’m out-of-ideas.


These posts look similar to my problem. Thank you for the valuable information.

I’ll try another SD card.

1 Like