SatNogs Raspbian doesn't boot on Pi 3B+

I tried to install a fresh StaNogs raspbian on my new Pi 3B+. It didn’t start. Tried an aftermarket powersupply and an original RPi supply, but nope.

So I put the same card in my Pi 3B and everything was ok. After all was installed and updated/upgraded I took it and put it in the Pi 3B+ again and it WORKED.

Looks like some of the config, start or … stuff of SatNogs Raspbian is too old for the initial boot on the Pi 3B+.



1 Like

Could you open an issue in satnogs-pi-gen project? Thanks!

Just opened an issue over on GitLab.


Great! Thanks. Let’s continue the discussion there.

I got the same problem.
I solved it the following way
Mount the SD card on pi3b
Do an update
apt-get update
apt-get upgrade
apt-get dist-upgrade

Then move back the SD card on the pi3b+

73 Remi

1 Like

A new SatNOGS Raspbian image is out. I don’t have a PI 3B+ to test though. Can someone test it?

Just did my first install with the new image you linked to and its running on a brand new Pi 3B+. As far as I can tell it is working. my site is “online” in testing mode. and I scheduled a few observations.


Excellent! Thanks for the feedback.