Satnogs Network Invite

Hi all!

trying to get my client online , but I’m running into a 401 error. I was reading and it looks like I have to enter my client ID into the code from satnogs networks? If so, does anyone have the power to send me an invitation to sign up?

Thanks in advance! Hoping I can contribute

Hi @Bountyhunter,

Depending on the configuration you have, you can probably find solution in documentation sections 4 and 6.

Do you try to connect to or

I’m on, and I got signed up with no problem. Now I think my problem is I’m a little illiterate when it comes to the creating a new .env file for my settings and configuring my client (I’m trying to build the software in a VM to understand what I’m doing first before moving to my Pi)

You can easily do that with vi or vim on your setup. Check some documentation or let us know where you are stuck and we can help :slight_smile:
Also feel free to join us on Riot for live help.



Well, I’m working off of
(Sorry, your hyperlink didn’t work for me :frowning: ) but I’m on step 4.1 it looks like. I can (finally) start the satnogs-client software but I get a 401 error.

Thoughts? Im hoping to re-create this on my Pi (Ubuntu-mint) soon once I figure out what Im doing and how things work.
Eventually I have an Antenna question , but I’ll pop open a new thread for that after misc. searching :slight_smile:

This is most probably an error of not setting the API key correctly (401 is unauthorized access). Did you source .env before starting the client?

Also can you double check that inside the .env file the API key is correct?

That’s the part I think im stuck on. I’ve never really worked with sourcing a .env before

Check step 6.1.1 and type it as such on the terminal :slight_smile:

“Bash: .env: No such file or directory”

I’m in root/home/myusername/gr-satnogs

Usually we keep .env file on /home/myusername/ directory. To check if it is there run “ls -la” this will show all files (including the hidden ones starting with the dot).

Anyway check on your current directory and on /home/myusername/ and if the .env file doesn’t exist create one and add values as they are described in step 4.1.

Just make sure you use your API key, station id and the dev api url.

So I think I got it on my Raspberry PI now (YAY!) it’s not showing any errors at least. How long does it usually take to show up on my portal account that it’s online?

Also, When punching in the rotctld -m 202 -r /dev/ttyACM0 -s 19200 & I get an ROT_Open: error = IO error , so I did tail -f /var/log/syslog and saw that it was device on /sys/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.3 , do I use this to replace /dev/ttyACM0 ?

I’m a Dork and forgot I could totally do a touch filename.env (LOL)

Hey @Bountyhunter,

Let us know if you made any progress. With default settings, station it gets online in ~2-5min after starting the satnogs-client.

About the device as the device is a usb one maybe you can use /dev/ttyUSB0 or something similar.

Let us know if you have any other issues and also feel free to join us on our irc channel #satnogs on freenode server for faster feedback :slight_smile:. If you are not familiar with irc, you can also join us through which has a bridge to irc channel and also logs messages when you are not online.

May try USB0. Yeah It’s never come online 2 hours + Easily, I’ll give the IRC room another go