I built/installed the SatNOGS-Monitor from into my UHF ID-724 RPi SatNOGS ground station.

Thank you to those who shared an excellent tool for my station.
It wasn’t as hard as I thought it would be. However…
It runs by issuing via SSH & Putty the command satnogs-monitor -l 175
I got a crude wold map and some Station status on the left. I replaced the 175 with my station ID in the /config/satnogs-monitor/config.toml file which I had to edit with sudo nano instead of edit config.toml. Don’t know why, don’t care, it worked with nano.
here is my ~/config/satnogs-monitor/config.toml file content.

data path = “/temp/.satnogs/data” do these " " have to be there?
satnogs_id = 724 a space before and after the = is OK?
local = true
sat_footprint = true
spectrum_plot = true
waterfall = true

Now I get a crude map, a little blue dot roughly where my QTH should be but but no spectrum, waterfall or satellite footprint.

I think, please correct me where I’m wrong.
The crude map is because I have to address this— The monitor makes heavy usage of braille unicode characters so make sure your terminal emulator uses a font which includes those glyphs. The screenshot at the top shows alacritty[3] with the tewi-font[4]. Take a look at nerd-fonts[5] if you’re unsure about which font to use. You could also use a forked version of yaft[6] created by the same person as SatNOGS Monitor, which uses the Lucy Tewi font by default.

I’m not clear what I have to do here to fix it, Please advice me. I’m not a programmer.

As for the, no spectrum, waterfall or satellite footprint. I think nothing to see unless I or someone schedules some observations on my station 724

Thanks for you time to help someone who is in it way over his head again.
Bob vk2byf

Update: BHUTAN-1’s footprint just popped up with 3 orbit paths visible and it is updating itself.


if you have problems with the font rendering in putty (wrong colors, missing characters) check that you have the latest putty version and a font with all glyphs. See SatNOGS station monitor v0.3.x

Check your data_path configuration:

  • there is an underscore between data and path not a space
  • the default data path on the SatNOGS RPi image is `/tmp/.satnogs/data

Thank you wose
One problem fixed, I left out the _ in data_path
shame on me I should have been able to find that myself.

Downloaded " the latest" putty 7.3 but ended up with 0.70-4. have to keep trying but now I know I have to configure putty for the right fonts.

I’ll report back later how I go. It already looks better with more data on the left side.

I installed version 4 right after it was released and it worked great for at least a week. I had to set it aside for several days and when I started satnogs-monitor on my ground station again I received the following error:

Error occurred: Failed to deserialize data on struct (in GET or POST): missing field ‘location’ at line 1 column 473

The command line I have been using is:

satnogs-monitor -s 201 --data-path /tmp/.satnogs/data/ --waterfall --spectrum

Has anyone else seen this?
Am I doing something silly?

Bob, KO2F

There was a small API change on network side. You’ll need to update to version 0.4.1.

Thanks, that took care of the problem!

:slight_smile:Bob, KO2f