SatNOGS Flowgraphs error on satnogs-setup

I am getting the following error during setup:
Searched the web, but didn’t fine anything
rtl_test seems fine, but getting failures on observations.


------------[ copy here ]------------
“versions”: {
“satnogs-client”: “1.4”,
“satnogs-client-ansible”: “202012042053”,
“satnogs-flowgraphs”: “1.3-1”,
“gr-satnogs”: “”,
“gr-soapy”: “2.1.3-1”,
“gnuradio”: “”,
“satnogs-config”: “0.11”
“state”: {
“is-applied”: false,
“pending-tags”: null
“system”: {
“date”: “2020-12-27T02:03:21.946629+00:00”,
“distribution”: {
“DESCRIPTION”: “Raspbian GNU/Linux 10 (buster)”,
“RELEASE”: “10”,
“CODENAME”: “buster”,
“ID”: “Raspbian”
“pending-updates”: true,
“platform”: {
“system”: “Linux”,
“node”: “satnogs-bdc”,
“release”: “5.4.79-v7+”,
“version”: “#1373 SMP Mon Nov 23 13:22:33 GMT 2020”,
“machine”: “armv7l”,
“processor”: “”
“memory”: {
“total”: 969768960,
“available”: 799350784,
“percent”: 17.6,
“used”: 100777984,
“free”: 439173120,
“active”: 358187008,
“inactive”: 107274240,
“buffers”: 34676736,
“cached”: 395141120,
“shared”: 6492160,
“slab”: 47775744
“disk”: {
“total”: 31081148416,
“used”: 3191648256,
“free”: 26573209600,
“percent”: 10.7
“configuration”: {
“satnogs_antenna”: “RX”,
“satnogs_api_token”: “[redacted]”,
“satnogs_rx_samp_rate”: “2.048e6”,
“satnogs_soapy_rx_device”: “driver=rtlsdr”,
“satnogs_station_elev”: "31 ",
“satnogs_station_id”: “1265”,
“satnogs_station_lat”: “39.6850442”,
“satnogs_station_lon”: “-74.9968711”
------------[ copy end ]-------------

You could open a terminal and manually run the apt-get command as provided in the screenshot with the additional --allow-downgrade option. That could bring the desired flowgraphs package. And try again the satnogs setup afterwards.

Thank you pieira, That did seem to work as you stated.

I tried some more observations but still not getting any data (failed) waterfall.

I tried the two test in troubleshooting sections, rtl_test and --soapy-rx-device=“driver=rtlsdr” --antenna=RX --samp-rate-rx=2.048e6 --rx-freq=444000000 --file-path=./audio-out.ogg --waterfall-file-path=./waterfall.dat

both seem to work.

Are there any further troubleshooting steps I should follow?

@kd2lbu This was caused by an issue in satnogs-setup which should be fixed now.

You can either try to fix your station by updating it via satnogs-setup again, or in case this fails start over by downloading a fresh image. This new image was tested and released yesterday and shouldn’t have the issue you encountered.