SatNOGS client v0.9 and gr-satnogs v1.5.1-2 are released!


#1

New releases for satnogs-client and gr-satnogs.

Notable changes on satnogs-client:

  • Support demodulator for Reaktor Hello World satellite
  • Sent observation frequency in metadata
  • Add option for manual power level range in waterfall (there is an issue with this one, there will be an update in satnogs-client-ansible later that will fix this.)

Notable changes on gr-satnogs:

  • Golay (24, 12) decoder
  • Demodulating flowgraph for the Reacktor Hello World Satellite
  • Fix of the baud rate issue in BPSK gr-script

For updating your station through ansible script (satnogs-setup) follow the instructions in this wiki page section.

Note that before running satnogs-setup you will need to update the OS and reboot as is described in the instructions.


#2

I’m going to use this instead of a new thread. I followed the upgrade (apt, reboot, satnogs-setup). The satnogs-setup shows 0.9 in the setup of it- so it is updated. However the station dash says it is still on 0.8. I can’t find anywhere in the local logs or local interface that show the version number, but by exploring I see 0.9 and such:

$ ls -al /var/lib/satnogs/lib/python2.7/site-packages | grep satnogsclient
drwxr-xr-x  6 satnogs satnogs 4096 Feb 20 21:49 satnogsclient
drwxr-xr-x  2 satnogs satnogs 4096 Feb 20 21:49 satnogsclient-0.9.dist-info

Is this just a lag on the station dashboard? Is there a version indicator I can see in my local dash?


#3

It updated. Maybe there’s a lag in the version communication, but it’s nice to see.


#4

The version in network is updated after the first observation with the new version. However maybe we should change this… Thanks for the feedback!


#5

Any reason why the ESEO decoder didn’t make the cut for this update?
What’s missing to progress this?
73s Chris


#6

The merge request is still pending. cc’ing @surligas and @Sleepwalker for checking its status when they are available.


#7

It is up to me. Sorry I did not had the time to finalize the next version and integrate it.


#8

Hi. I followed the upgrade instructions to the letter. However, my client wouldn’t start. Systemd ran in an apparently endless loop restartíng the satnogs client and each and every attempt ended with the sad message:
Exception: SATNOGS_STATION_ID not configured.
At closer inspection it turned out that /etc/default/satnogs-client was empty.
Luckily I had a backup of the file (I have been in this business too long not have backups!) so now my ground station is up and running again.
I just thought I would bring this to your attention, so you can update the upgrade instruction to include this issue.
73, Bent


#9

That’s sound like the basic configuration had been deleted. Any chance you selected Reset Configuration option in satnogs-setup? This is the only option that would reset the configuration.


#10

I am sure that I did not select Reset Configuration during update. The configuration was indeed absent or empty. I can’t tell, because I manually entered my station ID when I saw the error message. Been there before. The file migth even have been absent before I started the update. You never know with software :grinning:
Anyway, let’s just put this aside as an odd happening.


#11

Thanks for the reply, let’s watch it and if someone else faces this issue in the future then check it in depth.