SatNOGS Client on Orange Pi Zero

At the suggestion from @orangepishop on twitter, I thought I’d have a go at porting the Satnogs Client to an Orange Pi. The Orange Pi Zero is based on the AllWinner H2+ SoC with 512Mb RAM.
I don’t really have the skills to port it, but I can follow instructions and report on the process.

My first attempt is with Raspbian Server. There’s a link from the page to download an image - HERE This is Raspbian version 8 (Jessie)

I did the usual apt-get update and upgrade, but am stuck for the next steps. Some of the previous build instructions are no longer available, such as the Raspi 2 ones -

I found somewhere that listed the prerequisites, but not all of them seem to be available for the Jessie version.

I’ve cloned the git repository and managed to run the pip installer, but running “sudo satnogs-setup” isn’t recognised.

Any pointers on where to go next?

Have a look here:

I used this to upgrade from Jessie to Stretch then install satnogs.

I’ve managed to do the upgrade, but it seems redis-server doesn’t want to install correctly.
I tried to edit the “/etc/systemd/system/redis.service” file and change the /var/run/ to just /run . ref :Here
This doesn’t seem to fix it.
The make process fails for gr-satnogs , so I can’t go any further.
I’ve tried to re-install redis-server with “apt-get install -f redis-server” but there’s an error. Something about 227 - No new Privileges…

It’s been a few years and the little OrangePi Zero hasn’t done much!
I’ve now re-imaged it with Armbian Buster, but the setup fails while running the ansible playbook. I then tried out each yml file one at a time to see where the error occurs and it fails while running the satnogs-client.yml file. Some packages fail to install.
Happens just after " Install or remove PyPI dependencies". It seems to fail, then retry a few times before spewing lines of red errors.
Probably a python version error, but I’m not sure where to begin troubleshooting (again!)
Any advice?

Further investigation suggests that it’s failing on the install of ephem as its using the precompiled version for the Raspberry Pi.
I’m guessing I’d have to manually activate the python virtual environment and manually compile that version to get it to work?

I’ve managed to manually compile and install all the pip prerequisites, but it’s now failing on installing satnogs-flowgraphs.

error is:

root@orangepizero:~/satnogs-client-ansible# apt-get install satnogs-flowgraphs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 satnogs-flowgraphs : Depends: gnuradio (>= 3.8) but is to be installed
                      Depends: gr-satnogs (>= 2.3) but it is not installable
                      Depends: gr-satnogs (< 2.4) but it is not installable
                      Depends: gr-soapy (>= 2.1) but it is not installable
                      Depends: gr-soapy (< 2.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

I’m guessing these all come from the satnogs repo? If I manually try and install gr-soapy via apt, it just says the package is not available, but is referred to by another package. Anyone with a tip to get around this one?