Satnogs-client installation

I’m trying to install satnogs-client on my ubuntu 16. I followed the instruction in the satnogs Documentation, but i had a problem with setting up mkvirtualenv

1- git clone

2- mkvirtualenv satnogs-client -a
(when i excute the above command i get an error “Cannot associate project with , it is not a directory”

help ?

this phase worked with me. Precisely, I think it was:
git clone
cd satnogs-client
mkvirtualenv satnogs-client -a .
with a point at the end (probably the above mentioned missing directory)


I have a problem during installation.

I followed this instruction: SatNOGS Client Ansible - SatNOGS Wiki

When I ran this ansible-playbook -i production/inventory/hosts -K site.yml
I got this error:

BECOME password:
[WARNING]: Invalid characters were found in group names but not replaced, use -vvvv to see details
Executing playbook site.yml

  • satnogs-setups on hosts: satnogs-setups -
    Gathering Facts…
    Create needrestart directory for Raspbian…
    Configure needrestart for Raspbian…
    Install or remove satnogs-setup system dependencies…
    Retrying… (1 of 4)
    Retrying… (2 of 4)
    Retrying… (3 of 4)
    [WARNING]: Updating cache and auto-installing missing dependency: python-apt
    satnogs failed | item: {‘name’: ‘python-apt’} | msg: E: Package ‘python-apt’ has no installation candidate | stdout: Reading package lists…

root@newsdrlinuxv11:/home/satnogs/satnogs-client-ansible# which python

root@newsdrlinuxv11:/home/satnogs/satnogs-client-ansible# pip list
Package Version

python-apt 2.2.1

root@newsdrlinuxv11:/home/satnogs/satnogs-client-ansible# python -V
Python 2.7.18

Debian GNU/Linux 11.2.0 Bullseye

Thank you for your advice

73’ Tony


I have run into your same problem. I am on Debian11 run inside VMware (since I don’t have a raspberry pi)

For now use Debian buster. (Debian old stable)
I have two systems running on that release and used the satnogs wiki for installation.

cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 10 (buster)"
NAME="Debian GNU/Linux"
VERSION="10 (buster)"

Gotcha, thanks for the prompt reply!

I managed to get it working installing everything manually in the end even though, although it was a bit painful. I’ll try buster if anything goes wrong

1 Like

I know it is possible, but you need to have some Linux experience, have a look at this install log that I created when installing and configuring a SatNOGS client running on Ubuntu server.

Ubuntu install log

This manual install can also be used on other Linux apt distribution.


i installed satnogsclient on debain 11

how satnogs client run
how it run
please help me

@shamika_sat Perhaps this will help:

I also replied via matrix, use Debian 10 / Buster and the SatNOGS Anisble Wiki to install.

I did a new Debian installation and shared the information on the following page:

This should help you in getting an up and running SatNOGS client on Debian.