SatNOGS Client Error 401

Hi everyone, I set up a new SatNOGS station for a friend/club. Everything seems to be fine, but when running “systemctl status satnogs-client” I am getting “satnogsclient.scheduler.tasks - ERROR 401 Client Error: Unauthorized for url:” I checked the ID and API Token many times and even tried the ones of my own station, but I always get this message. Any idea what else could cause this problem? I am leaving the country tomorrow morning and need to get that fixed before. Thanks a lot in advance.

What is your station id?

Also provide your station support report, you can generate it in Advanced --> Support in sudo satnogs-setup.

EDIT: make also sure that you don’t have any spaces in the API key in case you didn’t checked it.

Check the date/time is correct on client. <–guess

1 Like

The station ID is 2881. I checked for spaces in the API key, but there are none. How can I bring the station support report here?

Depending on the software you connect with, you need to find out how to copy paste it.

In case that finding it is difficult just get screenshot and upload it here.

Checked it, time zone is UTC and time and date are fine.


By the way if you can join #satnogs channel in matrix will be easier for more direct communication. More information can be found in Get In Touch - SatNOGS Wiki

Thank you all for your help. I really appreciate that.

If you wrote the API key manually and not copy paste make sure that zero is zero 0 and not the letter O.

I did - many times already, I am very sure there really is no typo.

The report looks ok. So, give me one moment to check it. In worst case scenario we will reset the API key.

Thank you, but I am afraid not even this would solve it as I have another account (my personal one, not the one of the club I am helping here) and I also tried this one together with the ID and it did not work either. I am also ready to flash the Raspberry again from scratch if this would solve the problem, but actually I am quite sure I made no mistake.

Thank you, just joined it.

The issue was that @cai-catania used the SatNOGS DB API Key instead of the SatNOGS Network one.


A big thanks to everyone who helped so quickly! As fredy said, I used the wrong API key. Lesson learned.


Great, glad you got it sorted out. Don’t forget to add the GAIN setting too!


If spaces in the key is a common problem, maybe the client can strip any spaces before saving the key?


I took a look at the code, was hoping to make a PR that strips leading and trailing whitespace. But there are too many levels of abstraction for me to comprehend unfortunately.

1 Like

To be honest extra spaces is not that a common issue. Indeed there is an abstract level so not very easy to make changes. However I wouldn’t spend time on this as in the next version of client user will not need to copy the API Key, it will be done automatically.

1 Like