Satnogs-auto-scheduler change in credentials handling


#1

Hello all,

We (@cgbsat and I) just merged some new changes on satnogs-auto-scheduler. Latest code can be found here:

For those of you using it, be advised that username/password is no longer part of the inline arguments you are passing on schedule_single_station.py but rather you have to create a .env file and store them there. (check env-dist file for a template).

We are also investigating a report from @on3rvh regarding the ability to use your credentials if you created a new account (after our transition to auth0). Regardless of that, we will be soon moving to a proper scheduling API implementation on the Network side, and will be able to schedule by using our API keys (vs username and password we do now).

Cheers!

pinging known auto-scheduler users @pjm , @kerel


#2

I was not able to schedule anything anymore. I had the message “Finding all passes for 0 satellites”.

I had to erase files in /tmp/cache to get it to work again.


#3

I am using this latest code but am a bit confused, it seems to schedule the passes, but they do not show up as such on my station page.
Here is the output of a typical run.

Am I looking for the passes with the ‘1’, or the pass with the satellite name?


#4

@thebaldgeek it clearly states “authentication failed” that’s why they are not scheduled and do not show up :slight_smile:
the text at the end stating “All passes are scheduled” is still a bug which should return an error when something (like authentication) failes.

did you copy env-dist to .env and update with your credentials? Also make sure there are no specials chars in your password as that will also fail


#5

Ah, that makes more sense.
Yes, I did copy the .env file and my password is pure.
Guess I just have to wait for the new API key auto scheduler…


#6

The latest version should exit on an authentication failure. When did you update the code?

The “1” for each pass means that it is already scheduled on the network.

As for authentication; I have heard that others were able to create an old account on the network for which the credentials worked with the auto-scheduler. I don’t know exactly how that works, but perhaps someone who tried can explain that here.


#7

I updated last night. Just before this screen shot.

Thanks for explaining the ‘1’.

I also got the email for authenticating my account, like the others said, so I was really really hoping that this code would work for me like them.


#8

@thebaldgeek I just pm’ed you on a possible workaround I found. Let us know if it works!


#9

well I personally did not create an old account. Just created an account after the Hackspace magazine article and just went and downloaded the auto-scheduler.
tried it out, changed my password to not include any special characters and confirmed the email once I got the mails after first and second run (and authentication failing).
After verifying my email authentication worked and that was it :slight_smile:


#10

@on3rvh Can you post the logs from auto-scheduler please? (if possible run it with -l DEBUG as a parameter)


#11

@pierros sure can, the log is too big to post here (max chars reached :p) but I posted it to pastebin:
https://pastebin.com/S9it5y2T


#12

Looks like i need some help here. Im getting the Authentication failed message. I created the .env in the same folder as the schedule_single_station.py script. At first my pass has a special char. Changed my password to remove that still getting the Authentication failed. Maybe i didnt make the .env file in the correct location?

pi@raspberrypi:~/satnogs-auto-scheduler $ /home/pi/satnogs-auto-scheduler/schedule_single_station.py -s 861 -d 1.2 -P /home/pi/satnogs-auto-scheduler/priorities_861.txt -z
2019-07-15 04:41:33,347 - root - INFO - Requesting information for ground station 861
2019-07-15 04:41:34,149 - root - INFO - Ground station information retrieved!
2019-07-15 04:41:34,244 - root - INFO - Finding all passes for 451 satellites:
100%|██████████| 451/451 [00:22<00:00, 20.49it/s]
2019-07-15 04:41:56,267 - root - INFO - Requesting scheduled passes for ground station 861
2019-07-15 04:41:57,329 - root - INFO - Scheduled passes for ground station 861 retrieved!
2019-07-15 04:41:57,341 - root - INFO - Found 0 scheduled passes between 2019-07-15 04:41:33 and 2019-07-15 05:53:33 on ground station 861
2019-07-15 04:41:57,348 - root - INFO - 3 passes selected out of 39, 2244 s out of 4038 s at 55.586% efficiency
2019-07-15 04:41:57,349 - root - INFO - GS | Sch | NORAD | Start time | End time | El | Priority | Transmitter UUID | Mode | Satellite name
2019-07-15 04:41:57,350 - root - INFO - 861 | | 43881 | 2019-07-15T04:45:15 | 2019-07-15T04:58:01 | 55 | 1.000000 | 7ZsdREe4GuNxhF4dhNTCLS | GMSK4k8 | Sparrow
2019-07-15 04:41:57,351 - root - INFO - 861 | | 40032 | 2019-07-15T05:05:26 | 2019-07-15T05:18:02 | 30 | 1.000000 | 6DQp67crsBzih2LWRGFNFM | BPSK1k2 | QB50P2
2019-07-15 04:41:57,352 - root - INFO - 861 | | 43879 | 2019-07-15T05:40:31 | 2019-07-15T05:52:33 | 26 | 1.000000 | yX2PAJWyj38qPmnxA6on8E | GMSK4k8 | ISAT
2019-07-15 04:41:58,305 - root - INFO - Authentication failed


#13

I just noticed that i cant use this auth since my account is one of the new ones. So we are waiting on the API auth. Is there a way to have a legacy user account created or learn more about the possible workaround?