Hi, I am prepairing my “old” Setup which was made for receiving OSCAR40 @2400MHz

Now I plan to use this setup for receiving an upcoming LEO Satellit around 2403Mhz.
Actually I don’t know a Satellit which is transmitting close to this frequency.
How to test the whole setup from the antenna to SATNOGS e.g. with SATNOGS-monitor?
I have running here a station which works actually in the 2m Band. I can test with different Satellites but only if they are “visible”.
Receiving a Sat which is not in space is not possible with SATNOGS-monitor.
I have here a local source for that band but how to bring SATNOGS-monitor to receive it?
Is there a way to put the monitor in a “transparent” mode?
Any other idea how I could test my setup?
(Static I can receive a source with the converter thats no problem)

1 Like

Apart from challenges in the S-band and 13cm I guess currently the biggest is being able to configure the right RX freq when using a down converter like in your setup.

I need to have a look in the SatNOGS client documentation to see if there is an offset mode option.

In the meantime if you want to have an idea on satellites received in S-band and 13cm, have a look at the transmitters selection visiting the SatNOGS db


frequency offset not supportet yet, as far as I know. it can be done, hardcoded in the flowgraphs or properly implemented but it is some work to be done in at least a few repos.

1 Like

WIP: flowgraphs and client, feel free to try it out. I will probably include these after some testing, in my sa2kng branches that goes into the corresponding docker images.

That sounds good!
I did check all the Sats around 2400 2402 No signal!

Most of us are listening for S-band signals, 13cm is also difficult due to 2.4 wifi.
My S-band cavity only has a 2170 - 2300 bandpass

S-band 2288.5 reception:

RX success! Offset is working!
Just from teh last obeseravtion the META DATA:

radio: {
    name: "gr-satnogs",
    version: "v2.3-compat-xxx-v2.3.5.0",
    parameters: {
        soapy-rx-device: "driver=lime",
        samp-rate-rx: "2e6",
        rx-freq: "2402400000",
        file-path: "/tmp/.satnogs/data/receiving_satnogs_8869684_2024-01-13T09-19-30.out",
        waterfall-file-path: "/tmp/.satnogs/data/receiving_waterfall_8869684_2024-01-13T09-19-30.dat",
        decoded-data-file-path: "/tmp/.satnogs/data/data_8869684",
        doppler-correction-per-sec: null,
        lo-offset: "500000",
        ppm: null,
        rigctl-port: "4532",
        gain-mode: "Settings Field",
        gain: "20",
        antenna: "LNAH",
        dev-args: null,
        stream-args: null,
        tune-args: "OFFSET=2256000000",
        other-settings: "TIA=12,PGA=10,LNA=12",
        dc-removal: null,
        bb-freq: null,
        bw: null,
        enable-iq-dump: "0",
        iq-file-path: null,
        udp-dump-host: null,
        udp-dump-port: 57356,
        wpm: null,
        baudrate: null,
        framing: "ax25"
latitude: 47.212456,
longitude: 7.621808,
elevation: 5,
frequency: 2402400000

As you can see now an OFFSET of 2256.000000MHz is set.
Set in ADVANCED menu under RADIO is the the argument SATNOGS_TUNE_ARGS and here I set OFFSET=2256000000 (offset frequency in Hz).
See the observation
Just at rise may be a short signal from satellite. Announced TX is for July 24 on this frequency, The signal midpass is from my generator coupled over the air on 2402.400 as testsignal. Dopplercorrection >> OK and RX frequnency >> OK.
Does somebody has a list of the parameters that could be set under SATNOGS_TUNE_ARGS??

1 Like