RTL-SDR, VHF Rx's fine but UHF not Rx'ing

Hi Folks,

Problem: VHF via satnogs is fine, UHF is not.

I have an RPi with an RTL-SDR that is freshly updated and have my config all sorted with no problem. I had to set 3 or 4 new items (to use the soapy interface and set the bandwidth but those were all google’able).

We have a separate system to operate the antenna and switches that are working spot on:

I also used a splitter to ‘view’ the signal entering the RTL-SDR and it’s fine.

Things I’ve checked:

  • SDR broken? Nope, I tried the RTL separately on the RPi and it can receive fine on VHF, UHF, and more. Just not in satnogs it seems.
  • RF signal simply not there? Nope, I’ve used a splitter to validate that RF is coming in and it OK.
  • Settings? Hmm. Perhaps! This is where I need help to know where to look! Perhaps I’ve set something wrong.

73s Chris

OK - Have read: It's time to upgrade the software of your stations, again (Oct 7, 2020) and I’ll add I checked the journalctl -f -u satnogs-client.service AND also the SoapyUtil --find too to get me my options.

Again: VHF works fine, just not UHF.

Opssat doesn’t appear to be as functional as it was so it could well not be your system.

I’d try something like spooqy-1 or something else pretty reliable.

Perhaps check through stations close by or with similar set up and see which sats they are decoding successfully.

What antenna are you using?

Thanks @doctorvenables - Yes, it seems it’s on / off. I’ll talk to the team to understand the schedule.

My ants are 28 El X-yagis or custom helicals (large ones): https://www.surrey.ac.uk/surrey-space-centre/facilities/ground-station. Previous OPSSAT recordings have got me a few thousand packets. I’ll attempt to look at something more reliable on the downlink.

My concern is that I’m not even seeing noise. 73s

Similarly here with OPSSAT sometimes hundreds of packets at a pass but recently nothing and thought it was because I’ve only got a self-built UHF eggbeater II and an airspy mini attached to an RPi 4.

As an aside are you related to a Dr Robert Bridges used to teach Maths in Birmingham?

OK, ace - I see OPSSAT evening passes are not good. But the early AM ones are. I’ll retry tonight and report back.

I don’t think I’m related to Dr Robert in Birmingham - I’ll have to ask for some of his DNA :wink:

Interesting. Hadn’t really spotted that. Worth a look though!

Can you please post the result from Advanced >> Support here? Thanks!

OK, looking this from a RF perspective, that ISS pass is not ‘good’ at all. The ISS should be incredibly strong with your kind of setup. Instead you can just barely see the packets, and only a few have decoded.

Looking at the observation metadata, your gain is set to ‘null’. I’m not sure what a ‘null’ gain results in with the more recent updates, but I suspect its nothing good.

You should follow this guide to set your gains correctly: https://wiki.satnogs.org/Omnidirectional_Station_How_To#Setting_the_gain

Hi @pierros, @vk5qi! Yes, the ISS should be super loud. It’s usually something silly like 20-30 dB above the noise floor. I didn’t see that gain was null - that must’ve been an artefact from the last update.

Also, I couldn’t ‘fail’ my recent OPSSAT observations. Where’d that button go?

Will report back on Tuesday when I’m at the station. And also post my Advanced >> Support (from the satnogs-config I assume?). 73s Chris

1 Like

ISS is at a lower altitude than most of the cubesats and MUCH higher transmitter power so should be easily received. The CAS-4A and 4B satellites CW beacons are very good VHF targets and not as strong as the ISS. Waterfall passband is wide enough you should also see the lower part of the transponder passband. On UHF, try SO-50 and AO-27 (operating schedule is at ao27.net, basically 4-5 min on timed for N Hemisphere mid-latitudes).

RESOLVED: It was that “null” default setting on the client upgrade. Will calibrate when I’ve a chance (COVID, uni teaching). Good pass using “20” dB gain:


Can someone help me fail some passes? Where did that button go?
They certainly shouldn’t be listed as “bad”.

Thanks folks! 73s Chris

Paging @fredy … another need for a station owner being able to fail observations again.

1 Like

@fredy @pierros - Any chance I can ‘fail’ some passes please?

My switches keep failing meaning the LNA turns off - the passes are not good, and not bad.

73s C

There is an active discussion currently between developers for the future of the vetting and there will be a public proposal soon. This will take into consideration the ability of station owners to mark their station as non-functional for a period in the past which will affect the status of observations performed during that period.