RTL_biast- only works from within /rtl_biast/build/src directory

Newbie here, trying to get pre and post observations script to turn on/off lna. I have followed the wiki on installing rtl_biast. I can manually turn the lna on and off but only from within the home/pi/rtl_biast/build/src directory by typing ./rtl_biast -b 1 (or 0). If I try from any other directory using /home/pi/rtl_biast/build/src/rtl_biast -b 1, I get an error that says “/home/pi/rtl_biast/build/src/rtl_biast: symbol lookup error: /home/pi/rtl_biast/build/src/rtl_biast: undefined symbol: rtlsdr_set_gpio” I have tried manually setting the gpio to 0 in the command with no luck. Without this working, I cannot set up pre and post observations scripts to turn the lna on/off. Appreciate any help.

I’d try a

sudo make install

from that build directory to get the binaries/libraries/includes installed properly in /usr/local.

Then go from there.

Thanks for the reply. I tried your suggestion, but just get errors. Something must be wrong with how I installed rtl_biast, but I followed the wiki exactly. The rtl_biast is in the /home/pi directory. Is that correct? Really frustrated as everything will be done once I get the pre/post observation scripts working.

Yes, that is correct.

Looks like make is trying to ‘cd’ into a non-existent directory (/rtl_biast/build instead of /home/pi/rtl_biast/build).

I would start over and reinstall rtl_biast and see if that resolves the issue

As the default user (not su or root) remove the rtl_biast directory with

cd ~
rm -rf ~/rtl_biast

then install from scratch

git clone https://github.com/rtlsdrblog/rtl_biast
cd rtl_biast
mkdir build
cd build
cmake ..
sudo make install

Scott (MAUSyagi)

Thank you! :grinning: Had to delete the directory with sudo, but now everything is working as it should. I think whoever installed the rtl_biast (a student) maybe wasn’t logged in correctly. Thanks again, AV (RHOK-SAT)

1 Like