Rotator Un-Winder Utility

Hello All.

Being new at this I’ve been working my way around the software for the last few weeks and just want to know if anyone is using the Rotator Un-Winder Utility I’ve followed the instructions on Github and wrote my script file ( made it executable put it in the post script but not sure i have the format correct. SATNOGS_POST_OBSERVATION_SCRIPT /home/pi/

The Script runs 100% with $ bash when executed from PuTTY so i at least know it’s good that way.

Any examples of how you’ve entered post script command would be great.


Is this script executable? e.g. chmod +x

You should be able to run it with ./

Mark VK5QI

The Script runs fine but doesn’t seem to run after an observation with the way i have it entered in SatNOGs Post Script. SATNOGS_POST_OBSERVATION_SCRIPT` /home/pi/


pi@raspberrypi:~ $ ./
2021-01-28 08:09:03,778 DEBUG:Starting new HTTPS connection (1): network.satnogs .org:443
2021-01-28 08:09:04,532 DEBUG: “GET /api/observat ions/?ground_station=1920&status=future HTTP/1.1” 200 12670
2021-01-28 08:09:04,545 INFO:Next observation (#3557191) rises at 16.0 degrees, in 80.2 minutes.
2021-01-28 08:09:04,548 INFO:Attempting to move to target position: 16.0, 5.0
2021-01-28 08:09:04,846 DEBUG:Target position: 50.0, 5.0
2021-01-28 08:09:08,126 DEBUG:Current position: 128.0, 5.0
2021-01-28 08:09:11,421 DEBUG:Current position: 107.0, 5.0
2021-01-28 08:09:14,701 DEBUG:Current position: 87.0, 5.0
2021-01-28 08:09:17,996 DEBUG:Current position: 67.0, 5.0
2021-01-28 08:09:21,164 DEBUG:Current position: 49.0, 5.0
2021-01-28 08:09:21,164 INFO:Movement successful!
2021-01-28 08:09:21,371 DEBUG:Target position: 16.0, 5.0
2021-01-28 08:09:24,651 DEBUG:Current position: 36.0, 5.0
2021-01-28 08:09:27,850 DEBUG:Current position: 16.0, 5.0
2021-01-28 08:09:27,851 INFO:Movement successful!
2021-01-28 08:09:28,026 INFO:Finished moving to target position.
2021-01-28 08:09:28,058 INFO:Elapsed time: 23 seconds
pi@raspberrypi:~ $

It might still be a permissions issue. The post-observation script is being run at the satnogs user, not as the pi user.
Can you post the actual contents of the script?

#!/usr/bin/env bash

python3 /home/pi/ --home_azimuth=0.0 --home_elevation=5.0 --station_id=1920

Thanks for the replay and above is the contents of the bash file.


When ever i make a change in the SatNogs Setup and apply it i get this output which seems to point to the Ansible so i might of broken something along the way :frowning: but it’s still running observations just fine.

Traceback (most recent call last):
File “/var/lib/satnogs-config/bin/satnogs-config”, line 8, in
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/”, line 29, in main
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/”, line 258, in show
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/”, line 463, in _apply
if[settings.ANSIBLE_PLAYBOOK], tags=tags):
File “/var/lib/satnogs-config/lib/python3.7/site-packages/satnogsconfig/helpers/”, line 42, in run
[‘ansible-playbook’] + args, cwd=self._ansible_dir, check=True
File “/usr/lib/python3.7/”, line 472, in run
with Popen(*popenargs, **kwargs) as process:
File “/usr/lib/python3.7/”, line 775, in init
restore_signals, start_new_session)
File “/usr/lib/python3.7/”, line 1522, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘ansible-playbook’: ‘ansible-playbook’

Hi All.

I’m still looking for your HELP!!! with this as it’s still NOT running the post script after the observation and I’d like to get it working with your help.
Being new to Pi and Linux it’s doesn’t come easy as yet.


Hi Karl,

I am also very new to satnogs. I’ve been solving the same issue just a week ago. I think I could trace the source of my problems by watching output of journalctl -f -u satnogs-client.service (not sure about this one).

The first problem was that I have installed the requirements python-requests python-dateutil using pip. That way it worked for me as a user, but not for other users such as satnogs. The solution was to install it using:

sudo apt-get python-requests python-dateutil

Then there is another problem with /tmp/rotator.log. This is mentioned on the github page. You can either delete the file (and not run the script from bash ever) or chmod it so other user can access too. This will not persist after boot, since the file from /tmp is deleted.


Hi Adam and Welcome to SatNogs.

I the end i wrote a small script to park the rotor at 0 AZ and 90 EL and it’s been running for a couple months now with no issues.